Search found 36 matches

by anarchogeek
Sat Aug 06, 2005 1:20 pm
Forum: Bugs and Problems
Topic: bz in window bugger
Replies: 8
Views: 4111

For some reason I've hear that a non-SDL build will cause some key mappings to not work. I've read that somewhere in the forums... but am not entirely sure. That is entirely correct. Tell us more about where you got this BZFlag build. Did you compile it yourself, or did you download it? What versio...
by anarchogeek
Fri Jun 24, 2005 9:42 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: F4 and F1 do not work
Replies: 7
Views: 2848

I use the NVidia driver too. I had my gl.h under /usr/include/GL, but I also now have everything under /usr/X11RC/include/GL. I also reinstalled the latest SDL from source. gle.h gl.h glxext.h glxint.h glxproto.h osmesa.h glext.h glu.h glx.h glxmd.h glxtokens.h are all the files in the said director...
by anarchogeek
Fri Jun 24, 2005 9:02 pm
Forum: Help: Source Code / Compiling / Development
Topic: Can't build client
Replies: 0
Views: 2081

Can't build client

configure returns these messages: configure: WARNING: could not find a curses library, will build bzadmin without curses checking for SDL framework... no checking for sdl-config... /usr/bin/sdl-config checking for SDL - version >= 1.2.5... yes configure: WARNING: adns seems to not be available on yo...
by anarchogeek
Fri Jun 24, 2005 8:44 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: F4 and F1 do not work
Replies: 7
Views: 2848

Exactly right.. SDL is not enabled in this build.

Code: Select all

BZFlag client 2.0.2.20050330-STABLE-linux-gnu (protocol 0026) http://BZFlag.org/
Copyright (c) 1993 - 2005 Tim Riker
Should I just figure out how to build my own? With those errors it won't build the client.
by anarchogeek
Fri Jun 24, 2005 8:27 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: F4 and F1 do not work
Replies: 7
Views: 2848

What OS? Are you using an SDL enabled version of bzflag? Good Lord you responded fast. SuSE 9.1 Relatively fresh install. I used an RPM install of BZFlag, since the normal compilation wouldn't make a client. configure returns this: configure: WARNING: could not find a curses library, will build bza...
by anarchogeek
Fri Jun 24, 2005 8:22 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: F4 and F1 do not work
Replies: 7
Views: 2848

F4 and F1 do not work

I can't seem to use F1 and F4. I normally use F4 constantly, so this is a bit depressing :D. I can still take screenshots (F5) and shut down (F12). Any clue where I might look, or what further info you need? This system is running a fresh SuSE 9.1 install (plus the extra packages I installed that DT...
by anarchogeek
Fri Jun 03, 2005 8:42 pm
Forum: Bugs and Problems
Topic: Server Can't Connect
Replies: 0
Views: 2052

Server Can't Connect

This is really starting to bug me. On FC3, I am unable to run self-compiled versions of BZFlag. When I do, it can't connect to the list servers. Reportedly, the gethostbyname() function no longer works with the latest glibc libraries. Naturally, the RPM's work fine. The issues began when I did an sy...
by anarchogeek
Fri Jun 03, 2005 2:25 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

If I upgraded to GCC 4 might the bug go away? This all seems to be in the library versions... Perhaps downgrade?
by anarchogeek
Fri Jun 03, 2005 2:48 am
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

OK, so according to that thread, BZFlag is calling a deprecated function which no longer works with the latest C++ libraries. So, are the devs going to fix it, or is it still somehow my fault? :lol-old:
by anarchogeek
Thu Jun 02, 2005 7:10 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

The RPM does work. Quite frankly, I hate version 2.0.2 :lol-old:. I can't have "smooth" turned on because it breaks radar, and I don't have my shot meter or any of the other new features. It just makes me feel empty inside. ;) After reinstalling the c-ares and c-ares-devel packages and ins...
by anarchogeek
Thu Jun 02, 2005 2:35 am
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

Major clue: In the older version of the game, I'm not able to log into servers by entering normal addresses. HOWEVER, if I enter in the IP address, I AM able to log in. This means I'm still at a loss with the server list though. Also, that's grossly inconvenient. For some reason, the CVS version wil...
by anarchogeek
Wed Jun 01, 2005 11:10 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

Can you surf the internet on that machine? Or is just the program screwed up? My Internet connection is fine. I'm posting these things from the machine in question. Some additional notes: -- I've reinstalled curl and curl-devel. Do I have to do make clean etc. to see if this works? The packages cla...
by anarchogeek
Wed Jun 01, 2005 10:58 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Connection Issues
Replies: 7
Views: 3347

Connection Issues

OK. My connection to the Internet is great. Lately, I've been messing around with the display drivers and some system permissions. Anyway, and again my normal Internet connection is fine, I am unable to connect to the list server or ANY OTHER BZFlag server (by directly entering the information in at...
by anarchogeek
Tue May 31, 2005 1:44 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Fedora Core 3 Performance
Replies: 2
Views: 1664

Thanks a lot. Can you tell I'm still relatively new to Linux? :P
by anarchogeek
Tue May 31, 2005 4:49 am
Forum: Help: Setup / Hardware / Performance Issues
Topic: Fedora Core 3 Performance
Replies: 2
Views: 1664

Fedora Core 3 Performance

I recently switched from SuSE 9.1 to Fedora Core 3. I used the same video drivers on SuSE (from the NVidia site) as I do on the current Fedora Core. I noticed under display settings that I'm not currently being allowed to assign color depth (just gives me resolutions). Do I somehow need to configure...
by anarchogeek
Sat Apr 16, 2005 10:08 pm
Forum: Help: Setup / Hardware / Performance Issues
Topic: Radar Performance Problems
Replies: 9
Views: 3338

I had a similar problem. The problem was initiated on maps with Arcs with ratios and maps with meshes. It always happens under Linux; almost never under Windows. Basically, the radar shows a vast star shaped object centered on the object in question. Usually FPS is in the 1-5 range. Anyway, it's fix...
by anarchogeek
Wed Apr 06, 2005 1:37 am
Forum: Servers: General Discussion
Topic: EAGAIN error
Replies: 14
Views: 5818

Notice, also, that EAGAIN occurs only when someone has been accepted multiple times on the same connection (it appears that a list bot is logged on in the given player number every time someone attempts to logon to that same number). This is marked in blue in my table above. I, therefore, believe th...
by anarchogeek
Tue Apr 05, 2005 11:02 pm
Forum: Servers: General Discussion
Topic: EAGAIN error
Replies: 14
Views: 5818

I'm telling you, it's Windows. There has been a problem with BZFS and it's compatibility with Windows for a long time. The problem hasn't been tracked down yet, so for now BZFS will never be reliable on Windows. Well, we won't get anywhere without people whining about the issues :). Here's a partia...
by anarchogeek
Tue Apr 05, 2005 3:35 pm
Forum: Servers: General Discussion
Topic: EAGAIN error
Replies: 14
Views: 5818

Waistless wrote:funny, i couldn't put in any +f good number without it getting an error....
must be just my machine. :?
ARGG!!! I'm getting it again, but it just happens after more people have joined. Seems about 5 people.
by anarchogeek
Tue Apr 05, 2005 3:06 pm
Forum: Servers: General Discussion
Topic: Global Logins with WIN32 server
Replies: 7
Views: 3241

Global Logins with WIN32 server

Hi, I'm running a server on a Windows XP machine. Having just fixed my EGAIN error, I've discovered an issue with global logons. Nobody is able to use global logons to access my server. Several other WIN32 servers have the same problem, but I've noticed that there are others that seem to work fine. ...
by anarchogeek
Tue Apr 05, 2005 2:12 am
Forum: Servers: General Discussion
Topic: EAGAIN error
Replies: 14
Views: 5818

+f good{40} is the breaking point on my machine. you can use +f good{N}, just keep N reasonable. Excellent. Thanks for the help. Just out of curiosity, why does this vary between operating systems? On Linux, I was able to insert over 200 flags of a particular type with ease, but on Windows I have t...
by anarchogeek
Sat Apr 02, 2005 4:00 am
Forum: Servers: General Discussion
Topic: EAGAIN error
Replies: 14
Views: 5818

EAGAIN error

Hi. I'm running a server on Windows XP (*crowd gasps at Happy Tanker's stupidity*). Anyway, it can only handle one client. It does this: Player Happy Tanker Admin [1] removed at 2005-04-01 22:56:00: Write error EAGAIN if more than one client tries to join. What's causing this? Any more information y...
by anarchogeek
Fri Apr 01, 2005 10:59 pm
Forum: Bugs and Problems
Topic: Material Reference
Replies: 5
Views: 3700

Yes... I've confirmed that this happens only under Windows. The problem has existed, as far as I can tell, from late beta to 2.0.2.
by anarchogeek
Wed Mar 30, 2005 6:55 pm
Forum: Bugs and Problems
Topic: Material Reference
Replies: 5
Views: 3700

what names did you give your materials? In this case, the materials are named mat13 and mat14. Let me give you a similar (but simpler) piece of code that messes it up.. (I've never been able to assign a particular side using material names): material color 0.15 0.58 0.61 1 name mat14 end Arc #name ...
by anarchogeek
Wed Mar 30, 2005 6:59 am
Forum: Bugs and Problems
Topic: Material Reference
Replies: 5
Views: 3700

Material Reference

OK. Now this COULD just be my stupidity. Using the side-specific matrefs, such as: outside matref mat13 inside matref mat14 I can use ONLY the material reference numbers. The above code turns up a bug, stating that the materials cannot be found. A standard "matref" finds it without difficu...