bzflag will not start

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.

bzflag will not start

Postby jsbjsb001 » Tue Dec 27, 2016 9:28 am

I have installed bzflag and get this message below every time I try and run it;

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x298
Serial number of failed request: 157
Current serial number in output stream: 159

I know that the nvidia driver (openGL driver) is loaded and 3D rendering is enabled on my system. I am using PCLinuxOS (installed from software package, in repo) and am using BZFlag client 2.4.2.20130215-MAINT-linux-gnu-SDL (protocol 0221). PCLinuxOS also has all of the latest updates installed.
posting.php?mode=post&f=12#
jsbjsb001
Private
Private
 
Posts: 1
Joined: Tue Dec 27, 2016 9:17 am

Re: bzflag will not start

Postby Bullet Catcher » Thu Dec 29, 2016 5:27 pm

A newer version than BZFlag 2.4.2 may work better. If you can compile version 2.4.8 (the most recent release) and it still doesn't work we can probably help further diagonse the problem.
User avatar
Bullet Catcher
Captain
Captain
 
Posts: 510
Joined: Sat Dec 23, 2006 7:56 am
Location: Escondido, California

Re: bzflag will not start

Postby blast » Fri Dec 30, 2016 1:38 am

It also looks like PCLinuxOS has SDL2, so perhaps building a recent client against SDL2 instead of SDL1.2 may also help.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image
User avatar
blast
General
General
 
Posts: 4475
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx

Re: bzflag will not start

Postby kaadmy » Sun Jan 08, 2017 8:35 pm

What are your video mode specs? Resolution/color depth?
User avatar
kaadmy
Private First Class
Private First Class
 
Posts: 31
Joined: Wed Oct 28, 2015 5:31 pm


Return to Help: Setup / Hardware / Performance Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron