bzflag will not start

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
jsbjsb001
Private
Private
Posts: 1
Joined: Tue Dec 27, 2016 9:17 am

bzflag will not start

Post by jsbjsb001 » Tue Dec 27, 2016 9:28 am

I have installed bzflag and get this message below every time I try and run it;

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x298
Serial number of failed request: 157
Current serial number in output stream: 159

I know that the nvidia driver (openGL driver) is loaded and 3D rendering is enabled on my system. I am using PCLinuxOS (installed from software package, in repo) and am using BZFlag client 2.4.2.20130215-MAINT-linux-gnu-SDL (protocol 0221). PCLinuxOS also has all of the latest updates installed.
posting.php?mode=post&f=12#

User avatar
Bullet Catcher
Captain
Captain
Posts: 534
Joined: Sat Dec 23, 2006 7:56 am
Location: Escondido, California

Re: bzflag will not start

Post by Bullet Catcher » Thu Dec 29, 2016 5:27 pm

A newer version than BZFlag 2.4.2 may work better. If you can compile version 2.4.8 (the most recent release) and it still doesn't work we can probably help further diagonse the problem.

User avatar
blast
General
General
Posts: 4581
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: bzflag will not start

Post by blast » Fri Dec 30, 2016 1:38 am

It also looks like PCLinuxOS has SDL2, so perhaps building a recent client against SDL2 instead of SDL1.2 may also help.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
kaadmy
Private First Class
Private First Class
Posts: 37
Joined: Wed Oct 28, 2015 5:31 pm

Re: bzflag will not start

Post by kaadmy » Sun Jan 08, 2017 8:35 pm

What are your video mode specs? Resolution/color depth?

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Tue Jul 11, 2017 10:03 pm

I'm having this problem on Ubuntu 16.04.2 (latest bz from source). I can start in windowed mode doing

Code: Select all

> bzflag -window 1620x1000 &
to fill the screen all but for the menus and launcher at the resolution I am using, but
  • Accidental F1 = BLAM! (crash, with above message, so I had to unmap that function/key)
  • Can't figure out if there is a config.cfg option that more conveniently sets this on launch
At least it runs quite acceptably.

- gnu-sense

User avatar
blast
General
General
Posts: 4581
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: bzflag will not start

Post by blast » Tue Jul 11, 2017 11:56 pm

Are you using SDL 1.2 or SDL 2.0? Running 'bzflag -version' should indicate either -SDL or -SDL2.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Wed Jul 12, 2017 11:39 am

blast wrote:
Tue Jul 11, 2017 11:56 pm
Are you using SDL 1.2 or SDL 2.0? Running 'bzflag -version' should indicate either -SDL or -SDL2.
Since you point that out, I can see that it probably a/the problem. After checking, and apt-get install, the output of ./configure reports the following:

Code: Select all

checking for SDL... no
checking for sdl2-config... (cached) no
checking for SDL - version >= 2.0.3... no
*** The sdl2-config script installed by SDL could not be found
*** If SDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SDL2_CONFIG environment variable to the
*** full path to sdl2-config.
checking for sdl-config... (cached) /usr/bin/sdl-config
checking for SDL - version >= 1.2.10... yes
I'm a little non-adept at this part of things. Can you suggest something like flags for ./configure or something to make sure it picks the right libraries?

Thanks,

gnu-sense

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Wed Jul 12, 2017 11:45 am

Okay, nvm...
I rechecked that and found that I needed to install sdl2-dev (which figures). ./configure then reports it is using SDL2.

gnu-sense

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Wed Jul 12, 2017 11:52 am

Okay I'm a pest now. The is the result of make, when thus configured:

Code: Select all

In file included from OpenGLGState.cxx:1605:0:
../../include/bzfSDL.h:24:21: fatal error: SDL.h: No such file or directory
compilation terminated.
Makefile:444: recipe for target 'OpenGLGState.lo' failed
make[2]: *** [OpenGLGState.lo] Error 1
make[2]: Leaving directory '/home/paolillo/Project/BZFlag/bzflag/src/ogl'
Makefile:422: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/paolillo/Project/BZFlag/bzflag/src'
Makefile:482: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
Any idea how to fix the SDL.h header file problem?

User avatar
blast
General
General
Posts: 4581
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: bzflag will not start

Post by blast » Wed Jul 12, 2017 9:14 pm

Did you re-run the ./configure script after installing the sdl2-dev package?
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Thu Jul 13, 2017 1:39 am

Yes, I re-ran configure. The output above is from make after that point; Although it configures claiming it is using SDL2 (see previous message), make cannot locate the header SDL.h (above), which is why I asked my last question.

Thanks for any help.

gnu-sense

User avatar
Constitution
General
General
Posts: 1943
Joined: Wed Mar 01, 2006 5:43 am

Re: bzflag will not start

Post by Constitution » Thu Jul 13, 2017 6:43 pm

Did configure say that it found <SDL2/SDL.h> or not? Maybe do a make distclean, re-run configure, and post the entire output of configure and make here so we can check it out. Thanks.

User avatar
gnu-sense
Private First Class
Private First Class
Posts: 76
Joined: Wed Nov 22, 2006 1:21 am

Re: bzflag will not start

Post by gnu-sense » Thu Jul 13, 2017 8:37 pm

Constitution wrote:
Thu Jul 13, 2017 6:43 pm
Did configure say that it found <SDL2/SDL.h> or not? Maybe do a make distclean, re-run configure, and post the entire output of configure and make here so we can check it out. Thanks.
I did answer this above; yes, configure said it found SDL2, but failed on that header (more than once). I followed your suggestion and captured the output, but posting it is not necessary/useful: this time it compiled. My best guess is that the package updates with apt didn't fully synchronize somehow, and that after some arbitrary event it did.
In any event, it compiles, and it's full-screening like it's supposed to.

gnu-sense

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest