Brightness problem with ATI cards

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
a random tank
Private First Class
Private First Class
Posts: 5
Joined: Wed Feb 21, 2007 6:28 am

Brightness problem with ATI cards

Post by a random tank » Thu Mar 15, 2007 1:01 am

Every time...and mark my words, I want to make this clear. EVERY TIME I run bzflagon a computer with an ATI video card, the screen is too dark. I always have to go into the display options and increase the brightness. Even if I exit the game and reload it, the screen is ALWAYS too dark.

I have tried multiple computers. I seems that only the ATI cards are affected by this brighness bug.

I have tried X300 onboard, X800XL AGP and Rage Pro. All these cards have the brighness problem.
I never have problems with nVidia cards i.e MX440, FX5200, or Intel onboard graphics.

What is being done about this bug? :?:

User avatar
Saber
Private First Class
Private First Class
Posts: 207
Joined: Tue Nov 01, 2005 9:27 pm
Location: ¨¨¨¨¨

Post by Saber » Thu Mar 15, 2007 1:09 am

I got the same problem with my ATI Radeon X1300. I've stopped fixing the brightness because it became a waste of time and I keep playing with my dark screen but it would be nice to fix it.

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Thu Mar 15, 2007 1:10 am

sounds more like an issue with the ATI video drivers, then it does a bug with the bzflag code.

As you state cards that use other drivers work fine.

There is no ATI specific code in bzflag, we simply ask openGL to set the gamma.

I would check and make sure you have the current drivers from ATI, and if so, report the problem to them.

a random tank
Private First Class
Private First Class
Posts: 5
Joined: Wed Feb 21, 2007 6:28 am

Post by a random tank » Thu Mar 15, 2007 1:11 am

How do you play with a pitch black screen?

a random tank
Private First Class
Private First Class
Posts: 5
Joined: Wed Feb 21, 2007 6:28 am

Post by a random tank » Thu Mar 15, 2007 1:14 am

As I recall, ATI has openGL problems. I think they don't support the latest version?

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Thu Mar 15, 2007 1:30 am

bzflag only uses open GL 1.1, it is nowhere near the latest version.

have you verified that you have the current drivers from ATI for your card and OS?

lodxcol
Private First Class
Private First Class
Posts: 64
Joined: Thu Aug 10, 2006 6:13 am

Post by lodxcol » Thu Mar 15, 2007 1:32 am

My MacBook uses an Intel GMA 950 card, and I have the same issue. Though adjusting the brightness does not solve my issue, I have to open a second client, and then close it. Only then does my brightness return to normal.

a random tank
Private First Class
Private First Class
Posts: 5
Joined: Wed Feb 21, 2007 6:28 am

Post by a random tank » Thu Mar 15, 2007 1:43 am

I always use the latest drivers. The problem happens on both XP and SuSE 10.2, same computer (dual boot).

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Thu Mar 15, 2007 4:21 pm

then it would be a bug in the core ATI code. The drivers do share code between OSs.

I would report this to ATI with as much info as you can, our game is free so they can download it to evaluate the problem.

I went over the gamma code last night and didn't see anything that isn't to the openGL spec.

User avatar
Saber
Private First Class
Private First Class
Posts: 207
Joined: Tue Nov 01, 2005 9:27 pm
Location: ¨¨¨¨¨

Post by Saber » Fri Mar 16, 2007 2:08 am

Sometimes, BZFlag crashes and my screen gets very bright, like it is supposed to be but I can't control the crashes and the brightness stays on my desktop when I'm done playing.

User avatar
Triumph of the Soul
Corporal
Corporal
Posts: 294
Joined: Thu Jul 06, 2006 4:32 pm
Location: Minnesota

Post by Triumph of the Soul » Fri Mar 16, 2007 2:28 am

Saber

Here is a link to a dead thread that may help solve your problem, even if I couldn't solve mine. :)
Last edited by Triumph of the Soul on Thu Jun 14, 2007 5:05 am, edited 1 time in total.
Image
Creator @: Duck or Die, Duck or Die CTF, Fuel Stack, Guernica, Normal, Frayed

a random tank
Private First Class
Private First Class
Posts: 5
Joined: Wed Feb 21, 2007 6:28 am

Post by a random tank » Fri Mar 16, 2007 5:12 am

Saber wrote:Sometimes, BZFlag crashes and my screen gets very bright, like it is supposed to be but I can't control the crashes and the brightness stays on my desktop when I'm done playing.
Wow. that happens to me too. I forgot about that one.

Post Reply