Page 1 of 1

slow keyboard motion

Posted: Fri Apr 20, 2007 3:21 am
by hlfmnhlfamazing
I've lately been playing BZ with a gamepad, but the slow motion button (as is usually represented by pressing the "a" key) doesn't affect anything but the keyboard.

I'm not sure if this is an 'issue' per se, or if this belongs in the enhancements folder.

When I wanna snipe I'm getting tired of having to use both the keyboard and gamepad! :-P

Posted: Fri Apr 20, 2007 3:31 am
by A Meteorite
In BZFlag SVN HEAD (2.1), slow motion affects both keyboard and mouse.

I don't know about Gamepads/joysticks, though.

Posted: Sun Apr 22, 2007 1:10 am
by hlfmnhlfamazing
Well that's good that progress is being made on it.

Posted: Sun Apr 22, 2007 1:16 am
by ducktape
I just got one also. you have to open bzflag with your game pad pluged-in and then Options>Input settings>change Key mapping then find the "slow motion" button in the menu hit enter on it and push the key on your gamepad you want the slow motion button to be. hope that helps.

-ducktape

Posted: Tue Apr 24, 2007 3:26 am
by hlfmnhlfamazing
Yeah, I tried that. I set it to key(pad) 7 I think. Nothing.

Maybe it's flaky; only guaranteed to work with the keyboard for the time being. On some keypads it works, on some it doesn't.

Also, you use linux, windows, etc? Dunno if that would change anything or not.

Posted: Wed Apr 25, 2007 2:14 am
by ducktape
I'm in Linux here is my Game Pad: http://www.itreviews.co.uk/graphics/nor ... /h683a.jpg

I'll to to get it to work with mine. ifso I'll try to re-explain it.