Problems with Machine Gun (not very important though)

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
andreas_e93
Private First Class
Private First Class
Posts: 9
Joined: Tue Jan 22, 2008 5:07 pm
Location: Sweden

Problems with Machine Gun (not very important though)

Post by andreas_e93 » Sat Mar 29, 2008 4:36 pm

Hi. I´ve got a problem with the MG flag. As soon as I get the flag, it start shooting, but I don´t press any button. Also, if I use "Wheel scroll down" to shoot, it´s the same thing. Sometimes it work normally. But as the subject says, it´s not a very big problem. Anyone who knows?
andreas_e93

User avatar
tw1sted
Private First Class
Private First Class
Posts: 849
Joined: Tue Feb 21, 2006 10:21 pm

Re: Problems with Machine Gun (not very important though)

Post by tw1sted » Sat Mar 29, 2008 4:38 pm

This happens to me as well, but i always thought that was what the MG flag did. I guess i was wrong ;)

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Post by Spazzy McGee » Sat Mar 29, 2008 5:18 pm

I've had the same problem for ages. I've learned to live with it. May I ask what OS and key mapping you guys are using? Perhaps we can pinpoint it to a specific set up. My key mapping is default, except I have identify and fire mapped to the same key, space bar as jump, and / as drop flag.
"Life is what happens to you while you're busy making other plans." - John Lennon

A Hobo
Private First Class
Private First Class
Posts: 63
Joined: Mon Mar 13, 2006 9:34 pm
Location: Walking the Streets of Life

Post by A Hobo » Sat Mar 29, 2008 11:16 pm

Well, not sure why it does that, but has to do with the mouse scroll. I use "left click" and "mouse scroll" to shoot. Soon as I pick up MG, I click right away which stops it from constant fire. I just keep using left click to fire it.

User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

Post by khazhyk » Sun Mar 30, 2008 1:25 am

For some reason it does this if you have the scroll wheel used as the fire button. Just press the 'other' shoot button (left mouse, i guess?) it stops it.
Image

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Post by Spazzy McGee » Sun Mar 30, 2008 9:59 am

me1 wrote:For some reason it does this if you have the scroll wheel used as the fire button. Just press the 'other' shoot button (left mouse, i guess?) it stops it.
I don't have scroll wheel bound to anything, seeing as I'm on a macbook.

But don't worry, it's stumped me for about a year and a half.
"Life is what happens to you while you're busy making other plans." - John Lennon

User avatar
clarahobbs
Private First Class
Private First Class
Posts: 272
Joined: Thu Jan 10, 2008 1:45 am
Location: The Fourth Dimension

Post by clarahobbs » Sun Mar 30, 2008 4:42 pm

I have the same problem. I use all the default settings for the mouse, except scroll down is shoot, and scroll up is jump.
FKA Ratfink

User avatar
Joe-Schmoe
Private First Class
Private First Class
Posts: 192
Joined: Mon Jul 24, 2006 1:10 am
Location: This field unintentionally left blank.

Post by Joe-Schmoe » Tue Apr 01, 2008 12:23 am

I think I may be able to shed some light on this.

One of the "features" of the MG flag is that it lets you fire constantly. Normally, if you hold down the fire button, you will fire all your shots and then stop shooting, even after they have reloaded. With the machine gun, you can hold down the fire button and you'll keep shooting.

I think what happens is, the game thinks you are still holding down the fire button because there is no "mouse up" signal or something of that nature. It happens to me when I use the scroll wheel (because the game doesn't know I've stopped scrolling) and it goes away when I click (which DOES have a mouse up signal), just like me1 said.

Spazzy: I think this probably has something to do with spawn and fire being the same button, but you've probably already tried changing that. I'm using windows XP BTW.

Of course I may be horribly horribly wrong :D such is life.
Join MI6!

User avatar
macsforme
General
General
Posts: 2023
Joined: Wed Mar 01, 2006 5:43 am

Post by macsforme » Tue Apr 01, 2008 12:46 am

The issue seems to occur right when they pick up an MG flag, even without pressing the fire button.

z[h]ero
Private First Class
Private First Class
Posts: 204
Joined: Mon Jan 31, 2005 12:00 am
Location: hiding behind box...a real Bz coward :/

Post by z[h]ero » Tue Apr 01, 2008 1:10 pm

Constitution wrote:The issue seems to occur right when they pick up an MG flag, even without pressing the fire button.
Yep

I'm a keyboard user. I had the MG issue, too, but happily the problem somehow disappeared on my system. When i had the issue I SIMPLY needed to fire 1 shoot via keyboard to make the MG stop. (Still in my Bz i notice more bugs than in all my Applications alltogether! No joke)
Just on 1 map this was a bit an annoying issue, as a special powerful long range MG was limited to some shoots, and my reaction to stop the MG was often too slow...lol
Wirth's law: "Software is getting slower more rapidly than hardware becomes faster."

quantum dot
Private First Class
Private First Class
Posts: 1286
Joined: Sun May 16, 2004 10:19 pm
Location: Spain
Contact:

Post by quantum dot » Tue Apr 01, 2008 2:28 pm

Constitution wrote:The issue seems to occur right when they pick up an MG flag, even without pressing the fire button.
correct, and it happens to me too although I do not have the wheel mapped to fire. I use the wheel to select a radar zoom or another. I invariably drop MG in no time. I consider it a bad flag because of this bug.

User avatar
macsforme
General
General
Posts: 2023
Joined: Wed Mar 01, 2006 5:43 am

Post by macsforme » Tue Apr 01, 2008 7:40 pm

z[h]ero wrote:(Still in my Bz i notice more bugs than in all my Applications alltogether! No joke)
You are always welcome to fix the bugs you come across and submit patches. There isn't any one person who's assigned to fixing bugs in BZFlag.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest