OS X 10.5.3 and BZ 2.0.10 crashing

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
Cj_
Private First Class
Private First Class
Posts: 9
Joined: Thu Mar 10, 2005 3:53 am
Location: California

OS X 10.5.3 and BZ 2.0.10 crashing

Post by Cj_ » Mon Jun 02, 2008 12:43 am

It specifically has to do with 10.5.3, but ever since the OS upgrade, BZ crashes regularly. Usually about 1-2 minutes into play.

Curious if anyone else is having issues?

Cj

mashny
Private
Private
Posts: 2
Joined: Fri Apr 25, 2008 3:59 am

Post by mashny » Mon Jun 02, 2008 3:35 am

I have 10.5.3 but haven't noticed any problems with BZFlag -- at least not yet. There are known issues with this release though -- here's one of them: http://forums.macrumors.com/showthread.php?t=491285

User avatar
blast
General
General
Posts: 4786
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Mon Jun 02, 2008 7:30 am

Do you get any error message displayed on the screen?
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

Cj_
Private First Class
Private First Class
Posts: 9
Joined: Thu Mar 10, 2005 3:53 am
Location: California

Post by Cj_ » Mon Jun 02, 2008 6:40 pm

No errors, just play freezes and BZ crashes... never happened once before 10.5.3... So I am confidant they are related in "some" way.

Cj

I havent checked the crash log... but it wouldnt mean much to me anyway.
blast wrote:Do you get any error message displayed on the screen?

lol_u died

Post by lol_u died » Mon Jun 02, 2008 9:03 pm

Hey I got this in my e-mail saying about some bug fixes for your OS type and Version.... Check it out... don't know if it helps but here :P
Mac OS 10.5.3 Fixes
By Ted Landau (bugs@macworld.com)

Bugs & Fixes

For Mac users with an interest in tracking bugs and fixes, this past week was one to celebrate. In one fell swoop, dozens of irksome Mac OS X bugs were eradicated, courtesy of the Tuesday release of Mac OS X 10.5.3.
More on Mac OS X 10.5.3

While Apple's official list of what the update addresses provides numerous specifics, it is deliberately vague regarding many of OS X 10.5.3's most important fixes. For example, regarding problems with the Time Machine and Time Capsule combo (as noted in a recent Bugs & Fixes column), Apple states that Mac OS X 10.5.3 "improves reliability" and "fixes compatibility," but does not offer further details as to what these phrases mean. Still, it's good to know that we can expect better performance from these useful backup components.
Read the Bugs & Fixes column on Time Machine

There are also fixes in Mac OS X 10.5.3 that are not mentioned at all in the Apple list. The reach of some of these fixes extends beyond Apple's software to remedy problems with third-party programs. For example, if you own the Drive Genius 2 disk utility, you may have noticed the following text in the Read Me file for version 2.0.2:

"This new release adds preventive measures to help avoid an issue with Leopard (10.5.x) and Serial-ATA based drives. Apple is aware of the problem and is working on a fix. The workaround is to boot from the Drive Genius 2 DVD. If you are trying to repartition, rebuild, repair or defrag a Serial-ATA drive, you must either be booted from the Drive Genius 2 DVD or be running Mac OS X 10.4.x (Tiger)."

The key sentence here is "Apple is aware of the problem and is working on a fix." I have been told that this fix is now included as part of Mac OS X 10.5.3.

Similarly, if you launch the recently released 2.0 update to the Delicious Library cataloging application before installing Mac OS X 10.5.3, you will be greeted with the warning message displayed to the right, urging you to update to Mac OS X 10.5.3 "as soon as you can."

The bottom line: Mac OS X 10.5.3 will not put an end to all bugs -- otherwise I'd be fold up my column. But it promises to be the most significant improvement to Leopard since Mac OS X 10.5's debut last October.

User avatar
Winny
Grouchy
Grouchy
Posts: 2381
Joined: Wed Aug 24, 2005 12:27 am
Location: Ottawa eh?
Contact:

Post by Winny » Mon Jun 02, 2008 9:39 pm

lol_u died wrote:Check it out... don't know if it helps but here :P
Then why don't you use your brain and figure out if it's helpful or not?

That "article" only contains information about what was fixed or updated in 10.5.3, nothing about any problems arising from the update.

So, in the future, think before posting.

lol_u died

Post by lol_u died » Mon Jun 02, 2008 11:54 pm

Chill Winny Chill....

User avatar
Winny
Grouchy
Grouchy
Posts: 2381
Joined: Wed Aug 24, 2005 12:27 am
Location: Ottawa eh?
Contact:

Post by Winny » Tue Jun 03, 2008 12:24 am

lol_u died
If you "don't know", then don't reply to the post, simple as that.


Cj_
I havent had any issues, but I'll keep trying to replicate it.

Try starting BZFlag from the terminal, and see if it prints any errors into it after the crash.

temporal distraction
Sergeant
Sergeant
Posts: 250
Joined: Wed Jan 05, 2005 3:12 pm

Post by temporal distraction » Tue Jun 03, 2008 12:34 am

Winny wrote:Try starting BZFlag from the terminal, and see if it prints any errors into it after the crash.
and you can add levels of debugging when starting the client with " -d -d -d -d " (note that this is different syntax than the debugging levels when starting bzfs)

Cj_
Private First Class
Private First Class
Posts: 9
Joined: Thu Mar 10, 2005 3:53 am
Location: California

Post by Cj_ » Tue Jun 03, 2008 12:58 am

Seems this is happening with other games... and is a driver issue, it seems:

"OS X 10.5.3 Graphics Driver bugs/notes - (From recent Apple open-gl developer mail list posts)
Corrupt textures (shadows) on X1600 with 10.5.3 ("we only see this on non-mipped, driver-compressed RGBA images") - ATI is aware of the issue and noted working on a fix
One developer wrote "the hard lockup our NVIDIA 1.5.24 users were getting is now lessened to a pause/freeze and other erratic blocking behavior for what one of our users is calling "10 seconds" and then resumes. The system.log clearly shows low level graphics exceptions being emitted (NVChannel(GL): Graphics channel timeout and repeating "Graphics channel exception... Fifo: Unknown Method Error" messages)
I also had a reader last week (the day 10.5.3 was released) say he could not run Diablo II after the 10.5.3 update. I wrote to ask he was running the last update for it and if he tried trashing any prefs/cfg file for the game but never got a reply (to date). "

lol_u died

Post by lol_u died » Tue Jun 03, 2008 1:08 am

*RE-EDITED*

Ok sorry....
Last edited by lol_u died on Tue Jun 03, 2008 2:59 am, edited 1 time in total.

User avatar
blast
General
General
Posts: 4786
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Tue Jun 03, 2008 2:31 am

lol_u died wrote:If it's a grapihcs problem... try downloading the newest update for Nvidia..... go to http://www.nvidia.com

and download the correct driver and software for you graphics card and Mac.
Do you ever do any research before posting? Mac users cannot just go there and get a new driver. They have to wait for Apple to release an updated driver for them. He didn't even say that he had an nVidia card. His post mentioned quotes regarding both ATI and nVidia drivers for OSX, so it's possible that even Intel graphics is affected.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

lol_u died

Post by lol_u died » Tue Jun 03, 2008 3:06 am

blast wrote:Do you ever do any research before posting? Mac users cannot just go there and get a new driver. They have to wait for Apple to release an updated driver for them. He didn't even say that he had an nVidia card. His post mentioned quotes regarding both ATI and nVidia drivers for OSX, so it's possible that even Intel graphics is affected.
ok sorry.......

rabbit
Private
Private
Posts: 4
Joined: Wed Jun 22, 2005 11:42 pm

Post by rabbit » Thu Jun 05, 2008 1:24 am

I am on OSX 10.4.11 on an emac G4, ATI Radeon 7500 graphics card.
both bzflag 2.0.8 and 2.0.10 will occasionally crash the computer completely. this only happens on servers with many people and usually more complicated, larger maps, though even GU public maps have crashed when lots of people were present.
I've tried changing the textures setting to "none," this seems to alleviate the problem but (obviously) kills the visual appeal.
I'm not sure if this is related or not to your problem, it's been occurring for a while, though since I upgraded to 2.0.10 more frequently.

Cj_
Private First Class
Private First Class
Posts: 9
Joined: Thu Mar 10, 2005 3:53 am
Location: California

Post by Cj_ » Fri Jun 06, 2008 1:49 am

Agreed, I had seen that on my older machine. Unfortunately, this is happening with a map I frequent. the Only thing that changed was 10.5.3...

everything else the same.

Cj

Post Reply