Page 1 of 1

Tank hangs in the air and won't claim on short ramps

Posted: Fri May 08, 2009 6:43 am
by elaterite
Hi -

Since I rebuilt my box BZFlag acts strange on two maps: Hide-N-Seek Hills and Missile War 2.3 by Ducatiwannabe.

On Hide-N-Seek Hills my tank will hang in the air once I'm above a few hundred feet. It seems the higher I go the longer it will hang before it comes down. I can still move up, shoot, drop the wings flag (but I hang in the air), turn, go forward and backward - I just can't descend. And if I'm fighting and up a long time, once it hangs it never comes down. Also, if I'm sitting on one of the aerial shelves my tank makes tiny little hops as evidenced by the little "dust" clouds.

On Missile War 2.3 by Ducatiwannabe I cannot climb up on the small ramp in the front (center) of the compounds or on the spring ramps that launch you into the air and into your opponents compound. I either have to jump on to them or sometimes I can back up at an angle onto them.

I play Fox Burrow mostly and have no problems on that map. HOWEVER, I have noticed that when I pickup a burrow flag it seems to take a long time for me to fully burrow compared to my older setup.

Any ideas? I've reinstalled the drivers already and have even gone through a kernel upgrade. I've also tried remapping the default "tab" jump key to an alternate on my keyboard. On my old machine I had no problems under Kubuntu 8.04 (Hardy) but all the hardware and drivers were quite different and much older.

System Information:
UBUNTU RELEASE: Kubuntu-8.04.2-desktop-i386 (Hardy)
ARCHITECTURE: Intel x86 32-bit
KERNEL: vmlinux-2.6.24-24-generic
BZFLAG VERSION: (0026) (From Ubuntu repositories)

ASUS P5QC LGA 775 Intel P45 Motherboard
CPU: Intel Core 2 Duo E8400 Wolfdale 3.0GHz
VIDEO: MSI N9800GT-T2D512-OC V2 GeForce 9800 GT 512MB 256-bit GDDR3
STORAGE: Western Digital VelociRaptor WD1500HLFS 150GB 10000 RPM
STORAGE: Western Digital Caviar SE WD2500JB 250GB 7200 RPM

Re: Tank hangs in the air and won't claim on short ramps

Posted: Fri May 08, 2009 1:32 pm
by clarahobbs
Well, I see several possible issues.
  1. Your BZFlag version is old. The latest for Linux is 2.0.12.
  2. Your Ubuntu version is old. The latest is 9.04.
  3. Your kernel is old. The latest version is
  4. Your KDE version is old. The latest version is 4.2.2.
Maybe none of those is the problem, but the old kernel and BZFlag version might be a bit problem-causing.

Re: Tank hangs in the air and won't claim on short ramps

Posted: Fri May 08, 2009 2:57 pm
by blast
It sounds like your framerate is too high. Try hitting 't' while in-game. You should see an FPS reading near the top of the mouse box after a second or two. If it's over 150 or 200, you'll want to limit it. Either turn on vertical sync (sometimes called v-blank or vertical blank - This should limit the FPS to your refresh rate), or turn on the Options > Display Settings > Energy Saver option.

If you use the Energy Saver option, I would recommend adjusting your configuration file to include a higher limit. Look for this line:

Code: Select all

#set fpsLimit 30
And change it to something like:

Code: Select all

set fpsLimit 150
Notice I removed the #, as that is used to comment lines out.

Re: Tank hangs in the air and won't claim on short ramps

Posted: Fri May 08, 2009 6:19 pm
by elaterite
Tanks, blast! That did the trick. I set the vblank to 'on' under the openGL driver setting in the NVIDIA settings tool and it brought the FPS down from 250+ to 56. It was set 'on' as default for the NVIDIA driver, but not the openGL driver. Now I can drive up on those short ramps in Missile War. I have yet to test the Hide n Seek Hills though.

I figured it was one of those simple settings, I just didn't have a clue which one though.

Ratfink - I appreciate your comments but I'm sticking with Hardy as Ibex isn't ready for prime time in my opinion, or at least it doesn't provide the ergonomic GUI interface I'm accustomed to. I really hate searching through menu panels looking for applications. Mostly there's not enough Plasmiods available yet for the applications I use the most. Also, the quick launch section for icons or Plasmiods or whatever is missing.

I haven't tried Jaunty yet so the solution may lie there. But then I've always run older versions as stability is more important to me than having the latest and greatest - and then there's always that learning curve thing that cuts into productivity too.

Thanks for the replies guys/gals!

elaterite (aka Bob)