Wont start

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
jpenguin
Private First Class
Private First Class
Posts: 128
Joined: Wed Jun 11, 2008 11:56 pm

Wont start

Post by jpenguin »

2.0.13 from lucids repo diddn't start, so I downloaded 2.0.16 src, compiled and it still has the same problem. BZFlag worked when I was still on Karmic, but won't work with Lucid

ATI Raadon HD 4890-- yes, glxgears works

Code: Select all

/bzflag-2.0.16$ ./src/bzflag/bzflag
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  130 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0xaa
  Serial number of failed request:  150
  Current serial number in output stream:  152

Code: Select all

$ uname -a
Linux ubuntu 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series
OpenGL version string: 3.2.9756 Compatibility Profile Context
User avatar
blast
General
General
Posts: 4812
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Wont start

Post by blast »

Have you tried running -window'ed?

And are you running the latest driver from AMD?
http://support.amd.com/us/gpudownload/Pages/index.aspx
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image
jpenguin
Private First Class
Private First Class
Posts: 128
Joined: Wed Jun 11, 2008 11:56 pm

Re: Wont start

Post by jpenguin »

I don't know why I didn't try '-window'; it runs!

Looks like I'm one version behind; I have 9-12, newest is 10-3

I can currently play OPL games in fullscreen, but BZFlag only in windowed mod- wierd
User avatar
blast
General
General
Posts: 4812
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Wont start

Post by blast »

After you get it running, you can try setting it to a full screen mode. Options > Display Settings > Change Video Format
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image
User avatar
Cobra_Fast
Dev Monkey
Dev Monkey
Posts: 322
Joined: Sat Oct 07, 2006 11:51 am
Location: Germany
Contact:

Re: Wont start

Post by Cobra_Fast »

This is an old issue that only appears when using ATI cards on linux with the proprietary ATI driver.
User avatar
blast
General
General
Posts: 4812
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Wont start

Post by blast »

I'm almost thinking people have had it happen with the DRI drivers for older cards as well (ones not supported by the proprietary drivers). But I might be wrong.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image
jpenguin
Private First Class
Private First Class
Posts: 128
Joined: Wed Jun 11, 2008 11:56 pm

Re: Wont start

Post by jpenguin »

I upgrade the ATI driver, but it still only works in windowed. At 1280x800 it takes most of my screen (14040x900) Odd that it worked in Karmic with the binary driver. Othe games that use SDL & OpenGL seem to work OK.

I geuss I'll play BZ on my iMac(ATI Radeon x1600)
User avatar
Cobra_Fast
Dev Monkey
Dev Monkey
Posts: 322
Joined: Sat Oct 07, 2006 11:51 am
Location: Germany
Contact:

Re: Wont start

Post by Cobra_Fast »

As long as you are using the official "fglrx" driver from ATI there is a very good chance to have this problem.
You probably were using a community/opensource driver on Karmic then.
jpenguin
Private First Class
Private First Class
Posts: 128
Joined: Wed Jun 11, 2008 11:56 pm

Re: Wont start

Post by jpenguin »

Nope, I used FGLRX


the difference was that I was using KDE, now I use gniome. I even reinstalled KDE & ran bzflag in fullscreen
Post Reply