Issues Installing 2.4.0 on Ubuntu 10.04

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
cepris
Private First Class
Private First Class
Posts: 132
Joined: Wed Dec 01, 2010 6:49 am

Issues Installing 2.4.0 on Ubuntu 10.04

Post by cepris » Sun Jul 10, 2011 11:02 pm

Hi,
I have Ubuntu 10.04 and I am trying to install BZFlag 2.4.0. I am following instructions that Macskeeball gave me earlier: http://my.bzflag.org/bb/viewtopic.php?f ... 77#p157799.

Once I get up to the ./configure step, I get the following result in my Terminal (once it has finished it's business):

Code: Select all

BZFlag-2.4.0.20110710 configured with the following:

             Prefix: /usr/local
           Binaries: /usr/local/bin
            Plugins: /usr/local/lib/bzflag
       Manual pages: /usr/local/share/man

CC       = gcc
CXX      = g++
CFLAGS   = -g -O2
CXXFLAGS = -g -O2
CPPFLAGS = 
LDFLAGS  =  
LIBS     = -lm  -lpthread

Build ares ........: yes
Build curl ........: yes
Build glew ........: no (clients disabled)
Build regex .......: no (using system)
Build zlib ........: yes

BZFlag client .....: no bzflag client binary! (need OpenGL)
BZFlag server .....: yes (with plugins)
BZAdmin client ....: yes

User avatar
blast
General
General
Posts: 4791
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by blast » Sun Jul 10, 2011 11:50 pm

Can you post your config.log file? You may have to rename/compress the file to get it up here. May also want to glance over the file and make sure nothing "confidential" is in there. (Can't recall all that goes in there)
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

Avatar
Private First Class
Private First Class
Posts: 132
Joined: Sun Sep 18, 2005 9:28 pm

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by Avatar » Mon Jul 11, 2011 1:08 am

Just from a cursory glance of your .configure output, it seems you're having an issue compiling the player client? That's the only thing I'm seeing not being made, and it appears to be because the script isn't detecting OpenGL support...?
And the lesson for tonight is:

Never underestimate the ability of a newb to expect instant success and cry "cheat!" when they don't get it. Don't hate the newb, just give them plenty of learning opportunities. ;)

User avatar
blast
General
General
Posts: 4791
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by blast » Mon Jul 11, 2011 1:27 am

There are many reasons why our configure script could think that OpenGL support is not there. It won't be clear why until we see the config.log file as that will show what tests are failing.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

ChCh
Private
Private
Posts: 4
Joined: Thu Jun 30, 2011 11:26 pm

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by ChCh » Mon Jul 11, 2011 4:36 pm

I'm having exactly the same issues as wildrune11 (same distro) and have posted the .configure output here with the config.log file.

Hope someone can help.

Chch
Attachments
configlog.txt
The log file.
(234.56 KiB) Downloaded 126 times
output.txt
./configure output.
(59.22 KiB) Downloaded 134 times

User avatar
Bullet Catcher
Captain
Captain
Posts: 556
Joined: Sat Dec 23, 2006 7:56 am
Location: Escondido, California

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by Bullet Catcher » Mon Jul 11, 2011 5:46 pm

ChCh, you do not have the g++ compiler installed. It looks like the name of the package in Ubuntu is simply g++, so install that, do a make distclean command, and run configure again.

cepris
Private First Class
Private First Class
Posts: 132
Joined: Wed Dec 01, 2010 6:49 am

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by cepris » Mon Jul 11, 2011 10:02 pm

I'll try what Bullet Catcher has said and if I still fail to install then I will post my config file :) What will the make distclean command do?

homebrewer
Private
Private
Posts: 1
Joined: Thu Apr 27, 2006 1:04 am

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by homebrewer » Tue Jul 12, 2011 12:33 am

I had the same trouble you are describing at first. I had to install lots of packages through synaptic; all I can suggest is you look through the config.log and try to knock down all its complaints.

Now, I get the client to compile but it has no sound support. config.log claims I have no SDL files, but the headers are right there (in /usr/include/SDL) where they should be and so is sdl-config (in the path). So I'm stuck.

User avatar
blast
General
General
Posts: 4791
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by blast » Tue Jul 12, 2011 1:32 am

Note that you can't satisfy ALL of the tests that fail in config.log, since some of them are testing platform specific code. For instance, Mac OSX has the OpenGL header in a different spot compared to Linux.

As per README.Linux, ensure that you have the following installed:
libgl1-mesa-dev
libglu1-mesa-dev
libsdl1.2-dev
libcurl3-dev
libsdl-sound1.2-dev
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

ChCh
Private
Private
Posts: 4
Joined: Thu Jun 30, 2011 11:26 pm

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by ChCh » Tue Jul 12, 2011 6:04 am

As per Bullet Catcher's advice above, I installed the g++ compiler and everything worked fine.
Bullet Catcher wrote: you do not have the g++ compiler installed.

All the libraries I required I installed (including g++ once I knew it was missing) using apt and had no other problems or download required.

Thanks all.
:D

User avatar
[honc]
Private First Class
Private First Class
Posts: 31
Joined: Tue Dec 06, 2011 2:48 am
Location: europe
Contact:

Re: Issues Installing 2.4.0 on Ubuntu 10.04

Post by [honc] » Tue Dec 06, 2011 2:53 am

This was a very helping me to get the game to run !!

Finally !

Thanks a lot
may the tool's be with you

Post Reply