No sound Ubuntu11 64-bit bzflag 2.4 install

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
User avatar
range-target
Private First Class
Private First Class
Posts: 21
Joined: Sat Dec 24, 2005 2:54 am
Location: Houston, Republic of Texas (formally of the USA)

Re: No sound Ubuntu11 64-bit bzflag 2.4 install

Post by range-target » Sat Aug 13, 2011 4:59 pm

here is the output of 'bzflag -version':
bzflag -version
BZFlag client 2.4.0.20110811-STABLE-linux-gnu (protocol 0221) http://BZFlag.org/
Copyright (c) 1993-2011 Tim Riker

I suppose the lack of SDL showing brings me back to my ./configure. When I grep for SDL my config.log file, it shows the following:

configure:18020: checking for SDL/SDL.h
configure:19634: checking for SDL framework
configure:19650: gcc -o conftest -g -O2 -framework SDL conftest.c -lGLU -lGL -lm -lpthread >&5
gcc: SDL: No such file or directory
| #include <SDL/SDL_version.h>
configure:19746: checking for SDL - version >= 1.2.10
configure:19920: WARNING: could not find an appropriate SDL version. BZflag will build without SDL
ac_cv_header_SDL_SDL_h=no
ac_cv_path_SDL_CONFIG=no
HAVE_SDL_FALSE=''
HAVE_SDL_TRUE='#'
SDL_CFLAGS=''
SDL_CONFIG='no'
SDL_LIBS=''

That warning message 19920 seems to indicate SDL won't be used for the build. And, a few lines before that message, it looks like the call to the c++ compiler looking for an appropriate SDL framework is failing. I commented on this same observation back in my 2nd post in this thread. all (user-ID) recommended the need to install the libsdl1.2-dev package which has since then been confirmed as installed.
I drive, I shoot, I jump, I die. Pretty simple stuff...

Will admin for food! May Tux bless you.

anomaly
Private First Class
Private First Class
Posts: 220
Joined: Tue Jul 26, 2005 10:32 pm
Location: Gainesville Florida

Re: No sound Ubuntu11 64-bit bzflag 2.4 install

Post by anomaly » Sat Aug 13, 2011 9:59 pm

at this point you should try

Code: Select all

sdl-config --cflags --libs
your output should look something like this:
-I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT
-L/usr/lib -lSDL


If it does then you might do a make distclean and then ./autogen.sh
I can't remember if bzflags autogen will also run configure or not. You may need to run it again manually.
Then try make again. If this doesn't work you may have gotten some corrupted source or something.

User avatar
range-target
Private First Class
Private First Class
Posts: 21
Joined: Sat Dec 24, 2005 2:54 am
Location: Houston, Republic of Texas (formally of the USA)

Re: No sound Ubuntu11 64-bit bzflag 2.4 install

Post by range-target » Sun Aug 14, 2011 8:44 pm

Well, I finally got the SDL to hook-in on my ./configure using the "shotgun" method of installing most all program libraries which seemed remotely related -- about 28 programs total including dependencies. Which one actually fixed it, I don't know. Now, I will hop over to my fedora13 system to see if I can determine why I get an error during make install calling out the airspawn.so .
Thanks.
I drive, I shoot, I jump, I die. Pretty simple stuff...

Will admin for food! May Tux bless you.

angryfirelord
Private First Class
Private First Class
Posts: 23
Joined: Fri Dec 15, 2006 12:29 am

Re: No sound Ubuntu11 64-bit bzflag 2.4 install

Post by angryfirelord » Mon Oct 10, 2011 1:31 am

I had the same issue under Ubuntu 11.10 amd64 and I was able to solve it by using sigonasr2's post.

First, make sure your deb-src sources are enabled. Issue this in the terminal:

Code: Select all

sudo apt-get build-dep bzflag
Then, we need to grab the source code. Anomaly's comment about corruption may be true because when I downloaded it, I couldn't get it to work either. But when I use subversion, it worked. So, install subversion and do this:

Code: Select all

svn co https://bzflag.svn.sourceforge.net/svnroot/bzflag/trunk/bzflag
Change into the directory and run:

Code: Select all

./autogen.sh
It'll ask you about some missing utilities. Install them as necessary and run it again until the errors go away.

After that's done, then issue:

Code: Select all

./configure
Make sure that it builds the client with SDL. If it doesn't have that SDL, then you won't get audio.

After that, run:

Code: Select all

make
sudo make install
Now you should have sound.

Post Reply