Scrambled text in Windows 95

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
RobertB
Private
Private
Posts: 4
Joined: Fri Jun 04, 2004 8:46 pm

Scrambled text in Windows 95

Post by RobertB » Fri Jun 04, 2004 8:56 pm

In the cafeteria at work, they've put in a couple of old PCs with Windows 95. I was able to install BZFlag on each one and run it -- once. After that first session, when I attempt to run, all text is completely scrambled, with what appear to be random graphic elements.

The first thing I did was re-install BZFlag. No luck; same problem. I dinked with the screen resolution settings -- no luck there, either.

I downloaded Ad-Aware, but all it found was Alexa (I got rid of it anyway).

I've tried getting the latest ActiveX (8.0, the highest available for Win95) from Microsoft on both boxes. On one box, I downloaded new Matrox Millenium video card drivers -- they now report that the ActiveX version is too old (doh!).

The boxes are slow and jerky, but not laggy enough to upset anyone. Is there any way to get BZFlag to work on them?

Death Barrel
Private First Class
Private First Class
Posts: 641
Joined: Fri Jan 03, 2003 3:26 am

Post by Death Barrel » Fri Jun 04, 2004 9:18 pm

opengl? do you have it?

elmer fudd
Private First Class
Private First Class
Posts: 109
Joined: Fri May 07, 2004 11:17 pm
Contact:

Post by elmer fudd » Fri Jun 04, 2004 9:37 pm

its called WINDOWS 98!!! even that(ugh) would be an improvment. just get a cracked copy and give it to ur IT dept.
then OPENGL(thats important ppl) THEN MAYBE you will get decent preformance(not scarmbled characters)

User avatar
blast
General
General
Posts: 4746
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Fri Jun 04, 2004 9:39 pm

Hmm..you need to turn off texturing. Also, I assume you mean DirectX, because ActiveX would have nothing to do with this. BZFlag uses OpenGL for graphics, so my guess it that you don't have a video card or drivers that can do OpenGL. If you can run the game, you must have OpenGL.dll, just not hardware acceleration.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

RobertB
Private
Private
Posts: 4
Joined: Fri Jun 04, 2004 8:46 pm

Post by RobertB » Fri Jun 04, 2004 9:44 pm

Death Barrel wrote:opengl? do you have it?
Actually, that's what I was trying to do when I reloaded the Matrox drivers. The OpenGL site said that each card mfg implements OpenGL in its own way, so you have to go through them. Any hints on how I should make sure I have the latest & greatest Win95 OpenGL for the hardware?

(If it's not painfully obvious by now, I haven't given much thought to graphics since the late '80s!)

As far as upgrading to Win98: yah, dats funny. I'm still afraid I'll get spanked for installing BZFlag in the first place, and you're telling me to slip the IT guy a bootleg Windoze CD? No thanks, I find employment in the IT industry to be a Good Thing, as opposed to the excitement of "Would you like fries with that?"

RobertB
Private
Private
Posts: 4
Joined: Fri Jun 04, 2004 8:46 pm

Post by RobertB » Fri Jun 04, 2004 10:05 pm

blast wrote:Hmm..you need to turn off texturing. Also, I assume you mean DirectX, because ActiveX would have nothing to do with this. BZFlag uses OpenGL for graphics, so my guess it that you don't have a video card or drivers that can do OpenGL. If you can run the game, you must have OpenGL.dll, just not hardware acceleration.
Oops, yeah that should have been DirectX.

How do I turn off texturing without being able to read the text on the configuration screen?

elmer fudd
Private First Class
Private First Class
Posts: 109
Joined: Fri May 07, 2004 11:17 pm
Contact:

Post by elmer fudd » Fri Jun 04, 2004 10:36 pm

lol
1st: i missed the at work part

2nd: we dont know what model/how old the vdeo card is so we cant really help in a pecific way.

3rd: are cracked copies of win98 even bootleg anymore? microsoft doesnt even support it anymore...

4th: Start -> Find -> Files or Folders... -> find OpenGL.dll

User avatar
blast
General
General
Posts: 4746
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Fri Jun 04, 2004 10:44 pm

He has OpenGL.dll, or else he wouldn't be able to launch the program.

To turn off the textures, start notepad and open:
C:\my documents\my bzflag files\bzflag19.bzc

Then search for the "set texture" line, remove it, and save. Run the game and it should fix it. Also, as elmer said, could you give us the exact model of your video card so we can determine if it even supports OpenGL?
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

RobertB
Private
Private
Posts: 4
Joined: Fri Jun 04, 2004 8:46 pm

Post by RobertB » Fri Jun 04, 2004 11:38 pm

w00t!

I found the file and deleted the offending line. No effect. Doh!

So I renamed the file and ran BZFlag. Success! It works! I didn't have much in the way of settings
I couldn't live without, anyway -- just swapping "jump" and "drop flag".

Now to do something about the 200ms lag. :)

elmer fudd
Private First Class
Private First Class
Posts: 109
Joined: Fri May 07, 2004 11:17 pm
Contact:

Post by elmer fudd » Sat Jun 05, 2004 12:01 am

200 isnt so bad
what fps do you have?

Post Reply