Page 1 of 1

[solved] config file key mapping in mac os x 10.9 mavericks

Posted: Mon Jan 13, 2014 9:04 pm
by leviathan
hey all,

chesval is coming soon, and it has a different world size than usual ducati maps. So i wanted to adjust my radar zoom keys. but strange things happen to a process i have done earlier without problems.

this is a line of my current setting in the config.cfg:

bind 1 down "set displayRadarRange 0.25"

when i open the config file (the bzflag client is closed) i alter the number 0.25 to 0.3.
when save, close the texteditor, open bzflag and hit "1" in any server, nothing happens.

so i return to the config file and the line is missing now. also the in-game key mapping list says "not-mapped".

any thoughts would be helpful!
which information/log files can i provide to help look for the cause? i am on mac OS 10.9.1

thanks in advance!
all the best,

edit: it is enough to just open and close bzflag to cause this
edit: i also tried switching the texteditor

Re: config file key mapping

Posted: Mon Jan 13, 2014 11:10 pm
by macsforme
My config has these lines:

Code: Select all

bind 1 down "set displayRadarRange 0.03"
bind 2 down "set displayRadarRange 0.25"
bind 3 down "set displayRadarRange 0.45"
bind 4 down "set displayRadarRange 1"
So modifying the bindings should work. Did you try a different value?

Re: config file key mapping

Posted: Mon Jan 13, 2014 11:48 pm
by blast
There is also the in-game slash command /bind that should let you do the same stuff. Just send /bind and it should give you examples of how to use it.

Re: config file key mapping

Posted: Tue Jan 14, 2014 10:35 pm
by leviathan
hey consti and blast

my guess is that this has something to do with mac OS X's feature called "versions" which is some kind of autosave for the texteditor. Also apple introduced a feature called "lock" which somehow prevents other applications do modify a file or at least displays an alert if it happens.
I recently updated to OS 10.9 and I did not have this problem before, so..

I'll just run through apple related forums and try to find out more or even try to disable these features via the terminal.

consti: I tried different values yes. no effect. strangely, when I copy one of these lines, e.g.

bind 2 down "set displayRadarRange 0.25"

I can alter 2 to 1 successfully. radar on key 1 is then 0.25 but altering the value the lines disappears again..

blast: /bind 1 down "set displayRadarRange 0.01" shows me no error, so I guess it worked. but no effect :)

anyways guys: as I wrote up there: this problem seems to be not bz-related, I can't expect more help here, really!
If I find a solution I'll post it here, maybe there are other Mac users I can make happy :)

all the best and thank you guys,

Re: config file key mapping

Posted: Wed Jan 15, 2014 6:57 am
by alfa1
It could be serveral things, IMO... Suggestions, in order:

1 - It seems silly but it is necessary: be sure that the file is really modified after you save it (maybe, there is a failure in the system/editors). Close the editor, open it, open the file and check it. Then, close it again. Always, without BZ running.

2 - Operating system: you say that you updated the system recently but, was it a fresh installation or you just did an upgrade (maintaining the previous configuration, file system, BZ installation, etc.)? I recommend doing the first, backing up all before, OFC. It is cleaner, in general.

3 - BZFlag: unistall it completely. After this, if you see some files/folders persisting, delete them manually. Then, Install it again (a fresh installation too, don't use previous files/folders).

If all these don't work, it would seem that BZ doesn't read and/or overwrites the config file each time you use it, with its default values. According to my experience, when you start BZ, it finds its config folder/files and reads the configuration. If they don't exist, it creates them, using the default values. When you quit it, it saves all of the configuration (because it could have changed). Then, as it seems that you are using the same BZ version that previously worked, it would be an op. system/BZ incompatibility, or only the system would be defective, as you say. (If it is a new BZ version, try the previous one.)

Re: config file key mapping

Posted: Wed Jan 15, 2014 12:52 pm
by macsforme
You could also use a command-line text editor.

Re: config file key mapping

Posted: Wed Jan 22, 2014 4:17 pm
by kajo
hi levi
Im experiencing the same. Cant modify my config. Everytime I type in a new command and save it, it has not effect on BZflag when launching. Afterwards when looking on my config, the line I just typed in has gone...

I had the bad idea of deleting my config thinking it would refresh itself... well, it's now gone and I can't launch Bzflag anymore. Tried out downloading a new version, still not working...
poor apple

Re: config file key mapping

Posted: Thu Jan 23, 2014 12:07 am
by blast
Perhaps try renaming the entire 'BZFlag' folder in your application support folder and see run the game to see if it creates a new folder. Maybe there's a permission issue with the current folder.

Re: config file key mapping

Posted: Thu Jan 23, 2014 1:08 am
by kajo
Unfortunately, that doesn't work either. Tried deleting it and re-downloading it, and it does rebuild the application Bzflag folder, but the folder only contains the cache data - no new config

Nevermind, restarted my Mac and re-downloaded it. Got an all fresh BZflag folder with config etc, launching works too.

Re: config file key mapping

Posted: Thu Jan 23, 2014 7:03 pm
by leviathan
Happy to hear I'm not alone with this.

just ran another series of tests, while writing a pretty long post here, when I got a reproduceable success!

Download another texteditor (I got "Textwrangler"), close the client, open the config with that app and alter your lines. Save, quit and restart bz, works.
I could swear that I had no positive result with this test, when I first tried it some days before chesval, but that method works now.

My resumé of this whole episode: My guess is that bzflag still uses a relatively old code, or is written in a rather old programming language. The new mac system can't handle the way the bzflag client grabs information from the config file when it's being started. An indication for that is the message that appears when i try to save the config after an alteration: "do you really want to save? Another application made changes to your file". Since I turned off autosave for the appe texteditor, I can exclude that feature to be the cause, though.

Happy config alteration, again (although I never did anything else there than applying radar changes and setting up hotkeys) !

Thanks to all contributors in this thread.
See you in-game!

Re: [solved] config file key mapping in mac os x 10.9 maveri

Posted: Fri Jan 24, 2014 10:39 am
by kajo
Works for me too! Thanks for the recommendation.