Bzflag won't launch in the latest Ubuntu 14.xx

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
User avatar
yarro
Private First Class
Private First Class
Posts: 77
Joined: Sat Oct 23, 2004 3:51 pm
Location: NH, USA

Bzflag won't launch in the latest Ubuntu 14.xx

Post by yarro » Sun Oct 19, 2014 10:25 pm

I get this error when trying to launch form the terminal:

~$ bzflag
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 153 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x2b7
Serial number of failed request: 191
Current serial number in output stream: 193

Any ideas? I tried re-installing and deleting relevant config and other files.

yr00

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Re: Bzflag won't launch in the latest Ubuntu 14.xx

Post by JeffM » Mon Oct 20, 2014 1:01 am

it is more then likely your video driver setup, this usually happens on linux upgrades where the default drivers do not know how to change the fullscreen video mode. I'd make sure you are running the best drivers for your system.

You can also try running bzflag in a window to be sure that the fullscreen mode is the problem, bzflag -window 800x600
ImageJeffM

Avatar
Private First Class
Private First Class
Posts: 132
Joined: Sun Sep 18, 2005 9:28 pm

Re: Bzflag won't launch in the latest Ubuntu 14.xx

Post by Avatar » Mon Oct 20, 2014 5:41 am

This sounds vaguely familiar (maybe a regression?), though that issue didn't really get a definitive fix at the time...
And the lesson for tonight is:

Never underestimate the ability of a newb to expect instant success and cry "cheat!" when they don't get it. Don't hate the newb, just give them plenty of learning opportunities. ;)

Post Reply