Page 1 of 1

using a dns service?

Posted: Sun Jan 12, 2003 7:13 pm
by -353-CAPPY
How do i go about using a dns service to list my server.

every time i go to list my server i just get my ip addy(with no descriptions)

i have to use BZFlag GUI edit because i cant edit using the bzfs propt.

Posted: Sun Jan 12, 2003 7:26 pm
by Fiberchunks
alright -- here we go:

from the command line, you should be able to do this:
<shell prompt> bzfs -p <portnum> -public 'This is a description' -publicaddr '<dnsservicedomain>:<portnum>' [options]

replace <portnum> with whatever port you're using (and make sure that it's specified in the -publicaddr portion of your command line. Replace 'this is a description' with whatever you want your server's description to be. Replace <dnsservicedomain> with whatever domain you've chosen from your dnsservice (note that I am unsure how a dynamic ip assigned by your provider will work, but with a static ip, this works fine. Replace [options] with whatever options you want for your server: number of flags, players, max shots, etc.

There is no reason why you shouldn't be able to run from the command line. So, we need to know some things about your setup:

1. What OS
2. What version of bzflag
3. What is the EXACT command line you're trying to pass off to bzfs?
4. Are you behind a firewall / router? If so, what ports are open?

These things are necessary for us to be able to help you properly.

Let us know.


Posted: Sun Jan 12, 2003 7:46 pm
by -353-CAPPY
the dns i use is a dynamic update client.

i run Win ME
gui edit for bzfs 1.7
run threw port 5155

but i got it working as far as the dns prob

still working on the command propt for the bzfs.exe lol

Posted: Sun Jan 12, 2003 8:02 pm
by Fiberchunks
what you should probably do, is open up an msdos prompt, and type in the bzfs string (all the options and crap) that you want-- instead of creating a shortcut to it. Also, there are known issues with running a bzf server on windows platforms. So good luck.


Posted: Sun Jan 12, 2003 9:54 pm
by JeffM
if your running someting like the dynamic ip thing from "no" then it should work fine. Just put the domain name that you set up with them in the command line like fiberchunchs shows.

Posted: Mon Jan 13, 2003 1:38 am
by Dutchrai
Try ports 5156 and 5157.