Annoying Mac Crash

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Lunarian Moogle
Private
Private
Posts: 4
Joined: Fri Jan 14, 2005 11:50 pm

Annoying Mac Crash

Post by Lunarian Moogle » Sat Jan 15, 2005 12:01 am

Hey, I just downloaded BZFlag 1.10.8 and I am running Mac OS 10.2.8 on a G3 iBook. I mounted the DMG file and dragged BZFlag to my applications folder, and all went well. Unfortunately, when I double click BZFlag, the screen turns black, then goes back to the Finder with an alert window stating that BZFlag unexpectedly quit. This is what I found in my console.log:

Code: Select all

data path is "/Applications/BZFlag-1.10.8.app/Contents/Resources"
data path is "/Applications/BZFlag-1.10.8.app/Contents/Resources"
loading fixedmr
dyld: /Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag Undefined symbols:
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _btowc expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _iswctype expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _mbsrtowcs expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _towlower expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _towupper expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _wcscoll expected to be defined in /usr/lib/libSystem.B.dylib
/Applications/BZFlag-1.10.8.app/Contents/MacOS/BZFlag undefined reference to _wcsft
Jan 14 18:45:22 Umoya crashdump: Crash report written to: /Users/squid/Library/Logs/CrashReporter/BZFlag.crash.log
Umoya is the name of the comp.

Any idea what's wrong?

EDIT: Well, I've discovered that I can play BZFlag fine if I use 1.10.6, but 1.10.8 continues to not work. Oh well, at least I can play the game!

User avatar
learner
General
General
Posts: 270
Joined: Sun May 11, 2003 2:06 am
Location: Maryland
Contact:

incompatible

Post by learner » Tue Jan 18, 2005 1:11 am

BZFlag 1.10.8 is incompatible with OS X 10.2. You'll need to use version 1.10.6 which is feature-wise identical in every regard to 1.10.8. That said, BZFlag 2.0.0 is just released (and will work on 10.2).

User avatar
Timerider
Private
Private
Posts: 1
Joined: Mon Jan 24, 2005 12:44 am

10.2 compatability on 2.0.0

Post by Timerider » Mon Jan 24, 2005 12:53 am

:cry: :( :cry: :( :cry: :(

2.0.0 still doesn't work on 10.2.8.

It just fades out, then quits.

Lunarian Moogle
Private
Private
Posts: 4
Joined: Fri Jan 14, 2005 11:50 pm

Post by Lunarian Moogle » Tue Jan 25, 2005 12:17 am

It has worked for me, your problem apparently doesn't lie in the operating system.

KidRdbz
Private
Private
Posts: 2
Joined: Tue Feb 22, 2005 6:11 pm

Post by KidRdbz » Tue Feb 22, 2005 6:21 pm

:( I have this problem with 2.0.0 too ( I have MacOSX 10.2.8 ), and unfortunatly I don't have administrator access, and can't put the file in the applications folder(don't know if it matters though, got it on my desktop)

It's really frustrating as I played 1.10.6 quite a bit and liked it, and now I can't try the new version :( :?

If someone could help that would be great:)

User avatar
Scorch
Private First Class
Private First Class
Posts: 747
Joined: Thu Sep 30, 2004 12:16 am
Contact:

Post by Scorch » Tue Feb 22, 2005 7:09 pm

I think, just a guess, but i think that you have too low a resolutioin (not sure!). I have a low res 10.2 mac comp and it cant run bz 2.0.0, it starts, it blacks, it fades, it blacks, it fades, then theres just the menu bar for bz.

KidRdbz
Private
Private
Posts: 2
Joined: Tue Feb 22, 2005 6:11 pm

Post by KidRdbz » Tue Feb 22, 2005 10:07 pm

What resolution might it need then? I'm at 1024 X 768. :?:

Thank you :)

User avatar
Flash
Private First Class
Private First Class
Posts: 7
Joined: Fri Feb 25, 2005 8:55 pm
Location: Colorado

Crash on 2.0 too

Post by Flash » Fri Feb 25, 2005 9:02 pm

I've been playing 2.0 for a little while, and now it decides to crash on me at some point. My console log offers this:

Code: Select all

data path is "/Applications/Games/BZFlag-2.0.0.app/Contents/Resources"
  % Total    % Received % Xferd  Average Speed          Time             Curr.
                                 Dload  Upload Total    Current  Left    Speed

100   395    0   395    0     0    208      0 --:--:--  0:00:01 --:--:--     0
100   395    0   395    0     0    208      0 --:--:--  0:00:01 --:--:--     0
WARNING: player already exists at location with id 35
WARNING: player already exists at location with id 35
WARNING: player already exists at location with id 35
Hardware: Powerbook G4, MacOS 10.3.8

Any ideas?

User avatar
DTRemenak
General
General
Posts: 625
Joined: Thu Jan 16, 2003 4:54 am
Location: U.S.
Contact:

Post by DTRemenak » Sat Feb 26, 2005 1:07 am

That is a known bug that has been fixed in CVS. If you're comfortable compiling things, you can build a client from anonymous cvs (there are threads elsewhere about that); if not, wait for 2.0.2.

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 6:25 am

I have not been about to run 2.0 either. having the same, open, fade to black, app crash. Powermac G4, 10.3.8, Rage 128 Pro. I really hope this issue can get resolved.
Customize your client at http://bzflag.yamsp.com

User avatar
EbErT
Private First Class
Private First Class
Posts: 16
Joined: Wed Jan 19, 2005 1:49 am
Contact:

mac resolution problems

Post by EbErT » Mon Feb 28, 2005 3:54 pm

Try different resolutions if you are getting a black screen and then it crashes, but as others have said, if you have mac 10.2, make sure you are not using version 1.10.8 of bzflag. I recommend downloading 2.0 and giving that a try, especially if you have a higher-end mac that can handle the graphics. Many bugs including one I had trouble with (total keyboard lockup) have been fixed in this version. Note that it is not compatible with 1.10 versions of bz and those maps will not run on it.

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5184
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Mon Feb 28, 2005 5:46 pm

the rage128 card has VERY little ram, most macs don't have enough ram to run openGL double buffered mode (the mode bzflag asks for) at a res higher then 640x480. The other problem is the card is realy dumb, it tells us we can have resoultions that it can't do. this is why you can pick reses that give you black. Edit your config and set the res down to 640x480, or use the -window -geometry 640x480 command line option.

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 7:09 pm

JeffM2501 wrote:the rage128 card has VERY little ram, most macs don't have enough ram to run openGL double buffered mode (the mode bzflag asks for) at a res higher then 640x480. The other problem is the card is realy dumb, it tells us we can have resoultions that it can't do. this is why you can pick reses that give you black. Edit your config and set the res down to 640x480, or use the -window -geometry 640x480 command line option.
Finally, someone who knows something. Ya, I realize the card is a bit out dated. I would love to try the options you gave, can you point me in a direction where a newbe like me can figure this out?
Customize your client at http://bzflag.yamsp.com

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 7:29 pm

clipping from running the app in terminal:
/Applications/BZFlag-2.0.0\ copy.app/Contents/MacOS/bzflag; exit
data path is "/Applications/BZFlag-2.0.0 copy.app/Contents/Resources"
data path is "/Applications/BZFlag-2.0.0 copy.app/Contents/Resources"
Could not set Video Mode: Error setting OpenGL fullscreen: invalid memory allocation.
ERROR: Unable to initialize an OpenGL context
logout

looks like what you were saying. I have no idea where to change the settings or to find the config file, or where to run the command line. please advise.
Customize your client at http://bzflag.yamsp.com

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5184
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Mon Feb 28, 2005 9:08 pm

run it from a terminal, with -window -geometry 640x480

basicly it'll be /where/ever/your/bzflag/is/bzflag.app/something/something/bzflag -window -geometry 640x480

I don't remember where the game is on the mac, you'll have to find that out yourself.

or find your config ( don't remember where that is ether ), open it in a text editor, and change the resoultion lines.

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 9:28 pm

ok, I tried both entering in 640x480 in the config file and opening in the terminal and both get the same results, same as before. here is the info from my terminal window if it can help (I have the correct file directory).

Code: Select all

open BZFlag-2.0.0.app -window -geometry 640x480
2005-02-28 16:24:00.317 open[860] No such file: /Applications/-window
any help?
Customize your client at http://bzflag.yamsp.com

User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG » Mon Feb 28, 2005 9:30 pm

For some reason it's adding -window to the directory. Try putting "BZFlag2.0.0.app" in quotes, like that <---

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 9:38 pm

no dice... same results. any other ideas?
Customize your client at http://bzflag.yamsp.com

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5184
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Mon Feb 28, 2005 10:35 pm

the .app is not the actual game. that is the "package" the .app is actualy a folder. Inside it there is a dir called "CORE" and maybe one called "OSX", and folder called "resources" I don't remebmer exactly. I can check when I get home. If you right/ctrl click on the icon for bzflag and say "open package" it'll show you the folders that are inside. Basicly there is a folder that has bzflag, bzfs and bzadmin, THAT is where the actual executables are. That bzflag is the one you run from the command line. executables on OSX don't have an extension, like windows does. They are very similar to linux and unix.

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Mon Feb 28, 2005 10:57 pm

ok... half way there. I finally got it to load and open the start page (join game, options, etc) but can not interact with it. any command I press after that want to go into my terminal window. thoughts?
Customize your client at http://bzflag.yamsp.com

Tim Riker
Maintainer
Maintainer
Posts: 10
Joined: Thu Dec 02, 2004 5:33 pm
Location: USA, Utah, Salt Lake City
Contact:

more options

Post by Tim Riker » Tue Mar 01, 2005 6:05 am

try just the -geometry 640x480 and not the -window.
Tim Riker - http://rikers.org/ - Tim@Rikers.org
BZFlag maintainer - http://BZFlag.org/ - for fun!

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Tue Mar 01, 2005 6:13 am

Thanx Tim for jumping in on this, but no, that still brings the same error as stated above.

Code: Select all

Could not set Video Mode: Error setting OpenGL fullscreen: invalid memory allocation. 
ERROR: Unable to initialize an OpenGL context 
Customize your client at http://bzflag.yamsp.com

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5184
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Tue Mar 01, 2005 5:13 pm

http://bzflag.org/wiki/ConfigFile shows the locations of all the configs on all OSs.

find that file, and just edit the res line ( it's text ). tha'ts the best way, then you don't have command line or focus issues.

User avatar
mac user
Private First Class
Private First Class
Posts: 10
Joined: Tue Nov 02, 2004 5:38 am

Post by mac user » Tue Mar 01, 2005 6:01 pm

ok I opened that file and found that it was set to 640x480, but the problem still persists. thoughts? Can I keep it in a window? What about the Hz, I don't seem to be able to display anything over 85Hz?
Customize your client at http://bzflag.yamsp.com

SilentSwan
Private First Class
Private First Class
Posts: 99
Joined: Fri Jan 21, 2005 4:23 am
Location: Gone

Post by SilentSwan » Sun Mar 13, 2005 9:27 pm

Latest cvs build as of this date ran well for a couple days, then crashed randomly again locking down my system.

1) Could login remotely and attempt to kill the process, but this failed completely. WHY DOES IT NOT RESPOND TO EVEN A "kill -9" ???

2) Had to do yet another hard reboot.

3) MacOS X 10.3.8: Darwin Kernel Version 7.8.0

4) ATI display drivers have been updated to most current revision.

5) There are no messages displayed in the system log at the time of the crash.

6) There are no crash logs displayed.

Just my $0.02, but perhaps devs could be looking into this sort of issue (it appears quite common) instead of adding new features such as the new exploding tank view, etc...

Post Reply