fps rate very low - how can i make it higher?

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
doc holiday
Private First Class
Private First Class
Posts: 16
Joined: Tue Jan 18, 2005 7:42 pm

fps rate very low - how can i make it higher?

Post by doc holiday » Mon Apr 10, 2006 11:42 am

hello everyone,
i just want to ask for some advice to get my fps-rate higher.
my system is:
1,8xp, geforce4 ti-4200,256mb drr-333
bzflag 2.0.4
all effects off, graphics at 1024*768,32bit

i talked to some other players with much worse pcs and they told me that they normally have about 150fps or so.
my rate is at ~80 fps.

i tried to get it higher with changing the bit-rate (16bit), i put all graphic details off and so on; nothing changed.
i also closed other programs running in the background (icq,etc), but it didn't help neither...

so what i want to know, how can i get a higher framerate, what might cause the fact the rate never comes higher?

ty,
doc
Qui bene bibit, bene dormit. Qui bene dormit, non pecat. Qui non pecat, venit in caelum. Igitur: qui bene bibit, venit in caelum!

JPT
Private First Class
Private First Class
Posts: 260
Joined: Tue Nov 29, 2005 1:21 pm
Location: Germany

Post by JPT » Mon Apr 10, 2006 11:56 am

Your system is similar to mine...

And i've got a similar Framerate (FPS).

You should check the DirectX Version and perhaps, you should update it.

Check, if 3D Acceleration is turned on.

Go to Start -> Run...

enter "dxdiag" and press enter.



You should try to update your video driver, too...

User avatar
The Red Baron
Sergeant First Class
Sergeant First Class
Posts: 987
Joined: Sat Dec 07, 2002 6:21 am
Contact:

Post by The Red Baron » Mon Apr 10, 2006 12:17 pm

Turn off vertical Sync. That alone will boost your FPS dramatically. With V-sync on, at dub.bzflag.org I'm locked in at 75fps. Turn it off I can run at 200+ FPS. On a geforce 2 GTS.
Beware! I'm going to clone myself and spread those clones all over the world!

User avatar
Saturos
Art Master General
Art Master General
Posts: 1111
Joined: Mon Apr 19, 2004 2:48 pm
Location: Berlin/Germany
Contact:

Post by Saturos » Mon Apr 10, 2006 12:49 pm

You won't notice any difference between 80 fps and 150... really. I don't understand why you worry about that, I mean, I play with 25-30. :D
Is it some kind of "wer hat den Längsten?"?. ;)

User avatar
CannonBallGuy
Private First Class
Private First Class
Posts: 2083
Joined: Wed Apr 12, 2006 1:31 am
Contact:

Post by CannonBallGuy » Mon Apr 10, 2006 2:55 pm

I used to play with 25-30 FPS, I turned off "Energy Saver" in the bzflag in-game options and now I can get anything between 50 and 100 FPS.
I saw a slight DECREASE in quality - with the Energy Saver off my picture was jittery, even if my lagstats were fine.
So, I have put the Energy Saver back on and I play with 25-30FPS fine. :)
Image

Merry Christmas!

"Look, if I don't buy booze for the kids, I don't get any incriminating pictures to show to their parents, my business goes down the sink, my girlfriend leaves me and the baby goes on ebay. So help me search..."

"go Play With Toys urself in a dark alley u donkey ******" - Lt-Kirby2007

doc holiday
Private First Class
Private First Class
Posts: 16
Joined: Tue Jan 18, 2005 7:42 pm

Post by doc holiday » Mon Apr 10, 2006 3:08 pm

The Red Baron wrote:Turn off vertical Sync. That alone will boost your FPS dramatically. With V-sync on, at dub.bzflag.org I'm locked in at 75fps. Turn it off I can run at 200+ FPS. On a geforce 2 GTS.
well where do i find this option? would be nice you could tell me =)

i've got direct x 9.0c and the newest graphics-driver for my card; i think this ain't the problem (direct 3d+co all activated)
Qui bene bibit, bene dormit. Qui bene dormit, non pecat. Qui non pecat, venit in caelum. Igitur: qui bene bibit, venit in caelum!

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Post by Spazzy McGee » Mon Apr 10, 2006 3:14 pm

above about 30fps you can't tell anyway, so it dosn't really matter. 80 is a fine fps, don't worry if it's not higher. you only really need to worry about is untill it drops below 15. like i said above about 30 your eye can't really tell the difference anyway. i think the fps of a movie or tv program is about 30.
"Life is what happens to you while you're busy making other plans." - John Lennon

doc holiday
Private First Class
Private First Class
Posts: 16
Joined: Tue Jan 18, 2005 7:42 pm

Post by doc holiday » Mon Apr 10, 2006 3:26 pm

well my screen is running with 85Hz
that means it shows 85 pictures/second
so if i coudl see a difference between 85 and 75 :P
Qui bene bibit, bene dormit. Qui bene dormit, non pecat. Qui non pecat, venit in caelum. Igitur: qui bene bibit, venit in caelum!

Theme97
Private First Class
Private First Class
Posts: 221
Joined: Fri Nov 11, 2005 8:04 pm
Contact:

Post by Theme97 » Mon Apr 10, 2006 3:40 pm

Saturos wrote:I play with 25-30. :D
Well good, I'm not the only one. :?
Image

User avatar
The Red Baron
Sergeant First Class
Sergeant First Class
Posts: 987
Joined: Sat Dec 07, 2002 6:21 am
Contact:

Post by The Red Baron » Mon Apr 10, 2006 4:13 pm

doc holiday wrote:
The Red Baron wrote:Turn off vertical Sync. That alone will boost your FPS dramatically. With V-sync on, at dub.bzflag.org I'm locked in at 75fps. Turn it off I can run at 200+ FPS. On a geforce 2 GTS.
well where do i find this option? would be nice you could tell me =)

i've got direct x 9.0c and the newest graphics-driver for my card; i think this ain't the problem (direct 3d+co all activated)
what operating system do you use?
Beware! I'm going to clone myself and spread those clones all over the world!

doc holiday
Private First Class
Private First Class
Posts: 16
Joined: Tue Jan 18, 2005 7:42 pm

Post by doc holiday » Mon Apr 10, 2006 4:47 pm

ooops :D windows xp professional
Qui bene bibit, bene dormit. Qui bene dormit, non pecat. Qui non pecat, venit in caelum. Igitur: qui bene bibit, venit in caelum!

User avatar
The Red Baron
Sergeant First Class
Sergeant First Class
Posts: 987
Joined: Sat Dec 07, 2002 6:21 am
Contact:

Post by The Red Baron » Mon Apr 10, 2006 5:08 pm

ok,

Right hand click on your desktop, select properties. That will bring up your display settings. Go to the "Settings" tab and find the Advanced button. then find the Tab that has your Geforce icon. (i'm going on memory here)

Vertical sync will be found under openGL settings. its either "On by default" or "application controlled" I turn it to "off by default"
Beware! I'm going to clone myself and spread those clones all over the world!

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Mon Apr 10, 2006 5:15 pm

just so you all know, bzflag dosn't use directX for drawing.

so checking the settings for it won't affect the rendering at all.

BZFlag uses OpenGL.

doc holiday
Private First Class
Private First Class
Posts: 16
Joined: Tue Jan 18, 2005 7:42 pm

Post by doc holiday » Wed Apr 12, 2006 9:36 am

yay for the baron! :)
my fps rate is going up to 140 now =)
Qui bene bibit, bene dormit. Qui bene dormit, non pecat. Qui non pecat, venit in caelum. Igitur: qui bene bibit, venit in caelum!

NTH
Private First Class
Private First Class
Posts: 533
Joined: Thu Nov 25, 2004 4:25 pm
Location: UK / Hampshire

Post by NTH » Tue Apr 25, 2006 1:47 pm

doc holiday wrote:yay for the baron! :)
my fps rate is going up to 140 now =)

Same here thanks trb, I now get 156 fps (before 79fps)

NTH
NTH

Why is it when someone says there is a more than a billion stars in the sky you believe them, but if that same person says wet paint you have to touch it to make sure.

You die you spawn ..... You die you spawn .....
Only you controls the length of time between the two.

BZ Cycle of life

User avatar
TD-Linux
Sergeant
Sergeant
Posts: 724
Joined: Wed Apr 27, 2005 8:26 pm
Location: Mountain View, CA

Post by TD-Linux » Tue Apr 25, 2006 8:29 pm

But.............
Even if your framerate is higher than your vsync, you can't tell because your screen is updated slower. Turning the vsync on should increase quality I think, mainly the odd jitter... though I can't tell myself. The only reason to turn off vsync is if your fps is lower than your monitor's refresh rate or you want to impress friends & family.

User avatar
G-MAN
Private First Class
Private First Class
Posts: 85
Joined: Fri Aug 05, 2005 10:12 pm
Location: Location, Location, Location. This house has it all.

Post by G-MAN » Wed Apr 26, 2006 1:39 am

Just a tip, make sure to shut down all running applications that use processing power, usually works for me. :lol-old:
<hr>
<hr>
<hr>

Post Reply