BZFlag on an Intel Macintosh

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Re: sound on OSX/Intel

Post by Spazzy McGee » Sat Apr 07, 2007 5:47 pm

zetan wrote:How do I setup the sound driver in bzflag for OSX sound devices?
What do I enter for Driver and Device in the Audio menu?
Just don't.

BZFlag should automatically detect it, leave the field blank. If it's not being automatically detected then enter 'coreaudio' into the driver field. This will play the sound either through the mac mini's built in speaker or, the audio-out jack - to check if it is being detected automatically, look at the multi-coloured text in the chat console when you start up BZFlag. It should say 'Audio Driver: coreaudio'.
"Life is what happens to you while you're busy making other plans." - John Lennon

Huey Lewis
Private
Private
Posts: 3
Joined: Sun May 01, 2005 10:55 am

The brightness is broken in that first Intel build.

Post by Huey Lewis » Tue Apr 10, 2007 5:19 am

The brightness control in the display options doesn't work in

http://eidotter.de/~alexx/bzflag

But it does work in

http://homepage.mac.com/jmalcaide/.Publ ... sx-x86.zip

Thanks for posting! Most boards were unplayable at night.

User avatar
sherman
Private First Class
Private First Class
Posts: 15
Joined: Thu Oct 14, 2004 6:22 pm
Contact:

Post by sherman » Tue May 29, 2007 11:47 pm

so it's been a while, is the radar bug ever going to be fixed? it's very hard to play without it
nobody

User avatar
macsforme
General
General
Posts: 2026
Joined: Wed Mar 01, 2006 5:43 am

Post by macsforme » Wed May 30, 2007 12:50 am

sherman wrote:so it's been a while, is the radar bug ever going to be fixed? it's very hard to play without it
Turn "Smoothing" off in display settings.

Rufaluf!
Private
Private
Posts: 1
Joined: Mon Jun 25, 2007 5:49 pm

Works with bad graphics

Post by Rufaluf! » Sat Jun 30, 2007 3:34 pm

on my ppc mac mini i get all the 3d graphics of the game e.g explosions, cool buildings. But on my new macbook all I get is 2d horrible looking graphics and the floor is allways covered in lines and fonts are pixelate :shock:

User avatar
joevano
General
General
Posts: 1863
Joined: Sat Jun 18, 2005 1:08 pm
Location: South Bend, Indiana, USA

Post by joevano » Sat Jun 30, 2007 10:47 pm

You need to change your display settings in your BZFlag Client , Options... Display Settings... in the menu.
Last edited by joevano on Sun Jul 01, 2007 12:38 am, edited 1 time in total.
There is nothing worse than aggressive stupidity. -- Johann Wolfgang von Goethe
"How many legs does a dog have if you call his tail a leg? Four. Calling a tail a leg doesn't make it a leg." -- Abraham Lincoln

charg
Private First Class
Private First Class
Posts: 36
Joined: Thu Jun 28, 2007 11:11 pm

Post by charg » Sun Jul 01, 2007 12:33 am

donny_baker wrote:You need to change your display settings in BZFlag Client , Options... Display Settings... in the menu.
Is this the menu that you accsess in the game, by hitting esc as you are playing?
Make sure you get my new Map Editor!: http://my.bzflag.org/bb/viewtopic.php?p=115526#115526

User avatar
joevano
General
General
Posts: 1863
Joined: Sat Jun 18, 2005 1:08 pm
Location: South Bend, Indiana, USA

Post by joevano » Sun Jul 01, 2007 12:39 am

Yes, or it is also displayed right when you open BZFlag...
There is nothing worse than aggressive stupidity. -- Johann Wolfgang von Goethe
"How many legs does a dog have if you call his tail a leg? Four. Calling a tail a leg doesn't make it a leg." -- Abraham Lincoln

Post Reply