Page 1 of 2

BZFlag on an Intel Macintosh

Posted: Mon May 15, 2006 4:04 pm
by optic delusion
If you have one of those shiny new Intel Macintoshes, and want to play BZFlag. Here is the link you need.

Old link removed. was version 2.0.4.

BZFlag 2.0.8 for Intel Mac

Posted: Tue Jun 13, 2006 3:37 pm
by optic delusion
It appears we now have a 2.0.8 binary that works quite well.

Note this is an Intel-only build. It is not universal and will not work on a PPC machine.

Some players have reported a bug "shots not showing up on radar"
Just turn smoothing off in your GUI settings.

Posted: Mon Jun 19, 2006 3:59 pm
by Legolas_
Ok. Just tried it on my brand new spankin macbook. It works great until someone starts a countdown. Then the thing starts to crash (this only happens about 40% of the time)

Posted: Mon Jun 19, 2006 6:55 pm
by 10%
Just attempted to run it on my brand spanking macbook....

It just won't load....

<suspects permissions issue>


MacBook Pro No-Go.

Posted: Tue Jun 20, 2006 7:21 am
by optic delusion
It appears that this version is working well on Intel Mac desktop machines, but is having some problems on the macbook pro.
I'd be happy to work with someone to compile 2.0.8 on a macbook pro, if you have one, please contact me via PM.

Posted: Tue Jun 20, 2006 8:48 am
by 10%
After further analysis.... It appears that the 2.0.8 build above requires X11 and the X11SDK installed for essential libs - The MacBook's default install doesn't include dev tools or X11 - I installed them and now the build runs fine.

One *little* problem at the moment..... Shots don't show up on radar(!) The color 'trails' do, but the shot itself doesn't.


Posted: Tue Jun 20, 2006 1:40 pm
by optic delusion
Well, there ya go. The answer.

Now NOT dependent on X-11

Posted: Tue Jun 20, 2006 8:00 pm
by optic delusion
Alright, the build in the original link has been changed. The link will now produce an application that is NOT dependent on X-11. This means you do NOT have to install devtools, X-11, or SDL.

Keep posting bugs, if you notice any.
I'm pretty sure "shots not showing on radar" was just his particular settings, and it can be fixed with a change in GUI options.

Posted: Wed Jun 21, 2006 4:30 pm
by Daemon
I have just compiled BZFlag 2.0.8 for Intel Macs. It seems to run just fine. Download from: ...


Posted: Tue Aug 01, 2006 8:06 am
by sherman
I've gone through all the settings, and shots still aren't showing up on the radar. Any chance this will be fixed with a future release?

Posted: Tue Aug 01, 2006 11:49 am
by Saturos
I am on a MacBook Pro with that eidotter-build and it works perfectly fine. Try increasing the Shot-Size in your GUI-options.

Posted: Tue Aug 01, 2006 3:28 pm
by temporal distraction
I have the same issue, see the screenshot. Changing the shot size option in GUI settings has no effect. I can mitigate the issue by making the trails longer (and leading, so I can see where they are going).

I think I recall others having this issue with 2.0.0, I cannot find the solution though.

Any other ideas?

Edit: I can adjust the shotsize on a PPC G5 mac - so it really seems to be the IntelMac build.

Further Edit: Turning off "Smoothing" at the Options->Display Settings makes the shots appear - yippee!

Posted: Mon Aug 07, 2006 3:43 pm
by Winny
I got myself a macbook.

It runs great, but I do have the problem with the shots.

Posted: Mon Aug 07, 2006 4:24 pm
by temporal distraction
I've tried clearing out the client config file, and even rebuilding from scratch using A-Delusion's instructions, but the shots still appear as a single pixel in radar.

Ah well, there's always something...

Posted: Mon Aug 07, 2006 8:38 pm
by Saturos
I've had that problem on Linux before...

Found a couple more bugs, I think, to Mac Intel version.

Posted: Tue Aug 22, 2006 7:12 am
by G5 Serenity 2011
GRrrrr. New iMac running 10.4.7 and the other build of 2.0.8 for Intel Macs which I found on this forum. The official version will quit on my iMac everytime, no exceptions. The game starts on any server, and between 3-10 seconds later, quits. The "a" key for changing the speed at which your tank moves does not work. Same speed, which appears a little slow, on Bable anyway. Plus (and this is my biggest gripe), since installing this build, all the background scenery, mountains and meadows, anything beyond the border of the map, is extremely dark. I've checked and changed all the settings, monitor is set to brightest and best resolution, but nothing helps. It's definitely playable, but sure ain't pretty!


Posted: Tue Aug 22, 2006 8:42 pm
by Saturos
Might be OT, but... HEY G5 SERENITY! Remeber the good old GU-times? We played a lot... :o

Posted: Tue Nov 28, 2006 10:06 am
by Beth
Wow -- thanx ya'll for posting a link to the intel version. My new macbook thanks you too. Yay!


Posted: Thu Dec 21, 2006 9:24 pm
by Winny
Hmm, I had to reinstall BZFlag, but the eidotter link isn't working, and the other build freezes my macbook for some reason...

Anyone have a copy of the build around?

y'all rock...

Posted: Sun Dec 24, 2006 4:56 pm
by DohWhiteSoxRule
Thanks, I new there was a solution. You all rock! Thanks...

Posted: Fri Dec 29, 2006 6:43 am
by macsforme
I just got a new MacBook, and have confirmed that the shots don't show up on radar. I've also encountered this problem in Linux, using Ubuntu Edgy Eft on a 3GHz Sony Vaio (the shots, however, showed up fine under the Windows OS on the same machine). I'm going to try to diagnose and fix the problem, but I'm not really an expert, so I could use all the help that's available. There are several ways that people can help.

First of all, if you know the solution, post it. :-P If someone has Windows XP or Linux on one of these MacBooks or MacBook Pros, try BZFlag out under that and let me know how it works. This might help us figure out what's going on. One significant thing is that the configure scripts for PPC and Intel macs output exactly the same thing, with the exception of the machine type (obviously). That gives us a somewhat of an assurance that it isn't a library problem.

I'll let you know when/if I get it figured out.

Posted: Fri Dec 29, 2006 10:38 am
by macsforme
Okay I figured it out, courtesy of Grover. Just turn the "Smoothing" setting in your display settings to off. Shots should then appear as normal. Not sure what actually causes the problem, but this should fix it for you.

Can't connect to servers on Intel Mac

Posted: Mon Jan 22, 2007 2:52 am
by horizonstar
I got my MacBook Pro last year in February and have since been trying to play BZFlag (not very hard, I guess) for about a year. I've downloaded all the latest binaries as they've appeared on these forums, and they run fine, but I can't connect to any servers. No matter what server I select, I get "Server not found" when I try to connect.

I never had this problem on my PowerBook G4, and I was using the same NAT settings on my router with it. I assumed it was a problem with the new binary, but now I see all the discussion about people getting it to run just fine.

Any help would be very much appreciated so I can get back into my old (3-year) BZFlag habit!


Posted: Sun Apr 01, 2007 1:49 pm
by Red Cobra
Hey Win XP. The reason why it might not be working is because your callsiign is win xp and you are a microsoft kind of gye. Now using a mac? :D

sound on OSX/Intel

Posted: Sat Apr 07, 2007 4:47 pm
by zetan
bzflag 2.0.8 works great on my MacMini Intel.

How do I setup the sound driver in bzflag for OSX sound devices?
What do I enter for Driver and Device in the Audio menu?