Wont Load Up - Linux (Fedora Core)

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
User avatar
Pirate
Private First Class
Private First Class
Posts: 35
Joined: Mon Aug 01, 2005 6:47 pm

Wont Load Up - Linux (Fedora Core)

Post by Pirate » Thu Jun 15, 2006 4:42 pm

BZ Flag wont load :-( When I click on it the little icon bobs up and down for a bit then it just stops loading. When I tried loading it on Konsole this came up:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Could not set Video Mode: Couldn't find matching GLX visual.
Error creating window - Exiting
[/quote]

Longhair
Private First Class
Private First Class
Posts: 330
Joined: Tue Feb 08, 2005 6:06 pm
Location: Lancaster, PA
Contact:

Post by Longhair » Thu Jun 15, 2006 6:13 pm

I'm guessing that you don't have your glx drivers installed. What video card do you have?

Most likely, you'll need to download the proper drivers from the card manufacturer's website. If you have installed them, and it still isn't working, you may have forgotten to modify your /etc/X11/xorg.conf file. Make sure that it's loading the right kernel module.

For example, I have a nVidia card, and default Fedora Core installation doesn't come with nvidia accelerated graphics drivers. I usually just download the driver from nvidia.com and install it. (make sure X isn't running) The newer nvidia drivers automatically update the xorg.conf file for you so you don't need to open it up in vi and fix it. I think that YUM has the GLX drivers too, so you may be able to do it that way too.

User avatar
Pirate
Private First Class
Private First Class
Posts: 35
Joined: Mon Aug 01, 2005 6:47 pm

Post by Pirate » Thu Jun 15, 2006 7:13 pm

But what I don't get is why it's never worked before.

Post Reply