Page 1 of 1

Wont Load Up - Linux (Fedora Core)

Posted: Thu Jun 15, 2006 4:42 pm
by Pirate
BZ Flag wont load :-( When I click on it the little icon bobs up and down for a bit then it just stops loading. When I tried loading it on Konsole this came up:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Could not set Video Mode: Couldn't find matching GLX visual.
Error creating window - Exiting
[/quote]

Posted: Thu Jun 15, 2006 6:13 pm
by Longhair
I'm guessing that you don't have your glx drivers installed. What video card do you have?

Most likely, you'll need to download the proper drivers from the card manufacturer's website. If you have installed them, and it still isn't working, you may have forgotten to modify your /etc/X11/xorg.conf file. Make sure that it's loading the right kernel module.

For example, I have a nVidia card, and default Fedora Core installation doesn't come with nvidia accelerated graphics drivers. I usually just download the driver from nvidia.com and install it. (make sure X isn't running) The newer nvidia drivers automatically update the xorg.conf file for you so you don't need to open it up in vi and fix it. I think that YUM has the GLX drivers too, so you may be able to do it that way too.

Posted: Thu Jun 15, 2006 7:13 pm
by Pirate
But what I don't get is why it's never worked before.