Latest Version (2.0.8) with serious display problems

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
szuvjifhdsugihdfuioghdfui
Private
Private
Posts: 1
Joined: Tue Aug 01, 2006 12:39 pm

Latest Version (2.0.8) with serious display problems

Post by szuvjifhdsugihdfuioghdfui » Wed Aug 09, 2006 10:24 pm

Hello,
I upgraded my workstation from Fedora Core 3 to 5 and installed the latest BZFLAG 2.0.8 rpm and when I did, the game no longer diplays the screen properly (See attachment).
It works OK in a small window (about the size of the area that does show the objects).
It was fine on the older bzflag and fc3, so my display adapter is capable (Intel 82865G).
I also deleted the cache. In fact, I deleted the entire .bzf directory, uninstalled, then reinstalled bzflag. I've tried a variety of bzflag display settings aswell as manually attempting to adjust the config file. All in vain.

If anyone has any ideas how to rectify the problem, I will be very greatful.

p.s. Yes, I've compiled the source and tried that too.
Attachments
Screenshot.png
Screenshot, highlighting the problem
(478.33 KiB) Downloaded 68 times

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Wed Aug 09, 2006 11:36 pm

it's probalby not bzflag, but your video driver, make sure that FC5 didn't change you to a non functional video driver. Intel should have the current driver for your OS.
ImageJeffM

User avatar
GMMan
Private First Class
Private First Class
Posts: 186
Joined: Sat May 13, 2006 9:32 pm
Location: On the time-space continuum

Post by GMMan » Thu Aug 10, 2006 12:02 am

I have this problem if I use Ubuntu (any version with BZFlag 2.0.4) Live CD. I pop the disk in, use Synnaptics to install BZFlag 2.0.4 (the only available), and it does that.
I haven't touched BZFlag for years, but maybe sometime I'll make a comeback.

I'm on Twitter. And I mess with webOS. This signature is not a blog.

anomaly
Private First Class
Private First Class
Posts: 220
Joined: Tue Jul 26, 2005 10:32 pm
Location: Gainesville Florida

Post by anomaly » Sun Aug 20, 2006 3:39 pm

Sorry this is a late post. If you haven't already figured it out the problem is that BZFlag isn't figuring out the correct display setup. Not sure why. I have an Intel video driver as well but this happens on my son's Radeon too. We both are running Fedora 5. Try bzflag -geometry 1024x768. replace the 1024x768 with whatever your fullscreen resolution is. I made an entry to my .bashrc file like this:

Code: Select all

alias bzflag='bzflag -geometry 1024x768'
hope that helps

EDIT
I figured out that adding

Code: Select all

set geometry 1024x768
in your bzflag config.cfg file will solve the problem. It appears that bzflag and/or SDL don't get the display resolution right and it is defaulting to 640x480. And only this portion of the screen is being redrawn. May be the intel drivers. SDL_ListModes() function does work though...However I only have this problem on bzflag. Other SDL/OpenGL apps that I have seem to work fine.[/b]

Post Reply