Ultra Bright Screen

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
User avatar
Triumph of the Soul
Corporal
Corporal
Posts: 294
Joined: Thu Jul 06, 2006 4:32 pm
Location: Minnesota

Ultra Bright Screen

Post by Triumph of the Soul » Sat Sep 23, 2006 6:20 pm

Sometimes when I am at certain servers, and I am in observer mode, I try to join the game on a different team. When I do this transition from observer mode to any other team, BZFlag crashes, closes and I am returned to Windows. This wouldn't be a problem worth complaining about if that was the whole story, because something else happens too. When I am returned to Windows, the screen becomes super bright and I didn't do anything to my monitor settings. When I open on BZFlag in Windows, in the split second before BZFlag starts, the screen returns to normal brightness so I am pretty sure that BZFlag is the cause of all this. So far, the only way that I know of to return my screen to normal is to restart the computer. Does anyone else have this problem, and is there any way to fix it? Any help will be greatly appreciated. Thank you.

--A Distraction
Image
Creator @: Duck or Die, Duck or Die CTF, Fuel Stack, Guernica, Normal, Frayed

User avatar
A Vicious Muffin
Private First Class
Private First Class
Posts: 534
Joined: Sat Aug 26, 2006 12:25 am
Location: Drury Lane

Post by A Vicious Muffin » Sat Sep 23, 2006 6:24 pm

I have the exact same problem, on the exact same machine, at the exact same time. I would like to know what is up too. :?

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Sat Sep 23, 2006 7:15 pm

This happened to me too when I upgraded BZFlag on my Mac. Deleting the config.cfg file fixed it.
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
Triumph of the Soul
Corporal
Corporal
Posts: 294
Joined: Thu Jul 06, 2006 4:32 pm
Location: Minnesota

Post by Triumph of the Soul » Sat Sep 23, 2006 9:52 pm

A Meteorite wrote:This happened to me too when I upgraded BZFlag on my Mac. Deleting the config.cfg file fixed it.
I did this but the problem still occurs. It seems that config.cfg has replaced itself. :?

--A Distraction
Image
Creator @: Duck or Die, Duck or Die CTF, Fuel Stack, Guernica, Normal, Frayed

User avatar
Teppic
Private First Class
Private First Class
Posts: 576
Joined: Mon Mar 07, 2005 10:00 pm
Location: The North Block
Contact:

Post by Teppic » Sat Sep 23, 2006 11:30 pm

I have had this in the past, it's to do with BZs gamma settings (or do they call it brightness), anyhow, if you can find where to set the monitor gamma in the GFX card settings you can make it normal again.

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Sat Sep 23, 2006 11:44 pm

A Distraction wrote:
A Meteorite wrote:This happened to me too when I upgraded BZFlag on my Mac. Deleting the config.cfg file fixed it.
I did this but the problem still occurs. It seems that config.cfg has replaced itself. :?

--A Distraction
Ah, I meant about the crashing part. I don't know about the brightness, though (since it doesn't revert back to normal?).
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
MacMan92
Private First Class
Private First Class
Posts: 26
Joined: Thu Apr 13, 2006 2:40 pm
Location: New York
Contact:

Post by MacMan92 » Mon Sep 25, 2006 7:36 pm

I know that the brightness settings are in Options>Display Settings. You could try reinstalling BZFlag. Or maybe it's a mod that was put on the server that doesn't work, if it's only on one server. Have you done /report?
Image
Image
Image - LOL :-)
Image
Image

BZFlag-2.0.8
Apple PowerBook G4 15'' 1.67GHz, 80GB internal, 250GB external Lacie D2 Extreme
Mac OS 10.4.8

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5187
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Mon Sep 25, 2006 7:53 pm

the server can't set client brightness.

reinstalling won't do anything, the problem is not with the client app.

the problem is generaly with the video drivers. It is there job to put the gamma back when bzflag exits. Just make sure you have the most current version of your video drivers as well as direct X.
ImageJeffM

User avatar
chickin
Private First Class
Private First Class
Posts: 41
Joined: Sun Feb 26, 2006 1:25 am
Location: greenville, south carolina, USA
Contact:

Post by chickin » Tue Sep 26, 2006 7:09 pm

I know i quick fix. if u are on windows go to your video driver (usely there is a short-cut for me "ctrl alt F12") anyway go to the driver window and just close it! it should go back to normal. :)

Chickin.
:<>
-------------------(\ /)--------------------
------------------(O.o)-------------------
------------------(> <)-------------------

This is Bunny. Copy Bunny into your signature to help him on his way to world domination

User avatar
Triumph of the Soul
Corporal
Corporal
Posts: 294
Joined: Thu Jul 06, 2006 4:32 pm
Location: Minnesota

Ultra Bright Screen

Post by Triumph of the Soul » Tue Sep 26, 2006 9:30 pm

chickin wrote:I know i quick fix. if u are on windows go to your video driver (usely there is a short-cut for me "ctrl alt F12") anyway go to the driver window and just close it! it should go back to normal. :)

Chickin.
:<>
I don't know how it worked or why it worked but this seems to return the screen to normal each time. It's not a complete fix to the problem but it does treat the symptoms. Thanks, chickin!

By the way, A Meteorite, deleting config.cfg deleted all of my settings (as is expected when deleting a file by that name) and made all words on BZFlag's main menu become a sequence of unintelligible, vertically arranged lines. I don't know if the latter of these effects is to be expected or not. Thanks anyway.

--A Distraction
Last edited by Triumph of the Soul on Wed Sep 27, 2006 3:06 am, edited 1 time in total.
Image
Creator @: Duck or Die, Duck or Die CTF, Fuel Stack, Guernica, Normal, Frayed

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Re: Ultra Bright Screen

Post by A Meteorite » Wed Sep 27, 2006 3:02 am

A Distraction wrote:By the way, A Meteoite, deleting config.cfg deleted all of my settings (as is expected when deleting a file by that name) and made all words on BZFlag's main menu become a sequence of unintelligible, vertically arranged lines. I don't know if the latter of these effects is to be expected or not. Thanks anyway.
Either it's related to your video drivers or some weird settings in config.cfg did that (none that I know of, except resolution possibly...) - which I've never seen. If you didn't totally delete it (ie, empty your recycle bin) just replace the new config.cfg with your old one and see if that helps.
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
Triumph of the Soul
Corporal
Corporal
Posts: 294
Joined: Thu Jul 06, 2006 4:32 pm
Location: Minnesota

Update

Post by Triumph of the Soul » Wed Nov 08, 2006 11:27 pm

Update: It has been a while since this thread has been used, and my problem with BZFlag is just about gone, except for a few rare cases when it still occurs.

But now my attention has shifted to another matter: The problem described in this thread also happens in another full screen game, Starcraft. This time the Ultra Bright Screen happens whenever I start the game, and unlike BZFlag, the Ultra Bright Screen occurs inside the game as well as outside it. I know these are the BZFlag forums and I should try not to discuss other games here, but the problems in these two games seem to be related, and they likely share a common cause. Please, I would appreciate any help.

I have updated all my Video and Graphics card drivers, and I have had the most recent version of Direct X for a while now. I am puzzled because I didn't use to have this problem, although I hadn't played Starcraft for such a long time that I can't tell you when the problem started.

I am running on:

Dell Dimension 3000
Microsoft Windows XP SP2
Intel Integrated Graphics Card ((Intel (R) Extreme Graphics 2): Came with the computer.))

Thanks,

--A Distraction

Update: The problem with Starcraft only occurs if I have used BZFlag and it has experienced the problem described above since I last restarted my computer.
Image
Creator @: Duck or Die, Duck or Die CTF, Fuel Stack, Guernica, Normal, Frayed

Post Reply