Page 1 of 1

Kernel update

Posted: Fri Dec 22, 2006 2:59 am
by a1anc
Hello All,
Running Suse linux 10.1 and just updated the kernel and now the game starts up and hangs if I am in my normal login. If I log out and log in as root the game runs ok. All other 3D games work in my profile so I am not sure what happended, but open to suggestions. I have only tried observer mode but so far this game looks pretty cool..
a1anc

Posted: Fri Dec 22, 2006 12:39 pm
by anomaly
Does your distro save the previous kernel? If so you can try booting to the old kernel and see if BZFlag runs ok. That may be a clue. What kernel did you update to? I am running Fedora 5 and have never had any issues such as yours with kernel updates. Did you do a full update or just the kernel? Sometimes updates such as CURL or other networking programs can hose you up. When you say BZFlag hangs, how long have you waited? I have had it take up to 2 minutes in the past to timeout because of the network. BTW, what version of BZFlag are you running?

although it really sounds like a user permissions issue. are your other 3D games using the network? Maybe try reloading BZFlag.

Thanks for feedback

Posted: Sun Dec 24, 2006 12:58 pm
by a1anc
Anomaly,
Sounds like good advice.. At this point I don't think that the game is the issue. It runs under both root and it runs under guest profiles. In my normal profile it only shows the opening screen and hangs. I did try reinstalling with YaST.
Sounds like I may need to look at permissions like you mentioned. My related hardware consists of a 5 year old Shuttle MOBO and Intel P4, an NVIDIA video card that when I do any kernel updates I have to recompile the video drivers into the kernel using shell commands at runlevel 3. The distro is the OpenSUSE and the latest NVIDIA drivers. Anyway SUSE Linux has an auto updater that sits in the system tray. Seems as though when I get everything the way I like it an update or patch comes along and I got to start all over agn.. :)
a1anc

Posted: Tue Dec 26, 2006 9:54 pm
by anomaly
Seems as though when I get everything the way I like it an update or patch comes along and I got to start all over agn.. :)
I know the feeling :? I have had an updater running in the background in the past and it has messed me up as well. I disabled it in services. When BZFlag starts up it gets the MOTD. This means networking. If it lists your Audio and OpenGL drivers and then stops, thats probably what is happening. Something with the network.

Well, good luck :)

Posted: Tue Dec 26, 2006 11:07 pm
by DTRemenak
If the problem is specific to a particular profile, it frequently is caused by a problem with the config file. Move your ~/.bzf directory away and see if the problem persists.

Posted: Thu Dec 28, 2006 12:34 am
by angryfirelord
Yeah. those kernel updates are a pisser. That's one issue I had with Fedora Core because they would update the whole kernel (Ubuntu just puts security updates for the kernel). My wireless and nvidia drivers would be non-existant. It was fun for about the first day, but doing it over and over grew to be a pain.

Posted: Fri Dec 29, 2006 3:11 pm
by anomaly
Although I have not had BZFlag hang because of the config file I have seen it refuse to run in Windows. Deleting the config file solved that. Let us know if that fixes your problem, a1anc.

Speaking of Fedora, the livna repos has ndiswrapper and nvidia drivers (and ati) that will update with the kernel now. Thats a nice feature. I used to have to recompile ndiswrapper with every kernel update. :? Its also nice that there is a kernel module for my wireless now as well.