Page 1 of 1

Window Randomly Minimizes

Posted: Mon Jan 15, 2007 12:58 am
by Katarn
The BZFlag window randomly minimizes while I'm playing. I'm playing in full screen mode, so it shouldn't be a case of my clicking outside the window and shifting focus. I've tried disabling my virus scanner, but the problem persists. I imagine it is as likely to be a problem with something trying to steal the focus as it would be with BZFlag its self, but when ever it happens theres never another program or dialog box demanding attention. Any one have any ideas on what it could be, or on some possible steps or tools I could pursue to track down the issue? It's extremely frustrating to be seconds from returning to base with the enemy flag, and have your window minimize!

Thanks in advance for anyone's insight.

Posted: Mon Jan 15, 2007 1:25 am
by Triumph of the Soul
I was about to say it could be your antivirus software updating itself, but you said you disabled it. Do you use AVG? I know AVG minimizes BZFlag when it starts it's auto-update. Sometimes it finishes before BZFlag minimizes completely.I used to have this problem too, but I haven't had it ever since I stopped using AVG. Then again, it could be something completely different than AVG that is causing the problem. Does anyone else have ideas?

Posted: Mon Jan 15, 2007 2:22 am
by khazhyk
if you use aim or something, it might be that

Posted: Mon Jan 15, 2007 2:35 am
by Triumph of the Soul
That's right. It could be AIM, since I switched to Trillian at about the same time as I stopped using AVG and the problem has ceased to trouble me. But if it is AIM, I don't know exactly what part of it could be causing this problem.

Posted: Mon Jan 15, 2007 5:25 am
by H0ley
PSA: Sometimes when you press the "windows" key, it will minimize full screen apps.

/yes i am a richard.

On a more serious note, what kind of graphic card do you have? I used to have a problem going fullscreen with directx games on a integrated laptop graphic card.

Posted: Fri Jan 19, 2007 3:44 pm
by QuantumBeep
Random minimizes are very often caused by either Windows Update or some sort of spyware. Basically, if anything tries to steal input focus, BZflag will minimize. Run a good spyware scan and (TEMPORARILY) disable Automatic Windows Updates and see if that fixes it.

Posted: Fri Jan 19, 2007 10:18 pm
by GMMan
It's usually a background program starting. Every day Apple Updater starts (sidenote.. I'm using a PC!), and when I play the game when it starts, the game minimizes. If you have iTunes with a default installation, you have Apple Updater. Try using Microsoft/Sysinternal's Process Explorer and start it in tray form (using the \t switch, I think). Once the game minimizes, immediately click on PE's icon and you might catch a glimpse of the program starting. If not, note what programs are normally there and then sort out the offender.

More details on problem

Posted: Sun Jan 21, 2007 6:55 am
by Katarn
Thanks all for your hints; I'm not using AVG anti virus, I'm using AntiVir. I've scanned the system with both Spybot Search & Destroy and AddAware. I'm do not have AIM, Yahoo, or MicrosoftMessenger active. I'm definately not pressing any odd keys by accident; I've paid particular attention to make sure. I did just recently install itunes, so that is a possibility. But BZflag will sometimes minimize several times within a minute or so (and other times will not minimize for 1/2 an hour), so it doesn't sound like a once a day check from apple updater. Of course it could be several things causing it. I've installed Process explorer, and see if I can spot whatever it is.

Posted: Sun Jan 21, 2007 7:01 am
by Davy Jones
did u try disabling your AVG, that's what we are all saying, make sure no background programs are running, and you should be fine,

Posted: Sun Jan 21, 2007 7:27 am
by blast
Davy Jones wrote:did u try disabling your AVG, that's what we are all saying, make sure no background programs are running, and you should be fine,
He said he wasn't using AVG. Please try reading before you post.

Posted: Sun Jan 21, 2007 4:54 pm
by Davy Jones
I was reading...just not very clearly...i meant antvir...i was thinking about AVG when i wrote it.

Posted: Wed Feb 14, 2007 12:06 am
by CUPCAKE
I've had this happen to me before. Usually the problem is AVG popping up and updating or something else popping up. I just turn everything off that would do that before I play.

Posted: Wed Feb 14, 2007 1:58 am
by Katarn
Yes; when AntiVir does its update it does minimize BZ, but that is readily apparent, and easy to fix. My problem is BZ flag minimizes with no apparent application stealing the focus or poping up a window. I've completely killed all AntiVir processes, teatimer (from SpyBotSearch & Destroy), the NVidia desktop manager, and a number of other things. But it still does it. Sometimes several times within 30 seconds. Using System Internal's process explorer I sometimes see that "rundll32.exe" is exiting as BZ minimizes (but not always). Unfortunately it seems there are many things which run themselves through rundll32, so if that's it I don't know what program(s) are using it. Once I saw that "rundll32.exe NvCpl.dll,NvCplApplyColorProfile" was running through rundll32 when BZ minimized (which is part of the NVidia driver), but I don't know if that is part of the problem or not. And it may not be related to rundll32 at all. This problem is extremely annoying :( I'm sure a good programmer could write an app which would log every program/event which grabs the focus, but I wouldn't know how to do something like that.

Posted: Wed Feb 14, 2007 2:21 am
by Davy Jones
look at your taskmanager, and see if anything OPENS while in BZflag, Of course, when something closes, that might also be an issue, as it can steal the focus as well. You could eliminate the source code that has the windowed version, but that is a i littler more difficult

Solution Found!!!

Posted: Thu Feb 15, 2007 3:00 am
by Katarn
Yea! I Finally found the solution!!
Being an ex-IRIX person, I had used Tweak UI to change the mouse behavior to "X-Mouse", so that the focus followed the mouse for Unix-like behavior. Turning off X-Mouse has solved the problem. Of course now I don't have anything to blame my horrible score on :wink: I used to be much better back when I was playing BZ flag at SGI, on the manufacturing floor test workstations - honest! I guess I need to practice.