Page 1 of 1

"The application failed to initialize properly" pr

Posted: Fri Apr 27, 2007 1:37 pm
by crankdoofus
Hi all,
I have a bit of a problem here running home baked BZflag 2.0.8 build. Hope you can help me out here.
I downloaded the BZFlag2.0.8 source and set up the MS Visual Studio express + PSDK + DirectX SDK as mentioned at http://links-clan.net/howto_compilebzflag.php. The compilation went fine but when i tried running it, it got the following error.
I cant seem to think of anything. Any pointers would be helpful.

---------------------------
bzflag.exe - Application Error
---------------------------
The application failed to initialize properly (0xc0000142). Click on OK to terminate the application.
---------------------------
OK
---------------------------

thanks
-cd

Posted: Thu Jun 28, 2007 9:58 am
by Lan
It's been a while since you first posted. I hope you have figured out some solution, but if not, let's see if I can help.

I have gotten several seemingly random but nonetheless fatal errors in my experience compiling BZFlag. Often times they go away with a clean rebuild, so try that first. If that doesn't do it, I have often times considered what is being linked, and the integrity of the libraries. Did I get a stable SDL library from the official site, or build it myself while half-asleep? Try reinstalling your add-on libraries (cURL, SDL, etc...) Try building without optimizations. Strip any symbols in the executable. Replace your add-on DLLs (SDL.dll, curl.dll)

If that doesn't work, try debugging it with a debugger and finding the issue in the code.

If that still doesn't work, try using minGW32 to build if you are still desperate to build it yourself.

Hope this helps.