Page 1 of 1

What do I need to install? (Ubuntu)

Posted: Wed Oct 03, 2007 4:29 pm
by Mac Rep
I want to compile 2.0.10 and downloaded the zip file linked by Jeff. I ran configure but problems were reported and I'm (as an Ubuntu newbie) have no idea what to install. Can someone please point me in the right direction?

The messages are:

Code: Select all

checking for asinf in -lm... yes
checking for ares_init in -lcares... no
configure: WARNING: using an internal c-ares lib.
configure: WARNING: Consider installing an updated library at system level
configure: WARNING: link is
checking for working ncurses... no
checking for working XCurses... no
configure: WARNING: could not find a curses library, will build bzadmin without curses
checking for SDL framework... no
checking for sdl-config... no
checking for SDL - version >= 1.2.5... no
*** The sdl-config script installed by SDL could not be found
*** If SDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SDL_CONFIG environment variable to the
*** full path to sdl-config.
configure: WARNING: could not find an appropriate SDL version. BZflag will build without SDL
checking for SDL_image library... no
configure: WARNING: Client build has been requested, but GL is not fully available (missing gl.h)
     ... disabling client generation
checking if the compiler understands -Wl,-search_paths_first -mdynamic-no-pic... no
checking for CGLGetCurrentContext... no
checking for isnan... no
configure: creating ./config.status
config.status: creating
config.status: executing depfiles commands
CFLAGS are -g -O2  -Wall -W -mtune=i686 -ffast-math -fno-exceptions
LIBS are -lm 

BZFlag- with the following:
     no curses!
     no SDL!
     no bzflag client binary!

Posted: Wed Oct 03, 2007 4:38 pm
by macsforme
start with

Code: Select all

it also looks like you might need to install some OpenGL (mesa) libraries.

Posted: Wed Oct 03, 2007 4:43 pm
by JeffM
you also need yo make sure you have
and probably mesa-dev since your on ATI

Posted: Wed Oct 03, 2007 5:45 pm
by Mac Rep
Okay... libncurses5-dev and libsdl1.2-dev were no problem to install. Now I'm still missing gl and again have no idea what to install. I tried to find something using aptitude but couldn't find anything useful.

Posted: Wed Oct 03, 2007 9:01 pm
by Mac Rep
g++ was missing.

Still an error I have to fix

Code: Select all

libtool: link: cannot find the library `/usr/lib/' or unhandled argument `/usr/lib/'
make[2]: *** [bzflag] Error 1

Posted: Wed Oct 03, 2007 9:29 pm
by Mac Rep
Now it compiles after installing several missing libs.