Compiling problem...macosx

Questions or HOWTOs about the above? Post 'em here...
Post Reply
Seph1roth
Private
Private
Posts: 4
Joined: Mon Oct 02, 2006 7:51 pm

Compiling problem...macosx

Post by Seph1roth » Thu Dec 20, 2007 6:20 pm

Heya guyz i've a problem whit compiling bzflag 2.0.10..the .dmg isn't out...

After ./configure i see

BZFlag-2.0.10.20071220 with the following:
no curses!
no SDL!
bzadmin
no bzflag client binary!

maybe macosx need this components to compile?

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Thu Dec 20, 2007 6:26 pm

yes, you need sdl, it is required.

Seph1roth
Private
Private
Posts: 4
Joined: Mon Oct 02, 2006 7:51 pm

Post by Seph1roth » Thu Dec 20, 2007 6:42 pm

maybe i got it =)
thanks...let's see if it work....

Seph1roth
Private
Private
Posts: 4
Joined: Mon Oct 02, 2006 7:51 pm

Post by Seph1roth » Thu Dec 20, 2007 6:58 pm

nothing...doesn't compile..

F687/s
Private First Class
Private First Class
Posts: 369
Joined: Sun Dec 31, 2006 8:30 pm

Post by F687/s » Thu Dec 20, 2007 7:19 pm

Chances are, you need 1 of the two things:

1) The libSDL.framework installed (which should have come from the SDL disk image you downloaded)
2) A version of SDL that comes from a Mac package manager (like MacPorts)

Once you have those, try running ./configure again.

User avatar
macsforme
General
General
Posts: 2024
Joined: Wed Mar 01, 2006 5:43 am

Re: Compiling problem...macosx

Post by macsforme » Thu Dec 20, 2007 11:46 pm

Seph1roth wrote:2.0.10..the .dmg isn't out...
You could use our test binary at http://beta.bzflag.bz/builds/2.0.x/MacO ... 2.0.10.dmg

angryfirelord
Private First Class
Private First Class
Posts: 23
Joined: Fri Dec 15, 2006 12:29 am

Post by angryfirelord » Sat Dec 22, 2007 3:40 am

Make sure you have ALL of the SDL libraries and the libcurl library with it.

Seph1roth
Private
Private
Posts: 4
Joined: Mon Oct 02, 2006 7:51 pm

Post by Seph1roth » Wed Jan 30, 2008 3:34 pm

i still having problems with compiling under macosx leopard...

i've installed SDL and curl throug port...
but still give me the same errors...

BZFlag-2.0.10.20080130 with the following:
no curses!
no SDL!
bzadmin
no bzflag client binary!


i've followed similar topic here...

./autogen.sh
./configure (and gave me errors above)

also with xcodebuild...

angryfirelord
Private First Class
Private First Class
Posts: 23
Joined: Fri Dec 15, 2006 12:29 am

Post by angryfirelord » Thu Jan 31, 2008 12:42 am

It's possible that configure is looking in the wrong place for your libraries. There's a way to tell it to point to a different path, but I can't remember how to do that at the moment. :)

Post Reply