BZFlag autogen.sh fails with "no GNU autoconf installed

Questions or HOWTOs about the above? Post 'em here...
Post Reply
javawizard2539
Private First Class
Private First Class
Posts: 22
Joined: Wed Nov 07, 2007 9:20 pm
Location: Same place as TR

BZFlag autogen.sh fails with "no GNU autoconf installed

Post by javawizard2539 »

I'm attempting to download BZFlag and build it from source on a Win32 computer. I have followed the instructions in README.MINGW so far. I ran the msys console, and from there attempted to run autogen.sh . It said that it could not find GNU Autoconf installed. Does anyone have any suggestions? I made sure to add MinGW to the path.

Another question. It says to build and install SDL according to the instructions on libsdl.org . There are no instructions to download and install SDL there, only instructions on how to build it. I downloaded SDL.dll and tried putting it into the root bzflag folder. Is this correct?

Since I'm in to asking questions today, I'll write one more. I plan to do all of my development (which isn't much, I'm thinking of trying to write another flag) in Eclipse (www.eclipse.org). Is there anything I need to do different besides follow the instructions in README.MINGW, and then import the project into Eclipse?
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5195
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

you also need MSYS in addition to minGW, it will do the autoconf and automake stuff.

The install info for SDL under mingw is in the minGW sdl dev package that is on the SDL download webpage on libsdl.org.
http://www.libsdl.org/release/SDL-devel ... w32.tar.gz

please note that we do not normaly do builds on minGW. It "should" work but we do not put any effort into making sure that it does all the time.
ImageJeffM
javawizard2539
Private First Class
Private First Class
Posts: 22
Joined: Wed Nov 07, 2007 9:20 pm
Location: Same place as TR

Post by javawizard2539 »

umm... I mentioned in my post that I was running the script in the MSYS console. I already have it installed, but there is still a problem. Any suggestions? I'm mainly trying to build under MinGW and MSYS because I can't get MSVC++ to work, see another post I made in the general discussion forum (I completely mis-posted it but didn't realize it until after).
Post Reply