Page 1 of 1

Compiling on Solaris

Posted: Sun Jun 01, 2008 4:02 am
by Mets
So I have a Sunblade 100 sitting around and I thought I'd give compiling a shot on it. I've run into a few errors on both 2.0.11, 2.0.10, and 2.0.8, but the leading problem right now seems to be this error message:

Code: Select all

../c-ares/.libs/libcares.a ../regex/.libs/libregex.a ../date/.libs/libDate.a /usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.2.1/libstdc++.a -L/usr/ccs/bin -L/usr/ccs/lib -lm -lgcc /usr/local/lib/ -lssl -lcrypto -ldl -lz -lsocket -lnsl -lresolv -Wl,-R -Wl,/usr/local/lib -Wl,-R -Wl,/usr/local/lib -Wl,-R -Wl,/usr/openwin/lib
Undefined                       first referenced
 symbol                             in file
curl_multi_perform(void*, int*)     ../common/.libs/libCommon.a(cURLManager.o)
curl_multi_add_handle(void*, void*) ../common/.libs/libCommon.a(cURLManager.o)
curl_multi_remove_handle(void*, void*)../common/.libs/libCommon.a(cURLManager.o)
curl_multi_fdset(void*, fd_set*, fd_set*, fd_set*, int*)../common/.libs/libCommon.a(cURLManager.o)
curl_multi_init()                   ../common/.libs/libCommon.a(cURLManager.o)
curl_multi_info_read(void*, int*)   ../common/.libs/libCommon.a(cURLManager.o)
ld: fatal: Symbol referencing errors. No output written to bzfs
collect2: ld returned 1 exit status
make[2]: *** [bzfs] Error 1
I have libcurl installed, and I tried compiling with the --with-libcurl=/path/to/ switch, but I'm still getting that error. Any ideas?

Posted: Sun Jun 01, 2008 3:30 pm
by Enigma
Wait, did you use --with-libcurl=FILE or --with-libcurl=DIR?

Have you tried using LDFLAGS="-L/usr/local/lib" CPPFLAGS="-I/usr/local/include" instead of --with-libcurl?

I'm just throwing around ideas.

Posted: Mon Jun 02, 2008 2:10 am
by Mets
Thanks for the suggestion Enigma, unfortunately it didn't work :(

I tried both the libcurl path and physicall giving it the .so file, but neither worked. They both give the same output, as does giving it the LDFLAGS and CPPFLAGS.