Compile 32 bit bzflag on 64 bit ubuntu.

Questions or HOWTOs about the above? Post 'em here...
Post Reply
Yrogirg
Private First Class
Private First Class
Posts: 154
Joined: Sat Oct 27, 2007 7:24 pm

Compile 32 bit bzflag on 64 bit ubuntu.

Post by Yrogirg » Wed May 04, 2011 12:12 pm

How can I do this?

User avatar
blast
General
General
Posts: 4742
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by blast » Wed May 04, 2011 1:06 pm

Why would you want to do that? As far as I know, there are fewer issues with 64-bit builds of BZFlag than there are with 32-bit, specifically with the collision system.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

Yrogirg
Private First Class
Private First Class
Posts: 154
Joined: Sat Oct 27, 2007 7:24 pm

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by Yrogirg » Wed May 04, 2011 5:03 pm

blast wrote:Why would you want to do that? As far as I know, there are fewer issues with 64-bit builds of BZFlag than there are with 32-bit, specifically with the collision system.
I thought so, however now I have some doubts. First I must say that 64 and 32 bit versions I tried on different machines and different versions of ubuntu, so the problems may actually be due to different environments rather than 64 -- 32 dissimilarities.

Nevertheless on the 64 machine I can't play MW 2.3 in a popper way. The tank seems to have problem with driving over thresholds --- I can't drive onto the jumper. It also takes several attempts to drive onto the bottom shooting position in the middle of the wall.

That was what I'm completely sure in. There are also some sort of things I'm not certain. I have a feeling that tank jumps a bit lower --- now it is almost impossible to get enemy on the wall or pad from the level of field walls. The tank also seems to be more "rubber" --- on 32 when I jumped into the wall tanks normal speed used to turn almost to zero. On 64 it considerably bounces backwards, like a ball.

User avatar
War Pig
Private First Class
Private First Class
Posts: 46
Joined: Sat Feb 16, 2008 11:38 pm

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by War Pig » Wed May 04, 2011 6:05 pm

I have all those same problems under 32bit linux. I am relegated to my Windoze box for playing bz. :-/

-wp-
<life> <!-- insert something interesting here --> </life>

User avatar
Mopar Madness
Private First Class
Private First Class
Posts: 169
Joined: Mon Jul 03, 2006 3:31 am

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by Mopar Madness » Thu May 05, 2011 2:04 am

What's your framerate? Those last issues are also cause by high frame rates. At high framerates like over 200 FPS, tanks start getting holes in the hitboxes so they're slightly harder to hit, but they jump lower and bounce off walls like they're rubbery. At low FPS, like below 30 FPS you can actually jump higher. At 0 FPS you could probably make the jump from ground to base on MW2 in 1 jump. However setting your FPS below 30 intentionally to jump higher is considered cheating in most servers.

Yrogirg
Private First Class
Private First Class
Posts: 154
Joined: Sat Oct 27, 2007 7:24 pm

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by Yrogirg » Thu May 05, 2011 4:41 am

Oh, thank you, now I know the problems are not caused by 64 bits.
Mopar Madness wrote:What's your framerate? Those last issues are also cause by high frame rates. At high framerates like over 200 FPS, tanks start getting holes in the hitboxes so they're slightly harder to hit, but they jump lower and bounce off walls like they're rubbery. At low FPS, like below 30 FPS you can actually jump higher. At 0 FPS you could probably make the jump from ground to base on MW2 in 1 jump. However setting your FPS below 30 intentionally to jump higher is considered cheating in most servers.
Yes, 64 machine is newer and has >200 fps. 32 machine has ~70 fps. The tank jumps lower maybe for about 0.05 units, but this difference makes killing snipers approximately 5 times harder --- I need 3-5 jumps to make the laser travel over the wall. Are these issues valid for windows too?

Will lowering fps allow to drive onto the jumpers?

Yrogirg
Private First Class
Private First Class
Posts: 154
Joined: Sat Oct 27, 2007 7:24 pm

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by Yrogirg » Thu May 05, 2011 8:29 am

I was hinted that you can limit fps to ~30 in bzflag options --- just turn on energy saver. Now I can use jumpers and kill snipers.

However it's not very comfortable, it says my fps is 28 but it feels like < 20.

Fortunately there is a variable fpsLimit. Just add in the config file the next string:

set fpsLimit 100

I have a smooth motion and no bugs! War Pig , you can stay on linux if you want to play bz.

User avatar
blast
General
General
Posts: 4742
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by blast » Thu May 05, 2011 9:23 am

You could also turn on vertical sync in the configuration for your video driver, which would limit the FPS to the refresh rate of your video card (likely 60FPS, if you're using an LCD screen).
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
Mopar Madness
Private First Class
Private First Class
Posts: 169
Joined: Mon Jul 03, 2006 3:31 am

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by Mopar Madness » Thu May 05, 2011 11:21 am

BZFlag doesnt like vert sync from what I've seen. Both ATI and NVidia cards have a problem with it. I used VSync on my comp and anytime there's a big explosion, the FPS drop to like 20. When I keep VSync off, I get a solid 300-400 FPS, dropping to like 200-300 range in explosions.

User avatar
War Pig
Private First Class
Private First Class
Posts: 46
Joined: Sat Feb 16, 2008 11:38 pm

Re: Compile 32 bit bzflag on 64 bit ubuntu.

Post by War Pig » Thu May 05, 2011 9:00 pm

Yrogirg wrote:I was hinted that you can limit fps to ~30 in bzflag options --- just turn on energy saver. Now I can use jumpers and kill snipers.

However it's not very comfortable, it says my fps is 28 but it feels like < 20.

Fortunately there is a variable fpsLimit. Just add in the config file the next string:

set fpsLimit 100

I have a smooth motion and no bugs! War Pig , you can stay on linux if you want to play bz.


Oooo nice! Can't wait to get home and try it :)
<life> <!-- insert something interesting here --> </life>

Post Reply