Built 2.4.2 but segfaults when I shoot

Questions or HOWTOs about the above? Post 'em here...
Post Reply
lagbooger1
Private
Private
Posts: 4
Joined: Sun Aug 02, 2009 11:07 pm

Built 2.4.2 but segfaults when I shoot

Post by lagbooger1 » Wed Aug 08, 2012 11:02 pm

Hi All,

I don't know what to do or even where to start. I am running 64 Mepis 11. I manually d/l and built c-ares-1.9.1 and curl-7.27.0. Then built BZ 2.4.2 without issue. I did use checkinstall to install it. Now I can connect to servers and move inside a game, but the moment I click the mouse it segfaults. I changed the fire to something else and it segfaults. I just started using Mepis. In the past on Debian or AptoSid this worked flawlessly. Does anyone have any suggestions?

User avatar
blast
General
General
Posts: 4672
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Built 2.4.2 but segfaults when I shoot

Post by blast » Thu Aug 09, 2012 2:52 am

Doesn't Mepis have development packages for c-ares, curl, etc? Did you build with SDL support?
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

lagbooger1
Private
Private
Posts: 4
Joined: Sun Aug 02, 2009 11:07 pm

Re: Built 2.4.2 but segfaults when I shoot

Post by lagbooger1 » Thu Aug 09, 2012 7:49 pm

Yes it has libraries, but I installed curl and ares and they were not recognized in the configure script. And I added just about everything SDL under the sun to get it to show up in the configure.

User avatar
blast
General
General
Posts: 4672
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Built 2.4.2 but segfaults when I shoot

Post by blast » Thu Aug 09, 2012 8:07 pm

Did you read the README.Linux file we include with the source? Since Mepis is based on Debian, you should have tried installing the Debian packages we list. However, you now potentially have a "messy" environment since you manually installed some libraries.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

lagbooger1
Private
Private
Posts: 4
Joined: Sun Aug 02, 2009 11:07 pm

Re: Built 2.4.2 but segfaults when I shoot

Post by lagbooger1 » Thu Aug 09, 2012 8:50 pm

Tis is what it reported before I did make. I can remove curl and ares, but when i install the existing packages, it will mean that Bzflag will use its own libraries?

curl version: 7.20.1
Host setup: x86_64-unknown-linux-gnu
Install prefix: /usr/local
Compiler: gcc
SSL support: no (--with-ssl / --with-gnutls / --with-nss)
SSH support: no (--with-libssh2)
zlib support: enabled
krb4 support: no (--with-krb4*)
GSSAPI support: no (--with-gssapi)
SPNEGO support: no (--with-spnego)
c-ares support: no (--enable-ares)
ipv6 support: enabled
IDN support: no (--with-libidn)
Build libcurl: Shared=yes, Static=yes
Built-in manual: enabled
Verbose errors: enabled (--disable-verbose)
SSPI support: no (--enable-sspi)
ca cert bundle: /etc/ssl/certs/ca-certificates.crt
ca cert path: no
LDAP support: no (--enable-ldap / --with-ldap-lib / --with-lber-lib)
LDAPS support: no (--enable-ldaps)
RTSP support: enabled
Protocols: DICT FILE FTP HTTP IMAP POP3 RTSP SMTP TELNET TFTP

Done.

BZFlag-2.4.2.20120809 configured with the following:

Prefix: /usr/local
Binaries: /usr/local/bin
Plugins: /usr/local/lib/bzflag
Manual pages: /usr/local/share/man

CC = gcc
CXX = g++
CFLAGS = -g -O2
CONF_CFLAGS = -Wall -W -Wundef -Wshadow -fexpensive-optimizations
CXXFLAGS = -g -O2
CONF_CXXFLAGS = -Wall -W -Wundef -Wshadow -ansi -pedantic -fexpensive-optimizations
CPPFLAGS =
CONF_CPPFLAGS =
LDFLAGS =
LIBS = -lm -lpthread

Build ares ........: no (using system)
Build curl ........: no (using system)
Build glew ........: no (using system)
Build regex .......: no (using system)
Build zlib ........: no (using system)

BZFlag client .....: yes
BZFlag server .....: yes (with plugins)
BZAdmin client ....: yes

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5172
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Re: Built 2.4.2 but segfaults when I shoot

Post by JeffM » Thu Aug 09, 2012 9:10 pm

You are not building with SDL, it should say.

BZFlag client .....: yes (with SDL)
BZFlag server .....: yes (with plugins)
BZAdmin client ....: yes

lagbooger1
Private
Private
Posts: 4
Joined: Sun Aug 02, 2009 11:07 pm

Re: Built 2.4.2 but segfaults when I shoot

Post by lagbooger1 » Thu Aug 09, 2012 10:41 pm

You are a genius, or at least very experienced :) Thanks so much for noticing that. I should have posted that to begin with. Everything is working smooth now!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest