BZflag 2.0.3 CVS won't build on OS 10.4

Questions or HOWTOs about the above? Post 'em here...
Post Reply
User avatar
(Un)Guided Missile
Private First Class
Private First Class
Posts: 37
Joined: Sun Jan 23, 2005 2:23 pm
Location: Scotland
Contact:

BZflag 2.0.3 CVS won't build on OS 10.4

Post by (Un)Guided Missile » Sat May 07, 2005 10:11 am

After running make, I get the following:

Code: Select all

source='BitmapFont.cxx' object='BitmapFont.o' libtool=no \
depfile='.deps/BitmapFont.Po' tmpdepfile='.deps/BitmapFont.TPo' \
depmode=gcc3 /bin/sh ../../depcomp \
g++ -DHAVE_CONFIG_H -I. -I. -I../../include  -I../../include -pipe -ansi -pedantic -fno-exceptions -W -Wall -Wundef -Wstrict-prototypes  -g -O2 -DBZ_BUILD_DATE=20050507 -O3 -ffast-math -fomit-frame-pointer -fexpensive-optimizations -fno-exceptions -c -o BitmapFont.o `test -f 'BitmapFont.cxx' || echo './'`BitmapFont.cxx
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++
source='FontManager.cxx' object='FontManager.o' libtool=no \
depfile='.deps/FontManager.Po' tmpdepfile='.deps/FontManager.TPo' \
depmode=gcc3 /bin/sh ../../depcomp \
g++ -DHAVE_CONFIG_H -I. -I. -I../../include  -I../../include -pipe -ansi -pedantic -fno-exceptions -W -Wall -Wundef -Wstrict-prototypes  -g -O2 -DBZ_BUILD_DATE=20050507 -O3 -ffast-math -fomit-frame-pointer -fexpensive-optimizations -fno-exceptions -c -o FontManager.o `test -f 'FontManager.cxx' || echo './'`FontManager.cxx
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++
../../include/TextUtils.h:362: error: extra ';'
make[2]: *** [FontManager.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
(Well, there is more, just the rest goes without errors)
Cop @ Far, far, far too many servers. (How the heck am I meant to visit them all regularly?)

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Sat May 07, 2005 11:27 pm

I got the same type of errors, not fonts...
I belive I was missing libraries...
I can't figure out which one though...

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5184
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM » Sun May 08, 2005 12:54 am

there are problems with 10.4 GCC4.0 seems more strict and apple changed some system headers. Learner is our resdent Mac build expert, I've given him time on my 10.4 mini but I don't know how far he got.
ImageJeffM

ryan42
Private First Class
Private First Class
Posts: 23
Joined: Sun Sep 12, 2004 2:28 am

Post by ryan42 » Tue May 10, 2005 11:32 pm

run
sudo gcc_select 3.3

runs fine. I just got through with a good game under 2.0.3

ryan42
Private First Class
Private First Class
Posts: 23
Joined: Sun Sep 12, 2004 2:28 am

Post by ryan42 » Tue May 10, 2005 11:33 pm

btw, for the fonts problem

do
bzflag -directory /this/is/the/path/to/your/bzflag/data/dir

Post Reply