Version 1.9.x builds

All things BZFlag - no [OT] here please
oblomov
Private First Class
Private First Class
Posts: 86
Joined: Fri Sep 19, 2003 8:10 am

Post by oblomov »

widowmaker wrote:Noticed on the ducati server you can't jump as high, is this a tweak with the gravity? Also when you blow up on this server you go really high and I don't think that is supposed to happen!
Makes for a very nice Rabbit Run effect when you're the rabbit, though :)
widowmaker
Private First Class
Private First Class
Posts: 231
Joined: Sun Mar 09, 2003 2:13 am
Location: USA

Post by widowmaker »

Yeah it has the whole hopping effect to it.
User avatar
Chestal
Dev Guru
Dev Guru
Posts: 171
Joined: Fri Dec 06, 2002 11:56 pm
Location: Siegen, Germany
Contact:

Post by Chestal »

A lot of the game parameters are under server control now and gravity is one of them (use /set to display them). When you have the privileges, "/set _gravity -50" gives you the ducati 1.9 settings. It is also possible to specify non-default settings on server startup (which is what I did for now).

The high jumping when exploding is an artifact. When you die there is an eplodetime of 5s (I think), i.e. the time it takes you to explode before you can respawn again. The client calculates the jump speed on exploding in a way that it will take the tank exactly this time before it hits the ground again. With higher gravity, the jump must be higher (and faster) to keep the time constant.
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

bzflag.dragon.org down?

Post by Defman »

Koba wrote:you might have an out-of-date client, the releases have moved to....

http://bzflag.dragon.org/builds
Been trying to connect to this for over a day now with now luck...says that website cannot be found...

whats up with that?

cya round
Def
Grumbler
Dev Monkey
Dev Monkey
Posts: 453
Joined: Wed Jul 09, 2003 3:06 pm
Location: Space

Post by Grumbler »

not sure there defman, I have never had a problem..........can you get to the domain at all?
.........you kids, get out of my tank...........
widowmaker
Private First Class
Private First Class
Posts: 231
Joined: Sun Mar 09, 2003 2:13 am
Location: USA

Post by widowmaker »

Thanks for the info Chestal!
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

the domain is up and normal, maybe you have a chaching DNS that hasn't updated in weeks. Been good for ages now. Works for me and many others.
ImageJeffM
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

Post by Defman »

I cannot even connect to bzflag.dragon.org
pinging the same returns no results, and whois doesn't either (because of the .org I believe)

is bind (named) a possible problem here? If so is there a way to "flush" the cache? Or am I not even close? LOL

tanks
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

are you going thru a proxy server to get to the web?
ImageJeffM
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

Post by Defman »

not going thru proxy here either Patlabor. Am still surfing for an answer too...
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

if it's not resolving, the only thing I can think of is your DNS server isn't picking up changes. This was done over a week ago.
ImageJeffM
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

Post by Defman »

found the "problem" - on this standby server I am using (usual server's cpu fan died) I had an firewall add-on script running which somehow determined that dragon.org's ip was used in some sort of "attack" against our home network. Not too sure if that even happened - am not accusing anybody here, just stating that the script I use determined after scanning the logs that the ip given to bzflag.dragon.org was envolved in something related to winNT_port1029 (the script stated the winnt part as the "exploit") and then it inserted that ip into hosts.deny

I thought I disabled that script but guess not. Once I find someplace in town that still has a cpu fan for a P2 400Mhz for sale I will get it fixed and get that flipping standby server offline (and updated to avoid problems like this)

tanks for the suggestions though
Def
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5193
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

ahhh yeah slot 1 fans are harder to find.
ImageJeffM
Nidhoggr
General Bandwidth
General Bandwidth
Posts: 31
Joined: Mon Feb 10, 2003 5:09 pm

Post by Nidhoggr »

Defman wrote:found the "problem" - on this standby server I am using (usual server's cpu fan died) I had an firewall add-on script running which somehow determined that dragon.org's ip was used in some sort of "attack" against our home network. Not too sure if that even happened - am not accusing anybody here, just stating that the script I use determined after scanning the logs that the ip given to bzflag.dragon.org was envolved in something related to winNT_port1029 (the script stated the winnt part as the "exploit") and then it inserted that ip into hosts.deny
The same server that hosts the website also does all of the DNS for dragon.org, and few dozen other domains. The logs you sent showed my port 80 responding to a request to your port 1029, which means that is the port your web browser decided to use for the outgoing connection. Your script is probably not intelligent enough to tell the difference, and took this as an attack.

The problem really does look like your setup and firewall misconfiguration. I get about 40,000 hits a day on that machine over a handful of web servers, and haven't gotten a single complaint.

I feel your pain, though. I hate when I can't get to stuff no matter what the problem.

-Cameron (Nidhoggr)

P.S. Sorry I haven't been on the board for a few days. I have a lot of stuff going on at work, and I was on call the last 2 weeks.
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

Post by Defman »

I have no idea why it happens to me - but no matter what version of linux I use, that port 53 issue seems to always get me. Maybe I am installing named, bind or a DNS server (all the same right?) by mistake and actually do not need it, thus all that stuff in my logs.

Thanks for taking the time to check things out and welcome back Nidhoggr!
oblomov
Private First Class
Private First Class
Posts: 86
Joined: Fri Sep 19, 2003 8:10 am

Re: Help Please!

Post by oblomov »

MrApathyCream wrote: If you find that you are on a 1.9 server with no one else around, i'd ask that you try out Roger, the new AutoPilot.

start up bzflag like

bzflag -solo 3

(to add 3 robots, or however many you and your network connection likes)

and then hit the '9' key to engage Roger.

Roger is a more human-like robot that is similar to a newbie human. He uses flags, he dodges bullets, he jumps on buildings, and yes, he jumps too much to avoid shots. But he can usually pound a group of old robots. Sit back and enjoy the show.
Roger is a great advancement. I tried it today against a bunch of bots in Rabbit Hunt style. It's averagely smarter than the bots, so I would actually like to have the bots using Roger internally --would make for a more challenging AI.

There are a couple of "deficiencies" in Roger as currently impelemented, though, which i would like to point out:

* crashes into buildings a little too often, and gets stuck there; not very good topology detection, it seems.

* tends to keep flags when it would be smarter to drop them: example, a Thief flag when facing a shooter is useless. A machine gun when you managed to walk up behind somebody but are a little too far would better be dropped.

Can these two be fixed? Would it be possible to have an option to have Roger-controlled bots?
Post Reply