Add BZFlag to the available program list on Ubuntu

Make suggestions for improving one of the best games on the net!
Post Reply
User avatar
Mozul
Private First Class
Private First Class
Posts: 9
Joined: Wed Jan 21, 2004 11:50 pm
Location: Redondo Beach, CA, USA
Contact:

Add BZFlag to the available program list on Ubuntu

Post by Mozul » Mon Apr 02, 2007 7:31 pm

I just installed the latest Ubuntu release 6.10. I know that lots of the BZFLag guys are into Ubuntu, but when I went to the add programs list there was no BZFlag in the list. I was surprised. Thus my suggestion is, do what is needed to get BZFlag into this list of programs that can be easily installed into Ubuntu. It will add to the BZFlag community and thus make BZFlag better.

Thanks,

Kirk (Mozul, Sportchick's Husband)

User avatar
L4m3r
Hater of Everything
Hater of Everything
Posts: 724
Joined: Tue Feb 08, 2005 5:15 am
Location: Los Angeles

Post by L4m3r » Mon Apr 02, 2007 7:57 pm

I see BZFlag in the package list for Edgy... not sure about other versions. Can you still get it via apt-get?

I have no idea who maintains the list, unless you're talking about the actual package list. We've had the debian packages forever, and afaik there have been ubuntu packages ever since that distro became popular, also.
Optimism is just a milder alternative to denial.

User avatar
macsforme
General
General
Posts: 2033
Joined: Wed Mar 01, 2006 5:43 am

Post by macsforme » Mon Apr 02, 2007 8:00 pm

I believe that BZFlag is listed in the "Universal" repository in Ubuntu, which (as I understand it) contains programs for Ubuntu that are available but are compiled by third parties. Due to the nature of BZFlag and the way Ubuntu organizes its packages, I'm not sure that there's an easy workaround. :-(

User avatar
too much loving
Private First Class
Private First Class
Posts: 94
Joined: Sun May 23, 2004 7:47 pm
Location: Denmark
Contact:

Post by too much loving » Mon Apr 02, 2007 9:01 pm

If you just want to fix your own problem then you can add a menu entry it by hand
System -> preferences -> Menu Layout

EDIT: I didn't read the question properly before answering. Here is a better answer: You have to uncomment a line in the file named /etc/apt/sources.list.

I am fairly sure that you need to uncomment the line named universe. If that doesn't help, then you have to uncomment one of the other lines. You can also use some menu to do the same
https://help.ubuntu.com/ubuntu/desktopg ... ories.html

Post Reply