problems hosting 1.9.3 server

Place for people to discuss public servers, and also for admins to lay out the details of their servers
Post Reply
Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

problems hosting 1.9.3 server

Post by Defman » Sun Sep 21, 2003 1:29 pm

Has anything changed since 1.7g2?

Am attempting to use the Field and Stream map (possibly cannot use old maps?) and did notice that apparently we need to specify which interface to use (-i)

Here is the output when I run bzfs;

[steve@ampster bzflag]$ ./FieldandStream
using speed autokick tolerance of "15.000000"
require UDP clients!
using password file "bzdb"
style: 1ce
super flags allowed
rogues allowed
jumping allowed
shakable bad flags: timeout=3.000000, wins=1
antidote flags
listening on 24.118.179.107:5155

here is the script:

bzfs -d -d -d -d > /var/shared/shared/Linux/bzflag/server/logs/`date +%Y_%m-%d_%S`.log +f A +f A +f CL +f CL +f F +f F +f GM +f GM +f GM +f GM +f GM +f ID +f ID +f ID +f L +f ST +f ST +f ST +f ST +f SB +f SB +f ST +f OO +f OO +f OO +f T +f
ID +f SR +f SR +f SR +f SR +f ST +f ST +f ST +f SW +f T +f T +f V +f R +f R +f R +f V +f V +f SE +f SE +f SE +f BU +f BU +f BU -f PZ -f G -f JP -admsg "practice server" -badwords swearlist.txt -fb -j -i 24.118.179.107 -lagdrop 5 -lagwarn 400 -maxidle 900 -mo 1 -mp 2,3,3,0,0 -ms 7 -speedtol 15 -synctime -p 5155 -passwd
<not-posting-that-here> -r -requireudp +s 15 -s 15 -sa -st 3 -sw 1 -ttl 32 -tkkr 25 -sl SB 50 -sl GM 25 -sl ST 30 -passdb bzdb -public "Field and Stream" -publicaddr "24.118.179.107:5155" -srvmsg "practice server"

(hehe, just went and read the log created)

log:

Bad word filter specified without -filterChat or -filterCallsigns
There is a voting arbiter with the following settings:
vote time is 60 seconds
veto time is 20 seconds
votes required are 3
vote percentage necessary is 50.099998
vote repeat time is 300 seconds
Opening List Server 0
ADD 24.118.179.107:5155 1.9.3.20030919-ALPHA linux-gnu BZFS1903 01ce0009000700000000000000000000000200030003000000000001001e000000000000 Field and Stream

Closing List server 0
Opening List Server 0
REMOVE 24.118.179.107:5155

Closing List server 0

I had -world at the end specifying Field and Stream.bzw but removed that just to see if I could get anything to show up in the server listing. Is it possible we need to specify -publiclist <list-server-url>?

Also, is there someplace I can go to to find out what exactly some of the new bzfs options mean/are looking for when used?

P.S., I realize too that this script appears to be missing another option when using -passdb...I did not make it that far when creating a bunch of scripts awhile back. Some have both options needed when attempting to use the /register thing - and some don't LOL

Tanks
Defman

User avatar
SGI
Private First Class
Private First Class
Posts: 513
Joined: Mon Dec 09, 2002 7:24 pm
Location: Motown, MI, USA

Post by SGI » Sun Sep 21, 2003 4:32 pm

I dont know where is your error but I can give this shortcut for flags:
+f GM{*} +f L{*} +f ST{*}
*= numbers of flag 2~2000000000000
And you missing the world file or -c and -cr(CTF)
Windows:
-world maps/mapcontest/CTF/newtonsctf.bzw

unix
-world "/usr/games/bzflag/megadome.bzw"

-badwords config/mm/badwords.txt

-reportfile /config/mm/reportfile.txt

-passdb config/mm/pass.db

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Sun Sep 21, 2003 5:08 pm

maps should load fine, the format was not changed, just added too. The maps may behave difrently ( pyramids ), but they will load.

you don't need requireUDP

verify that you can get to the IP that the list server doc points to (http://bzflag.org/list-server.txt)

User avatar
larsl
Dev Monkey
Dev Monkey
Posts: 50
Joined: Tue May 20, 2003 2:35 pm
Location: Stockholm
Contact:

Post by larsl » Sun Sep 21, 2003 5:17 pm

This is a bug that has been fixed in CVS. The line

ADD 24.118.179.107:5155 1.9.3.20030919-ALPHA linux-gnu BZFS1903

is what your server sends to the list server as a request to be added to the list. The list server expects the format

ADD <ADDRESS> <VERSION> <PROTOCOL>

with no spaces in any of the fields. In the version you are using there is unfortunately a space in the <VERSION> field, so bzfls thinks that the protocol is "linux-gnu", which isn't a valid protocol name, so the server won't get listed.

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Sun Sep 21, 2003 5:39 pm

we'll get a 1.9.4 made on monday for everyone.

User avatar
Chestal
Dev Guru
Dev Guru
Posts: 171
Joined: Fri Dec 06, 2002 11:56 pm
Location: Siegen, Germany
Contact:

Re: problems hosting 1.9.3 server

Post by Chestal » Sun Sep 21, 2003 8:19 pm

Defman wrote: +f A +f A +f CL +f CL +f F +f F +f GM +f GM +f GM +f GM +f GM +f ID +f ID +f ID +f L +f ST +f ST +f ST +f ST +f SB +f SB +f ST +f OO +f OO +f OO +f T +f
ID +f SR +f SR +f SR +f SR +f ST +f ST +f ST +f SW +f T +f T +f V +f R +f R +f R +f V +f V +f SE +f SE +f SE +f BU +f BU +f BU -f PZ -f G -f JP
Btw., you can use +f GM{5} syntax for multipel flags of the same type. Depending on your shell, you'l have to put that into quotes.

Defman
Private First Class
Private First Class
Posts: 162
Joined: Thu Dec 05, 2002 4:06 am

Re: problems hosting 1.9.3 server

Post by Defman » Sun Sep 21, 2003 8:42 pm

Chestal wrote: Btw., you can use +f GM{5} syntax for multipel flags of the same type. Depending on your shell, you'l have to put that into quotes.
Thanks SGI & Chestal,
have made those changes, just waiting on 1.9.4 to make sure it works. No errors are being reported, just can't play on the server...then again suppose I could test it on the lan.

Patlabor,
I was wondering if I needed requireUDP anymore - took that out. Tanks!

not too sure if this is a bug or what, on bryjen's server just now, he had Decks loaded for a map, and we were seeing shots rico into the floor - and not coming back up. Was odd.

As for the paths you mentioned SGI, I have all those files in the same directory as the scripts used to launch bzfs...is that a wise thing to do? Or does anybody recommend sorting them out into separate directories?

later
Def

User avatar
SGI
Private First Class
Private First Class
Posts: 513
Joined: Mon Dec 09, 2002 7:24 pm
Location: Motown, MI, USA

Post by SGI » Sun Sep 21, 2003 11:16 pm

Thanks SGI & Chestal,
have made those changes, just waiting on 1.9.4 to make sure it works. No errors are being reported, just can't play on the server...then again suppose I could test it on the lan.
....what !!!!!!!!!!!!!!Thanks Chestal too, no way.....He stoled the prize.....Thank you SGI 1st place, and stop,nada, NOTHING ....
Thank Chestal but SGI already help me out about the flags.......
:)
As for the paths you mentioned SGI, I have all those files in the same directory as the scripts used to launch bzfs...is that a wise thing to do? Or does anybody recommend sorting them out into separate directories?
No ........if you have all in the same directory.
normaly I have a separate directory when i have a different server settings.

CTF or FFA etc etc
And dont tell me anymore thanks.....Im happy to help you out.
Fix your server and have fun

Post Reply