Problems in public list

Place for people to discuss public servers, and also for admins to lay out the details of their servers
Post Reply
User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Problems in public list

Post by 666 » Wed Dec 01, 2004 7:24 pm

Well... i've tried all i can remenber só i think it's because of the FW.

I use Kerio in XP and the windows version of bzfs 1.10.8.
the output of the server is:
require UDP clients!
style: bb
capture the flag
super flags allowed
jumping allowed
inertia: 0.000000, 5.000000
all shots ricochet
antidote flags
style: bb
capture the flag
super flags allowed
jumping allowed
inertia: 0.000000, 5.000000
all shots ricochet
antidote flags
Loading C:\BZFlag\configs\multilingualSwearList(1.19).txt
...............
Loaded 1446 words
There is a voting arbiter with the following settings:
vote time is 60 seconds
veto time is 10 seconds
votes required are 3
vote percentage necessary is 50.099998
vote repeat time is 300 seconds
available voters is initially set to 23
Running a public server with the following settings:
public address is monet.no-ip.info
listening on 0.0.0.0:5154
with title of "PORTUGAL ONLY (TwoCastlesByViper)"
Warning: bad teleporter link dropped from=24 to=0
Warning: bad teleporter link dropped from=25 to=0
Warning: bad teleporter link dropped from=26 to=0
Warning: bad teleporter link dropped from=27 to=0
Warning: bad teleporter link dropped from=28 to=0
Warning: bad teleporter link dropped from=29 to=0
Sent ADD message to list server
GET /db/?action=ADD&nameport=monet.no-ip.info&version=BZFS1910&gameinfo=00bb0005
00000000000000000000140000000a0000000a00000003&build=1.10.8.20041005-RELEASE-W32
VC71&title=PORTUGAL+ONLY+%28TwoCastlesByViper%29 HTTP/1.1
Host: list.bzflag.bz
Cache-Control: no-cache
The essencial of the conf file:
#Require UDP
-requireudp

#Public description for the server
-public "PORTUGAL ONLY (TwoCastlesByViper)"

#Initial port clients connect on
-p 5154

#Public network address for the server
-publicaddr monet.no-ip.info

#Server Message displayed when player joins
-srvmsg "Netcabo, pessoal: paciencia..."

#Lag Warning threshold time [ms]
-lagwarn 1000

#Drop player after this many lag warnings
-lagdrop 3

#Idle Kick Threshold [s]
-maxidle 60

#Team killer to wins percentage (1-100) above which player is kicked
-tkkr 5

#Bad Words filter file specification
-badwords C:\BZFlag\configs\multilingualSwearList(1.19).txt

#Message that is broadcast every 15 minutes
-admsg "n.inacio@netcabo.pt"
Its true that mi FW is permiting only Portuguese IPs to the server but I have an exception for:
bzflag.secretplace.us/any ports/any protocols

Do I need more?
What ports does it use?
What is wrong?

PS: if it helps I´ll post the full config.

THX
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

User avatar
Scorch
Private First Class
Private First Class
Posts: 747
Joined: Thu Sep 30, 2004 12:16 am
Contact:

Re: Problems in public list

Post by Scorch » Wed Dec 01, 2004 8:04 pm

666 wrote:
Running a public server with the following settings:
public address is monet.no-ip.info
listening on 0.0.0.0:5154
with title of "PORTUGAL ONLY (TwoCastlesByViper)"
AND

666 wrote:
#Initial port clients connect on
-p 5154

#Public network address for the server
-publicaddr monet.no-ip.info
It should be #Public network address for the server
-publicaddr monet.no-ip.info:PORT

in your case

#Public network address for the server
-publicaddr monet.no-ip.info:5154

that happened to me too. I think that in the next release it should automaticly put :PORT at the end.

User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Post by 666 » Wed Dec 01, 2004 8:15 pm

Infortunatly... "been there, done that"

Someone told me the same thing and I have tried also.

-publicaddr monet.no-ip.info:5154 and -p 5154 options.
just -publicaddr monet.no-ip.info:5154 without -p 5154 option
tried also with diferent port... (5157, 5159, etc)

but thx for the tip Scorch ;)

Thoes someone know of a bug in the windows version???? :?
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

User avatar
Scorch
Private First Class
Private First Class
Posts: 747
Joined: Thu Sep 30, 2004 12:16 am
Contact:

Post by Scorch » Wed Dec 01, 2004 8:17 pm

are you behind a firewall?

User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Post by 666 » Wed Dec 01, 2004 8:21 pm

Yup: Kerio Personal Firewall

But as I posted before, I've opened all OUTs and I'm monitoring all INs.

OUTs I see bzflag.secretplace.us ports 38xx and 80
INs... it's a mystery, but I presume that the server got some reply because of the output (chek out carefully).
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Wed Dec 01, 2004 9:37 pm

the list server will atempt a login to your server to verify that you are open. You will need to allow it login on your port before it will list you. I do not see the conenctback happening in your output.

This prevents unreachable servers from being listed.

I've run public servers on windows with no problems many a time.

User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Post by 666 » Thu Dec 02, 2004 4:50 pm

THX Patlabor221.
And can you give me some details on that?

i.e. what did tou left open in the FW, ports or IPs and/or FW tipe/name used.
Can you checked out in your FW logs or someting like that so we can compare and I could see where is my problem?

I reached the moment where I recognize that I can't solve it alone or without comparisons...

Nevertheless in the output whe it as :
Sent ADD message to list server
GET /db/?action=ADD&nameport=monet.no-ip.info&version=BZFS1910&gameinfo=00bb0005
00000000000000000000140000000a0000000a00000003&build=1.10.8.20041005-RELEASE-W32
VC71&title=PORTUGAL+ONLY+%28TwoCastlesByViper%29 HTTP/1.1
Host: list.bzflag.bz
Cache-Control: no-cache
Means that it received a answear from the server otherwise it will go:
Sent ADD message to list server....
and nothing else.

You are right as I only see something like OUT local port 33xx, remote IP 69.28.129.167(bzflag.secretplace.us) port 80.
No record of INs for system, bzfs.exe app or any other (as I am monitoring).
Perhaps someone in Linux as that information somewhere.

Other thing I just remember is that I'm running NT version of Squid (that i carefully disabled) but I think that my ISP (netcabo - cablemodem) may have a transparent proxy that they neither recognize or acknowlage as this as ben a complain of some clients.

I would prefer to dismiss the problem at my end 1st before taking that path.
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Post by 666 » Thu Dec 02, 2004 9:51 pm

Well... I've tried with the FW completly disabled... :cry:
This rules that one out...

A question:

When we see the local sever on the list should the public version appear also/instead of ?
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Fri Dec 03, 2004 12:45 am

you will see a message that a client has conencted. Your not seeing that so that is why you are not listed.

You'll probably want to check all incoming trafic and make sure you get a conenction attempt from the list server.

User avatar
666
Private First Class
Private First Class
Posts: 11
Joined: Wed Nov 10, 2004 8:20 pm

Post by 666 » Fri Dec 03, 2004 12:56 am

Patlabor221 wrote:You'll probably want to check all incoming trafic and make sure you get a conenction attempt from the list server.
Done that already: nothing
Patlabor221 wrote:make sure you get a conenction attempt from the list server.
How do I do that?
It seems that I've already run out of options...
Is there any other way of cheking that?

I've checked with the "IRC bot" and come back positive: it works, but still no listing...

THX Patlabor221
"You see things; and you say, 'Why?'
But I dream things that never were; and I say, 'Why not?'
"

"Back to Methuselah" (1921), part 1, act 1
George Bernard Shaw, Irish dramatist & socialist (1856 - 1950)

Post Reply