Page 1 of 2

not on the server list

Posted: Thu Mar 16, 2006 12:57 am
by tw1sted
for some reason, im not on the server list when i use my ip ( any help?

Posted: Thu Mar 16, 2006 1:55 am
by ducatiwannabe
Make sure your ports

-p 5155 (as an example)

are set up right. Also make sure you opened your port to allow things to get through from your firewall/router/whatever.

Make sure your IP is up to date.

-public "message"

those are some things.

Posted: Thu Mar 16, 2006 12:20 pm
by tw1sted
still doesnt work so i thinks its the router or firewall.

Posted: Thu Mar 16, 2006 1:10 pm
by Blazing King
the same thing happened to me when i tried to make one. it hase something to do with your router/firewall. try acessing it and making a hole it it

Posted: Thu Mar 16, 2006 1:23 pm
by ducatiwannabe
Open port 5154 (if that's the port you're using) all the way and things should get through.

Posted: Thu Mar 16, 2006 2:55 pm
by person1
What type of router do you have?

All the routers that I have come in contact with have a default IP on you local intranet of then you can login to the router.

You may already know this.

Posted: Thu Mar 16, 2006 11:47 pm
by Inferno
He said he doesn't know the password or the yeh. I've talked to him already about this.

Posted: Fri Mar 17, 2006 2:16 am
by tw1sted
yea inferno helped me befor and i dont know the name of the top of my head... (im not on my main comp, im on my laptop and have a broken ankle and dont feel like geting up and looking)...

Posted: Fri Mar 17, 2006 3:22 am
by person1
ok so basically you can't do anything right? Unless you know how to reset your router. Some (maybe I am mistaked) have this feature.

Posted: Fri Mar 17, 2006 6:20 am
by JPT
is -publicaddr your.ip:5155 in your configuration file ?

Posted: Fri Mar 17, 2006 11:44 am
by tw1sted
yea everything is in

Posted: Fri Mar 17, 2006 11:51 am
by tw1sted
hmmm. i wonder if i put my ip next to the -publiclist it might work.... because whenever i start the server from cmd it says something about a bad host and my host is my ip.... i think im getting something here even though im probably wrong

Posted: Fri Mar 17, 2006 11:54 am
by tw1sted
nvm doesnt work i still get bad host

Posted: Fri Mar 17, 2006 12:26 pm
by tw1sted
nooooooooooooooooooooooooooooooooo i just acidentally unistaled bzflag and all my files are gone!!!!!!!!!!!!!!!!!! :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :( :(

Posted: Fri Mar 17, 2006 1:10 pm
by JPT
That is the best solution to every problem with BZFlag ! ;)
Congratulations !

Posted: Fri Mar 17, 2006 5:31 pm
by tw1sted
how is that a good thing?

Posted: Fri Mar 17, 2006 6:13 pm
by tw1sted
ahhhhh ok w/e but its a bad way to fix stuff

Posted: Fri Mar 17, 2006 7:02 pm
by Inferno
Look for what type of router you have, and we may be able to help. Also look for a reset button on the back, I know mine has one :wink:

The reason it's not on the server list is because the bzflag list server tries to connect to the server before listing, and I'm SURE it can not. When you run the server add -ddd/-dddd and it will report any connection attempts and stuff incase of error, but in this case I doubt it's an error.

You need to get the router set up.

Posted: Fri Mar 17, 2006 7:12 pm
by tw1sted
thats what ive heard... i need to get my router set up and i have a........ (one sec let me check)......................................... ................................................. ................................. ok i have a barricade g router by: smc network i believe

Posted: Fri Mar 17, 2006 7:23 pm
by Inferno
How do I RESET the router?
You will have to use a paper clip or a similar pointed object to do the reset procedure.

Hard reset: Insert the paper clip to the reset button and hold it down for 15 seconds, while the paper clip is still in unplug the power cord that goes in to the router, now wait for 15 more seconds and then give the power supply back to the router, again wait for 15 more seconds and finally let the clip go. You will see the router's LEDs flashing. If this happens it means that we have successfully completed the reset.

Soft reset: Login to the router, go to the Tools menu, click on configuration tools and select the option restore router to factory defaults to reset the router.

What are the possible default passwords for the router?
The password would be blank/admin/smcadmin by default. Blank password implies that you need to click on login without giving any input.

But, if you have set a password on your own and not able to recollect it, try resetting the router.

How do I open ports in the Virtual Server?
You need to forward the ports used by the application to the server running the application in the Virtual Server, which is present in the router's management screen, as follows.

1. Open your web browser, type in the router's IP address (standard: '') and press enter.
2. Click on Login, Advanced Setup, NAT, Virtual Server.
3. Enter the port details and enable it as follows:

Private IP Private Port Type Public Port
192.168.2.x xxx TCP xxx
192.168.2.x xxx UDP xxx

Posted: Fri Mar 17, 2006 7:27 pm
by tw1sted
will i loose any info if i reset the router?

Posted: Fri Mar 17, 2006 7:50 pm
by Inferno
Connect to it and see if you can "save configuration" or anything...otherwise I donno.

And before you reset I would suggest trying each default password first:
I think those were all of them.

and notice once youreset you won't have internet to get help anymore so make sure you can setup BEFORE you reset.

print or at least read this page: ... wiredr-a11

How do I Login to the Router?
Open a new browser window and in the address bar type in '' or '' or '' and press enter.

Posted: Fri Mar 17, 2006 8:23 pm
by tw1sted
i dont feel like looseing anything and the passes dont work.

Posted: Fri Mar 17, 2006 8:39 pm
by Inferno
huh, if your going to set up that server, your going to have to reset. The only thing to loose is, well, configurations on your router, which I doubt you even have unique configurations anyway :?

Posted: Fri Mar 17, 2006 8:47 pm
by tw1sted
naa ill just wait for my host to be ready.... im impatient so i wanted to try myself...... again