Brightness doesn't work in 2.4.8 on Antergos Linux

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
G67P
Private
Private
Posts: 3
Joined: Sat Sep 12, 2015 12:33 pm

Brightness doesn't work in 2.4.8 on Antergos Linux

Post by G67P » Sun Feb 26, 2017 2:32 pm

Had an issues with other distros when I set the brightness level within the game and exit then start it back up, the brightness doesn't get saved. So I manually go into the config and set it and all works fine. Now that I moved to Antergos Linux (arch based distro) I can't even adjust the brightness level inside the game and when I set it manually in the config it does nothing. Anybody have this issue?
Thanks

G67P
Private
Private
Posts: 3
Joined: Sat Sep 12, 2015 12:33 pm

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by G67P » Thu Mar 23, 2017 3:38 pm

Nobody has had this happen to them?

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5119
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by JeffM » Thu Mar 23, 2017 4:45 pm

Check your video driver, it was probably replaced during your move.

User avatar
kaadmy
Private First Class
Private First Class
Posts: 37
Joined: Wed Oct 28, 2015 5:31 pm

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by kaadmy » Fri Mar 24, 2017 3:57 pm

Have you checked permissions on the config? It might be that you can still edit it manually but not save from BZFlag.

User avatar
blast
General
General
Posts: 4590
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by blast » Fri Mar 24, 2017 6:14 pm

It's very possible that the brightness control may not work with certain drivers, or it may differ in support between SDL1 and SDL2. Could you let us know what specific GPU and driver you are using, and whether you're using SDL or SDL2? The client version string should say -SDL or -SDL2 at the end to indicate the SDL version.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
kaadmy
Private First Class
Private First Class
Posts: 37
Joined: Wed Oct 28, 2015 5:31 pm

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by kaadmy » Sat Mar 25, 2017 5:21 pm

Hm, I just noticed I'm having the same issue on Arch Linux.when I close BZFlag, the gamma is reset to 1.018268 in the config.

User avatar
Bullet Catcher
Captain
Captain
Posts: 535
Joined: Sat Dec 23, 2006 7:56 am
Location: Escondido, California

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Post by Bullet Catcher » Sat Mar 25, 2017 5:58 pm

My understanding of this problem is hazy but I think this gamma problem was introduced in Fedora Linux by the fix to https://bugzilla.redhat.com/show_bug.cgi?id=891973 . Basically, the ability to read the actual current gamma setting was lost and instead BZFlag reads the default setting (e.g., 1.018268). Other Linux distros with SDL are apparently affected, too.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest