Map-Making Texture Bug

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
PlasticTank
Private First Class
Private First Class
Posts: 53
Joined: Sat Nov 22, 2008 5:45 pm

Map-Making Texture Bug

Post by PlasticTank » Mon Feb 23, 2009 9:26 pm

I'm working on new map, and just started experimenting with textures. In texturing, i found this very annoying bug! Maybe some of you can help me find a solution for it.

The Scenario

I have a base, and a meshbox side by side, and level. If i texture the meshbox, i can't move onto the box from the base, I get stuck right on the edge of the meshbox. I have to jump over the edge to get onto the meshbox. If I take away the texture, everything is fine. I have tried using a regular box, and applying a material, but nothing works. This is not good, since my map will be very difficult to play. Does anyone have any ideas for fixing it? Has it happened to anyone else?

-PT

User avatar
blast
General
General
Posts: 4741
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Map-Making Texture Bug

Post by blast » Mon Feb 23, 2009 9:38 pm

There are known collision detection bugs like that when moving from mesh objects to old-style objects. There's probably workarounds for it, like lowering the base height just a bit, but then you'll probably be stuck trying to get out of the base.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Re: Map-Making Texture Bug

Post by Spazzy McGee » Mon Feb 23, 2009 10:01 pm

This has plagued map makers ever since 2.0 came out. I think it maybe fixed in 2.99...? It affects transition between ALL 2.x and 1.x objects, not just bases. Including transitions between teleporters on old style and mesh objects. And the ground counts as an old-style object.

As far as I know, there is no good workaround for mesh-base transitions, but for teles you can put a thin strip of box beneath the tele.
"Life is what happens to you while you're busy making other plans." - John Lennon

trepan
Dev Wizard
Dev Wizard
Posts: 704
Joined: Fri Feb 21, 2003 7:50 pm

Re: Map-Making Texture Bug

Post by trepan » Mon Feb 23, 2009 10:12 pm

I have a fix, but it has not been applied to SVN.

User avatar
PlasticTank
Private First Class
Private First Class
Posts: 53
Joined: Sat Nov 22, 2008 5:45 pm

Re: Map-Making Texture Bug

Post by PlasticTank » Mon Feb 23, 2009 10:18 pm

Thanks for your clarification, I'm working on way to mod my map, to fix this bug.

Post Reply