2.4.0 "cannot load texture" errors

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
FiringSquad
Sergeant
Sergeant
Posts: 847
Joined: Thu Jan 26, 2006 5:53 pm
Location: Ireland

2.4.0 "cannot load texture" errors

Post by FiringSquad » Tue Jul 26, 2011 3:39 pm

I downloaded the 2.4.0 version from SourceForge.
Running on a Mac
System Version: Mac OS X 10.5.8 (9L31a)
Kernel Version: Darwin 9.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal

Model Identifier: Macmini3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
I'm getting thousands of "cannot load texture: threads", "cannot load texture: shot_tail", etc. in the "misc" tab.
Any ideas what might be wrong?
And, more importantly, how to fix it?

User avatar
blast
General
General
Posts: 4791
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: 2.4.0 "cannot load texture" errors

Post by blast » Tue Jul 26, 2011 8:11 pm

Open your config file for 2.4 and remove the 'set directory' line if it exists.

If that doesn't help, then you have likely done a 'make install' with a previous version of BZFlag. If you still have the source for the old version, you can use 'sudo make uninstall' to remove the files, or you can manually remove /usr/local/share/bzflag/
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
FiringSquad
Sergeant
Sergeant
Posts: 847
Joined: Thu Jan 26, 2006 5:53 pm
Location: Ireland

Re: 2.4.0 "cannot load texture" errors

Post by FiringSquad » Wed Jul 27, 2011 12:36 pm

Deleting the "/usr/local/share/bzflag/" folder did the trick.
Thx.

Post Reply