Page 1 of 1

Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Sun Feb 26, 2017 2:32 pm
by G67P
Had an issues with other distros when I set the brightness level within the game and exit then start it back up, the brightness doesn't get saved. So I manually go into the config and set it and all works fine. Now that I moved to Antergos Linux (arch based distro) I can't even adjust the brightness level inside the game and when I set it manually in the config it does nothing. Anybody have this issue?
Thanks

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Thu Mar 23, 2017 3:38 pm
by G67P
Nobody has had this happen to them?

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Thu Mar 23, 2017 4:45 pm
by JeffM
Check your video driver, it was probably replaced during your move.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Fri Mar 24, 2017 3:57 pm
by kaadmy
Have you checked permissions on the config? It might be that you can still edit it manually but not save from BZFlag.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Fri Mar 24, 2017 6:14 pm
by blast
It's very possible that the brightness control may not work with certain drivers, or it may differ in support between SDL1 and SDL2. Could you let us know what specific GPU and driver you are using, and whether you're using SDL or SDL2? The client version string should say -SDL or -SDL2 at the end to indicate the SDL version.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Sat Mar 25, 2017 5:21 pm
by kaadmy
Hm, I just noticed I'm having the same issue on Arch Linux.when I close BZFlag, the gamma is reset to 1.018268 in the config.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Sat Mar 25, 2017 5:58 pm
by Bullet Catcher
My understanding of this problem is hazy but I think this gamma problem was introduced in Fedora Linux by the fix to https://bugzilla.redhat.com/show_bug.cgi?id=891973 . Basically, the ability to read the actual current gamma setting was lost and instead BZFlag reads the default setting (e.g., 1.018268). Other Linux distros with SDL are apparently affected, too.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Mon Dec 04, 2017 9:55 pm
by G67P
I've been having same issue on a few distro's. Some would work if I edit config manually but Arch base distro's don't work at all. Weird.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Fri Dec 15, 2017 10:45 pm
by G67P
Ok. So i found why brightness can't be adjusted in BZFlag. I've been pulling out what little hair I have left on my head with this issue. I've jumped from distro to distro and finally figured it out. It's an NVidia setting called "Force Full Composition" option. If you have this checked you will not be able to adjust brightness. Even if I manually set the config setting "Gamma", it still doesn't work until I uncheck that option.

Re: Brightness doesn't work in 2.4.8 on Antergos Linux

Posted: Sat Dec 16, 2017 1:17 am
by blast
Thanks. That's a good find. Well done hunting that down. I don't, at the moment, have a Linux system with an nVidia card. I'll have to set one up soon to see if I can figure out why that's happening.

What video card model and nVidia driver version are you experiencing the issue with?