Page 1 of 1

No! Global Authentication is Broken!

Posted: Thu Jun 16, 2005 2:50 am
by 0_0_0
BZFlag/BZAdmin cvs are URLEncoding my callsign!
This results in a bad token, and so there is no authentication.

I get:
ERROR: NOTOK invalid callsign or password (0%5F0%5F0%5F:<pass here>)

This is really bad, as now I cant log in anywhere.

Posted: Thu Jun 16, 2005 3:54 am
by JeffM
this is why we do not recomend people using symbols in there names. it all HAS to be URL encoded, because the list server is just a web page. It is more then likely due to the upgrade to apache 2 that broke it.

Untill it's looked at and fixed, I would change your name to something that dosn't have special characters in it.

Posted: Thu Jun 16, 2005 4:13 am
by 0_0_0
My callsign worked the minute before I updated cvs...
Ah, well.
I guess there are the concequences of cvs... :(

Posted: Thu Jun 16, 2005 4:34 am
by 0_0_0
I just tried 2.0.2 stable, and login worked perfectly! :shock:
It must be a cvs problem, unless the new version # uses a diff database... :?

Posted: Thu Jun 16, 2005 4:57 am
by Tupone
I wonder if that work again with CVS last

Posted: Thu Jun 16, 2005 1:06 pm
by 0_0_0
I had a one week old cvs, heard about the new features, and updated.
Then, it didnt work, even names with spaces are broken!
Stable still works tho.
I'll try the new cvs tonight.

Posted: Thu Jun 16, 2005 8:14 pm
by JeffM
CVS is allways changing,

Posted: Fri Jun 17, 2005 2:35 am
by 0_0_0
K, the newest cvs fixed the prob!

Thank goodness its open source...