can't shoot anybody with new CVS version

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
Tux
Private First Class
Private First Class
Posts: 16
Joined: Sun Mar 20, 2005 9:07 am

can't shoot anybody with new CVS version

Post by Tux » Sat Sep 10, 2005 8:16 am

See subject. There should be some compatibility mode for bzflag 2.0.3 to make it work with old servers. This will increase the number of volunteers running the new version.

User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Re: can't shoot anybody with new CVS version

Post by RPG » Sat Sep 10, 2005 2:01 pm

Tux wrote:See subject. There should be some compatibility mode for bzflag 2.0.3 to make it work with old servers. This will increase the number of volunteers running the new version.
2.0.3 works with all 2.0.x servers. Anything that is 2.0.x will work with any other thing that is 2.0.x.

User avatar
optic delusion
Special Forces
Special Forces
Posts: 986
Joined: Sat Sep 25, 2004 2:29 pm
Location: Planet MoFo
Contact:

fourth time

Post by optic delusion » Sat Sep 10, 2005 2:22 pm

I've seen this 4 times now, Player Bier was the first to report it. If you run lagstats, you will see that your lag looks something like this...
Tux 150 +-215459821ms

I don't know what causes it, but I know it's been fixed every time, just by getting another CVS client.

http://my.bzflag.org/bb/viewtopic.php?t=5000&highlight=

Take a look at my Defender game mode concept.

Thinking is not an automatic process. A man can choose to think or to let his mind stagnate, or he can choose actively to turn against his intelligence, to evade his knowledge, to subvert his reason. If he refuses to think, he courts disaster: he cannot with impunity reject his means of perceiving reality.

User avatar
Tux
Private First Class
Private First Class
Posts: 16
Joined: Sun Mar 20, 2005 9:07 am

Post by Tux » Sun Sep 11, 2005 6:35 am

My lagstats looks completely normal (e.g. Silvercat: 200ms). But maybe I should mention that I am running BZFlag on Debian amd64, i.e. LP64. BZFlag is the cvs HEAD.

User avatar
optic delusion
Special Forces
Special Forces
Posts: 986
Joined: Sat Sep 25, 2004 2:29 pm
Location: Planet MoFo
Contact:

Post by optic delusion » Sun Sep 11, 2005 11:11 am

Well, not being able to shoot anybody is one of the symptoms when that lag happens. I suppose I was wrong.
Take a look at my Defender game mode concept.

Thinking is not an automatic process. A man can choose to think or to let his mind stagnate, or he can choose actively to turn against his intelligence, to evade his knowledge, to subvert his reason. If he refuses to think, he courts disaster: he cannot with impunity reject his means of perceiving reality.

User avatar
Tux
Private First Class
Private First Class
Posts: 16
Joined: Sun Mar 20, 2005 9:07 am

Heeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeelp

Post by Tux » Thu Oct 13, 2005 8:44 pm

I still can't shoot anybody, not even with the current 2.0.5 version on CVS. This is _very_ annoying. What's going on here? Is amd64 (Debian) not supported? Too difficult? How can I help?

User avatar
hans
Private
Private
Posts: 1
Joined: Fri Feb 25, 2005 7:35 pm

problems with amd64 builds

Post by hans » Wed Nov 16, 2005 7:14 pm

for problems with amd64 builds i found the following workaround at sourceforge.net
build the source (or put it in debian/rules) with

./configure CFLAGS="-m64" CXXFLAGS="-m64" CPPFLAGS="-m64"

works perfect !!!

:)

User avatar
Tux
Private First Class
Private First Class
Posts: 16
Joined: Sun Mar 20, 2005 9:07 am

Problem found

Post by Tux » Sun Nov 20, 2005 6:04 pm

The problem occurs only for gcc 4.x. Using gcc 3.4.4 to build bzflag the problem is gone.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests