Page 1 of 1

BZFlag 2.0.4-rc2 for Windows unusable for me

Posted: Fri Sep 23, 2005 10:31 pm
by J_Rey
I have been using BZFlag 2.0.2 for a while on my computer with only one minor problem. My computer specs:
Celeron 466
integrated i810 with shared video memory (Intel 82810-DC100)
64MB RAM
Windows 98 SE
latest (6.7) video drivers
DirectX 9.0c

The only problem that I experienced with 2.0.2 was that after a good 30+ minutes, at least, BZFlag sometimes abruptly quit. Not often enough to be a big problem.

Now, I uninstalled 2.0.2. Then I installed 2.0.4 rc2 and it gave me plenty of weird display & other problems. So, I went looking around and manually deleted all the files in the My BZFlag Files directory. Started new version again, works for a little bit, then it locks up. Tried for over an hour to track down the specific problems with little results. Tried a myriad of "Options," also.

Here's the only things that seem to occur regularly:
  • Immediately, after a settings reset (clearing out My BZFlag Files directory), I can join a game, start playing for a very short time and then either BZFlag or Windows will lock up (stop responding). Possibly sparked when either I or someone else gets blown up. May be the same as this bug (BTW, jjr16 is me).
  • After changing some Options and trying to spawn after joining a game/server, I get lots of display problems. I still hear sounds, but it seems like I can't control my tank. I've sent a message to everyone (M) before and kinda saw it on the screen after sending it, but that's about all I've done, except for Leave Game or End Task. Seems to be the same as someone else's post in the 2.0.4 rc1 annnouncement, although they're using Linux. Will attach screen shot to help explain what I see.
  • Both at once and maybe something(s) I forgot.
Either way, I'm done testing it by myself. Helpful suggestions accepted, though. Thanks.

Posted: Sat Sep 24, 2005 1:53 am
by khazhyk
wha' the? that is really weird :?