libcurl not detected even though it is on my system

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
slugkilla
Private First Class
Private First Class
Posts: 20
Joined: Mon Aug 15, 2005 7:32 pm

libcurl not detected even though it is on my system

Post by slugkilla » Wed Jan 04, 2006 2:03 am

Hello,
I just switched from fedora to Ubuntu linux. I am trying to compile bzflag and the server stuff but the ./configure file does not find libcurl. Any ideas?
checking for curl >= 7.10.0... ./configure: line 19763: curl-config: command not found
FAILED
configure: WARNING: curl-config was not found
configure: error: libcurl is required. You must install it. See http://curl.haxx.se/

User avatar
Hannibal
Private First Class
Private First Class
Posts: 1073
Joined: Mon May 02, 2005 10:27 pm
Contact:

Post by Hannibal » Wed Jan 04, 2006 4:11 am

try re-installing it. does it give an option to specify where libcurl is?
Games don't make people violent, lag does.
ImageImage

User avatar
slugkilla
Private First Class
Private First Class
Posts: 20
Joined: Mon Aug 15, 2005 7:32 pm

Post by slugkilla » Wed Jan 04, 2006 7:32 pm

Thanks for your reply,
Reintalling did not help. I think it could have something to do with the ./autogen.sh thing becuase originally I had to install each autoconf thing one by one untill it stoped yelling at me. here is what autogen.sh does now.
Found GNU Autoconf version 2.59
Found GNU Automake version 1.9.0
Found GNU Libtool version 1.5.6

Automatically preparing build ... Warning: autoreconf failed
Attempting to run the configuration steps individually

Preparing build ...
Restarting the configuration steps with a local libtool.m4
Found GNU Autoconf version 2.59
Found GNU Automake version 1.9.0
Found GNU Libtool version 1.5.6

Automatically preparing build ... done

The BZFlag build system is now prepared. To build here, run:
./configure
make
Am I missing something?

User avatar
slugkilla
Private First Class
Private First Class
Posts: 20
Joined: Mon Aug 15, 2005 7:32 pm

Post by slugkilla » Wed Jan 04, 2006 8:00 pm

wow ubuntu has like 2 jillion ways to install something and tons of versions. I just found a libcurl with headers and dev stuff. so now it passes the curl stuff. ARGH! but theres no SDL curses of client binary! :x

User avatar
DTRemenak
General
General
Posts: 625
Joined: Thu Jan 16, 2003 4:54 am
Location: U.S.
Contact:

Post by DTRemenak » Wed Jan 04, 2006 9:23 pm

You need curl-dev, SDL-dev, and the dev package for whatever opengl you're using (mesa usually). If you want to use bzadmin you'll want ncurses-dev also.

User avatar
slugkilla
Private First Class
Private First Class
Posts: 20
Joined: Mon Aug 15, 2005 7:32 pm

Post by slugkilla » Wed Jan 04, 2006 11:38 pm

Thanks a lot,
I found them on synaptic. Everything works great now.

Post Reply