ECONNRESET/EPIPE problem on really simple map

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
The Purple Panzer
Field Marshal
Field Marshal
Posts: 246
Joined: Tue Sep 23, 2003 8:13 pm
Location: Stonington, CT

ECONNRESET/EPIPE problem on really simple map

Post by The Purple Panzer »

I've got a really simple map, consisting of the following:
size 200
shift 40 -330 0
size 75.0 22.22 15.0
rotation 0
and it seems to run OK in the BZFlag version 2.0.5b5 bzfs; but when I try to connect to the server (from a client on the same machine) the client rapidly exits, and in the server log I have a message saying ECONNRESET/EPIPE.

I tried to google this error, but found nothing substantive. I thought maybe the existence of a concise example might help. (BTW, I don't know how to post this on the appropriate Sourceforge bugs list, but perhaps it ought to be there.)

Some further background: the above map text is from a larger map I'm working on, which suddenly (last night, about 10:30 PM) started to show this behavior (the client dying with the ECONNRESET/EPIPE message in the server log). Up to that point the map had been fine, indeed the block created by the above had worked reliably for some time. I backed out my incremental edits, and still had the behavior; finally, this morning I rebooted to make sure I had no odd hanging state, and systematically started removing big chunks of my map file, until I got down to the above.

So it's not just odd behavior, but odd behavior that just began last night, in what *was* reliable map text. Perhaps this won't be reproduceable on another machine, in which case there is some very strange persistent state (that survives server, client, and machine restarts) which causes it.
(And no, when it failed there was pretty much nothing else running which could explain this; I'd been working on a map for a few hours, doing incremental testing.)
Post Reply