Shots go through tanks in ubuntu , cant shoot people

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
1veedo
Private First Class
Private First Class
Posts: 184
Joined: Sat Feb 05, 2005 1:26 am
Location: usa

Shots go through tanks in ubuntu , cant shoot people

Post by 1veedo » Sat May 27, 2006 4:30 am

I swear all my shots go through people. I havn't killed a single person w/ 2.0.8 nor the cvs. People say I'm not shooting, so I guess it's not registering on the server or something. Bots dont even evade shots -- they let them go right through!

I havn't been playing bzflag recently so the version jumped from 2.0.4 to 2.0.8. I understand why 2.0.4 cant kill people but honestly the CVS shouldn't be broken?

Code: Select all

 bzflag -v
BZFlag client 2.0.9.20060526-DEVEL-linux-gnu-SDL (protocol 0026) http://BZFlag.org/
Copyright (c) 1993 - 2006 Tim Riker
curl is 7.14.0-2

I dont know what else to say. BZFlag doesn't shoot people. I'm about to steal 2.0.6 from the archlinux repository.
1veedo (libcurl.so.2) I have version 3!

User avatar
Tropican8
Private First Class
Private First Class
Posts: 312
Joined: Fri Mar 18, 2005 11:51 pm
Location: As close to the grove as you can get

Post by Tropican8 » Sat May 27, 2006 3:08 pm

I have no idea what packaging system Arch uses, but mixing repositories doesn't seem like a good idea.

Anyway did you completely remove the previous version before installing this one? (If you installed them to the same place)

(I assume you already know that the version of BZFlag Debian and Ubuntu ships with is a bad compile, and that's why you are trying CVS.)

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5173
Joined: Fri Dec 13, 2002 4:11 am
Location: https://discord.gg/NN9uAvx
Contact:

Post by JeffM » Sat May 27, 2006 4:12 pm

actualy there are patches on SF on how to fix it. it's a problem with how the floats are packed. We are looking at them an applying them to the code.

they are simple fixes.

1veedo
Private First Class
Private First Class
Posts: 184
Joined: Sat Feb 05, 2005 1:26 am
Location: usa

Post by 1veedo » Fri Jun 23, 2006 6:34 pm

BZFlag's now 2.0.8 on gentoo and it runs from chroot, except no sound, but I'm sure I can fix that. Emerge normally gets everything down pretty well, w/ automatic patches and everything.

edit--
yep, forgot to mount dev. /me bangs head. Now it works.
1veedo (libcurl.so.2) I have version 3!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest