Does this game work better on older hardware?

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
PhilKenSebben
Private
Private
Posts: 4
Joined: Sat Jun 17, 2006 10:09 am

Does this game work better on older hardware?

Post by PhilKenSebben » Sat Jun 17, 2006 10:21 am

This game is addictive as hell and it doesnt play well on my powerbook G4 1.67ghz with os x 10.4.6 and 128mb v-ram and a gig of ram. but it gets really hit (140 degrees) when playing this game, and i can only run it in low detail. However, on my 1.42 ghz g4 mac mini with 32mb of v-ram and 512ram it runs perfectly in high detail. it doesn't get hot either. any ideas?

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Post by Spazzy McGee » Sat Jun 17, 2006 12:32 pm

that's odd. i'm sure your powerbook shouldn't be getting that hot. and that's dangerously hot. when it gets that hot you should shut it down and leave it somewhere to cool, preferably bottom faced up.

i have an iBook G4 1.33, and i play bz on almost full graphics and it takes a good couple of hours to hit 70º.

try aclosing any other apps you have running. and if its still getting super-hot contact apple. that dosn't seem right.
"Life is what happens to you while you're busy making other plans." - John Lennon

PhilKenSebben
Private
Private
Posts: 4
Joined: Sat Jun 17, 2006 10:09 am

Post by PhilKenSebben » Sat Jun 17, 2006 7:34 pm

That's what ive been doing, it only happens when i play a game though. im probably going to get it looked at. thanks

User avatar
Think_Different
Private First Class
Private First Class
Posts: 108
Joined: Thu Jan 05, 2006 3:03 am
Location: Washington, DC

Post by Think_Different » Sat Jun 17, 2006 7:40 pm

i own a powerbook g4 12", 1.5Ghz, with 768mb ram and 64mb Vram,and am on os10.4
and i must say, this is an odd issue, i'd try updating the graphics driver,and possibly updating all system software. i've never had this problem, but my powerbook does often get to 140 degrees while playing bz. this is probbly because the powerbooks dont have the best vent system and also the aluminum case absorbs all of the heat.

PhilKenSebben
Private
Private
Posts: 4
Joined: Sat Jun 17, 2006 10:09 am

Post by PhilKenSebben » Sat Jun 17, 2006 7:48 pm

everything is completely up to date. so it is not that.

User avatar
Spazzy McGee
Sergeant Major
Sergeant Major
Posts: 1403
Joined: Mon Mar 21, 2005 4:59 pm
Location: Planet MoFo, Sheffield Division; United Kingdom
Contact:

Post by Spazzy McGee » Sat Jun 17, 2006 8:12 pm

is there some problem with the cooling system. the thermometer in the machine tells it to tun on/off the fans depending on the battery and heat. try changing your battery options to "lower performance, better battery" even if you have power plugged in, it will reduce the number of calculations the CPU does per second therefore reducing heat given off.

are your fans working? obviously laptops don't have as good cooling systems as towers and desktops do.
"Life is what happens to you while you're busy making other plans." - John Lennon

PhilKenSebben
Private
Private
Posts: 4
Joined: Sat Jun 17, 2006 10:09 am

Post by PhilKenSebben » Sat Jun 17, 2006 8:16 pm

That is a good idea, i had everything turned up.

User avatar
joevano
General
General
Posts: 1863
Joined: Sat Jun 18, 2005 1:08 pm
Location: South Bend, Indiana, USA

Post by joevano » Sat Jun 17, 2006 11:15 pm

Isn't the "Energy Saver" (in Display Options in BZ) option supposed to limit fram rate to 30FPS. The heat is most likely coming from your video chip, and limiting FPS should make it so that it doesn't have to work as hard. That should decrease heat build up. Of course I am a Windows guy, but video between Apple and Windows can't be that different. Also, anything over 30FPS is pretty much gravy, your eye can't really tell (although I am sure I could find people to argue that). I would try that also...

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Sat Jun 17, 2006 11:23 pm

donny_baker wrote:Isn't the "Energy Saver" (in Display Options in BZ) option supposed to limit fram rate to 30FPS. The heat is most likely coming from your video chip, and limiting FPS should make it so that it doesn't have to work as hard. That should decrease heat build up. Of course I am a Windows guy, but video between Apple and Windows can't be that different. Also, anything over 30FPS is pretty much gravy, your eye can't really tell (although I am sure I could find people to argue that). I would try that also...
Once you turn it on you must do (in-game):

Code: Select all

/localset fpsLimit x
Where x is the number of FPS you want to limit it too. I have mine set to 60 (yes, I do notice a difference) and keeps my iMac quiet and cool. :D
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

Post Reply