BZFlag 2.0.10 Release Candidate 3

News and info about current and upcoming releases of the game client and server.
ts
Dev Monkey
Dev Monkey
Posts: 970
Joined: Fri Jan 14, 2005 6:26 pm

Post by ts » Thu Oct 18, 2007 8:54 pm

My current compiles of v2_0branch are having an odd bug. In very rare occasions my client freezes after shooting one bullet for about 2 seconds, the outgoing bullet is huge in the HUD, I can not drive, sound stops and one other player told me a shot was going through my tank. However after the 2 seconds the client "resumes" and it then plays perfectly smooth.

It happened for example at longdon.guleague.org:5158 meaning no special flags and ctf mode. My client is using some mods but nothing that should cause this behaviour. Platform is Mac OS X 10.4.10 PPC. I thought just to drop a note here.

Anyone else having that problem, too?
GU league: http://www.guleague.org/
An introduction to TCP: http://www.lafkon.net/tc/

angryfirelord
Private First Class
Private First Class
Posts: 23
Joined: Fri Dec 15, 2006 12:29 am

Post by angryfirelord » Sat Oct 20, 2007 3:30 am

No issues here, in fact, I generated an amd64 deb package using checkinstall and that works really nice.
My current compiles of v2_0branch are having an odd bug. In very rare occasions my client freezes after shooting one bullet for about 2 seconds, the outgoing bullet is huge in the HUD, I can not drive, sound stops and one other player told me a shot was going through my tank. However after the 2 seconds the client "resumes" and it then plays perfectly smooth.

It happened for example at longdon.guleague.org:5158 meaning no special flags and ctf mode. My client is using some mods but nothing that should cause this behaviour. Platform is Mac OS X 10.4.10 PPC. I thought just to drop a note here.

Anyone else having that problem, too?
Did you get anything weird when you compiled it? It sounds like a compiler problem not meeting some requirement or a network issue (whether it be on the client side or the server side).

anomaly
Private First Class
Private First Class
Posts: 220
Joined: Tue Jul 26, 2005 10:32 pm
Location: Gainesville Florida

Post by anomaly » Sat Oct 20, 2007 11:51 am

That happened to me after I svn updated a while ago. 2.0.9, I think. I ended up deleting my entire bzflag directory and got the latest v2_0branch again. Recompiled and it worked fine. :?

Long freezes after firing a shot. SW was even worse. Has not happened since. Platform is Fedora 7 on P4, intel 865 video (yeah, I know...)

Enigma
Private First Class
Private First Class
Posts: 211
Joined: Sat Apr 23, 2005 3:13 am

Post by Enigma » Fri Oct 26, 2007 8:30 pm

The Mac 10.4 build does not work on Mac OS 10.5, nor do the sources configure, but both the 2.0.8 build and the 2.0.10 build for Mac OS 10.3 work.

Here is some output from configure that is a problem for me:

Code: Select all

./configure --enable-shared --enable-plugins LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include"
.........

checking for working ncurses... no
checking for working curses... no
checking for working PDcurses... no
checking for working XCurses... no
configure: WARNING: could not find a curses library, will build bzadmin without curses
checking for SDL framework... no
checking for sdl-config... no
checking for SDL - version >= 1.2.5... no
*** The sdl-config script installed by SDL could not be found
*** If SDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SDL_CONFIG environment variable to the
*** full path to sdl-config.
configure: WARNING: could not find an appropriate SDL version. BZflag will build without SDL
checking for SDL_image library... no
configure: WARNING: Client build has been requested, but GL is not fully available (missing gl.h)
     ... disabling client generation

I have SDL, SDL_Image, ncurses, and I have gl.h.

User avatar
I_Died_Once
Special Forces
Special Forces
Posts: 635
Joined: Sun Nov 28, 2004 5:27 pm
Location: The Dark Side
Contact:

Post by I_Died_Once » Fri Oct 26, 2007 11:49 pm

Enigma wrote:I have SDL, SDL_Image, ncurses, and I have gl.h.
Make sure you have the dev packages installed too
...This has been a recording.

Enigma
Private First Class
Private First Class
Posts: 211
Joined: Sat Apr 23, 2005 3:13 am

Post by Enigma » Sat Oct 27, 2007 1:48 am

I_Died_Once wrote:
Enigma wrote:I have SDL, SDL_Image, ncurses, and I have gl.h.
Make sure you have the dev packages installed too
I feel like this is one of those "there's your sign" moments, since I posted output from configure; aren't tools such as autoconf, libtool, libtoolize, and automake installed with the dev tools? Thus, the configure output implies that I have the dev tools.

At any rate, you are only trying to help, and your help is greatly appreciated. It would have been both funny and embarrassing if I forgot to install the dev tools, but they are installed.


Here are some packages that I have installed with macports, which shows that I do have ncurses:

Code: Select all

$ port installed
The following ports are currently installed:
  apr @1.2.11_0+darwin_9 (active)
  apr-util @1.2.10_0 (active)
  db44 @4.4.20_1 (active)
  expat @2.0.1_0 (active)
  gettext @0.16.1_0 (active)
  glew @1.3.4_0 (active)
  libiconv @1.11_6 (active)
  ncurses @5.6_0 (active)
  ncursesw @5.6_0 (active)
  neon @0.26.4_0 (active)
  openssl @0.9.8g_0 (active)
  readline @5.2.007_0+darwin_9 (active)
  sqlite3 @3.5.1_0 (active)
  subversion @1.4.5_0 (active)
  zlib @1.2.3_1 (active)

All of the packages are installed in /opt, and configure found glew but ignored ncurses for some reason.

User avatar
blast
General
General
Posts: 4726
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Sat Oct 27, 2007 2:06 am

Enigma wrote:
I_Died_Once wrote:
Enigma wrote:I have SDL, SDL_Image, ncurses, and I have gl.h.
Make sure you have the dev packages installed too
I feel like this is one of those "there's your sign" moments, since I posted output from configure; aren't tools such as autoconf, libtool, libtoolize, and automake installed with the dev tools? Thus, the configure output implies that I have the dev tools.

At any rate, you are only trying to help, and your help is greatly appreciated. It would have been both funny and embarrassing if I forgot to install the dev tools, but they are installed.


Here are some packages that I have installed with macports, which shows that I do have ncurses:

Code: Select all

$ port installed
The following ports are currently installed:
  apr @1.2.11_0+darwin_9 (active)
  apr-util @1.2.10_0 (active)
  db44 @4.4.20_1 (active)
  expat @2.0.1_0 (active)
  gettext @0.16.1_0 (active)
  glew @1.3.4_0 (active)
  libiconv @1.11_6 (active)
  ncurses @5.6_0 (active)
  ncursesw @5.6_0 (active)
  neon @0.26.4_0 (active)
  openssl @0.9.8g_0 (active)
  readline @5.2.007_0+darwin_9 (active)
  sqlite3 @3.5.1_0 (active)
  subversion @1.4.5_0 (active)
  zlib @1.2.3_1 (active)

All of the packages are installed in /opt, and configure found glew but ignored ncurses for some reason.
He was referring to the dev packages for SDL, thus the reason he quoted that specific part of your post. :P If you can't run 'sdl-config' from a terminal, then your SDL isn't installed properly, and that would be the first thing to fix.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

ts
Dev Monkey
Dev Monkey
Posts: 970
Joined: Fri Jan 14, 2005 6:26 pm

Post by ts » Sat Oct 27, 2007 9:18 am

Enigma wrote:I feel like this is one of those "there's your sign" moments, since I posted output from configure; aren't tools such as autoconf, libtool, libtoolize, and automake installed with the dev tools? Thus, the configure output implies that I have the dev tools.

At any rate, you are only trying to help, and your help is greatly appreciated. It would have been both funny and embarrassing if I forgot to install the dev tools, but they are installed.
Umm....gcc, gdb etc are dev tools, too but SDL has runtime libraries and development libs, too.

So when you tried to compile you installed "dev tools" I suppose you mean gcc, gdb etc but not SDL-dev.

Please install SDL-dev.
GU league: http://www.guleague.org/
An introduction to TCP: http://www.lafkon.net/tc/

SpedyRF
Private First Class
Private First Class
Posts: 22
Joined: Thu Jul 07, 2005 6:25 pm
Location: In a cramped picklejar

Post by SpedyRF » Sat Nov 10, 2007 7:12 pm

0_o sometimes I get NEGATIVE lag reading when I use lagstats. Is this supposed to happen?

Edit: 0_o When a SW is fired, it still shows the little "muzzel flash"
Cop @ cruel's
Cop @ ahs3's
Cop @ *shadow*'s

User avatar
styrofoam1994
Private First Class
Private First Class
Posts: 13
Joined: Sat Nov 10, 2007 12:48 am

Compatibility

Post by styrofoam1994 » Wed Dec 26, 2007 1:54 am

Is bzflag 2.0.10 RC3 fully (or adequately) compatible with Mac OS X Leopard Intel? I tried it but it hangs for a long time ("fantmap silenced" message or something like that). It also has problems connecting with the list server. :? :? :? :?
answer this

User avatar
macsforme
General
General
Posts: 2017
Joined: Wed Mar 01, 2006 5:43 am

Re: Compatibility

Post by macsforme » Wed Dec 26, 2007 11:49 pm

styrofoam1994 wrote:Is bzflag 2.0.10 RC3 fully (or adequately) compatible with Mac OS X Leopard Intel? I tried it but it hangs for a long time ("fantmap silenced" message or something like that). It also has problems connecting with the list server. :? :? :? :?
Are you using the posted Mac build, or one you built yourself?

We will hopefully be posting a mac build of the final 2.0.10 release soon, so we want to be sure to get all the bugs ironed out. The current build that's on its way toward a release was built the same way as the 2.0.10RC3 build, so if it's having problems then we'll definitely want to know about it.

Thanks.

User avatar
styrofoam1994
Private First Class
Private First Class
Posts: 13
Joined: Sat Nov 10, 2007 12:48 am

Re: Compatibility

Post by styrofoam1994 » Thu Dec 27, 2007 4:29 pm

Constitution wrote:
styrofoam1994 wrote:Is bzflag 2.0.10 RC3 fully (or adequately) compatible with Mac OS X Leopard Intel? I tried it but it hangs for a long time ("fantmap silenced" message or something like that). It also has problems connecting with the list server. :? :? :? :?
Are you using the posted Mac build, or one you built yourself?

We will hopefully be posting a mac build of the final 2.0.10 release soon, so we want to be sure to get all the bugs ironed out. The current build that's on its way toward a release was built the same way as the 2.0.10RC3 build, so if it's having problems then we'll definitely want to know about it.

Thanks.
I used the v2.0.10 RC3, which doesn't exist in the wiki anymore.
answer this

User avatar
macsforme
General
General
Posts: 2017
Joined: Wed Mar 01, 2006 5:43 am

Re: Compatibility

Post by macsforme » Thu Dec 27, 2007 9:03 pm

styrofoam1994 wrote:I used the v2.0.10 RC3, which doesn't exist in the wiki anymore.
Not sure what that means, as far as building yourself or using a pre-built binary; but please try this build, and let us know if you're having the same problem.

Enigma
Private First Class
Private First Class
Posts: 211
Joined: Sat Apr 23, 2005 3:13 am

Post by Enigma » Sat Dec 29, 2007 7:19 am

I may have found a small bug. My client has frozen twice today while driving with someone who has SW. The player will fire a bunch of SW's, and just before the other guy dies, the client freezes. It was the exact same scenario both times. Here is a screenshot:
Attachments
Picture1.png
(445.32 KiB) Downloaded 283 times

User avatar
ducktape
Private First Class
Private First Class
Posts: 1206
Joined: Sat Jul 01, 2006 2:06 am
Location: Right Behind you!
Contact:

Post by ducktape » Sat Dec 29, 2007 7:59 am

Any ideas when the ubuntu/Debian packages will be released?
Image

User avatar
macsforme
General
General
Posts: 2017
Joined: Wed Mar 01, 2006 5:43 am

Post by macsforme » Sat Dec 29, 2007 9:48 pm

Enigma wrote:I may have found a small bug. My client has frozen twice today while driving with someone who has SW. The player will fire a bunch of SW's, and just before the other guy dies, the client freezes. It was the exact same scenario both times. Here is a screenshot:
Can you provide us with a backtrace?

User avatar
styrofoam1994
Private First Class
Private First Class
Posts: 13
Joined: Sat Nov 10, 2007 12:48 am

Mac OS X Leopard

Post by styrofoam1994 » Mon Dec 31, 2007 10:08 pm

How come none of the bzflag v2s don't work on Mac OS X 10.5 leopard????? Also can you give me compilation instructions for Mac and Bzflag 2.0.10 from source? thankx
answer this

User avatar
macsforme
General
General
Posts: 2017
Joined: Wed Mar 01, 2006 5:43 am

Re: Mac OS X Leopard

Post by macsforme » Mon Dec 31, 2007 10:54 pm

styrofoam1994 wrote:How come none of the bzflag v2s don't work on Mac OS X 10.5 leopard????? Also can you give me compilation instructions for Mac and Bzflag 2.0.10 from source? thankx
As leopard is fairly new, the devs might be limited in just how much help they can provide at first. However, the README.MacOSX file in the source (which I believe just points you back to the regular readme) should take care of your needs.

User avatar
styrofoam1994
Private First Class
Private First Class
Posts: 13
Joined: Sat Nov 10, 2007 12:48 am

how to compile?

Post by styrofoam1994 » Sun Jan 13, 2008 9:11 pm

I tried compiling from the source, but it didn't work on my Mac Leopard. Can somebody give me detailed instructions on how to compile properly and successfully?
answer this

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest