2.0.3b9 Mac OSX Test build

News and info about current and upcoming releases of the game client and server.
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5172
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

2.0.3b9 Mac OSX Test build

Post by JeffM » Wed Jul 06, 2005 4:45 am

I have made an OS X test build under 10.4 ( tiger ).

I would like any mac users who care to test it out.

http://my.bzflag.org/builds/2.0.x/BZFlag2.0.3b9.dmg

thanks.
Last edited by JeffM on Wed Jul 06, 2005 4:27 pm, edited 1 time in total.

User avatar
netochka nezvanova
Private First Class
Private First Class
Posts: 116
Joined: Wed Jan 19, 2005 4:58 pm
Location: NL

Post by netochka nezvanova » Wed Jul 06, 2005 6:38 am

did short run

np here

667 dvi tibook 10.4.1 768 mb ram

:)
Image

User avatar
netochka nezvanova
Private First Class
Private First Class
Posts: 116
Joined: Wed Jan 19, 2005 4:58 pm
Location: NL

Post by netochka nezvanova » Wed Jul 06, 2005 7:08 am

don't like the new icon
Image

User avatar
netochka nezvanova
Private First Class
Private First Class
Posts: 116
Joined: Wed Jan 19, 2005 4:58 pm
Location: NL

Post by netochka nezvanova » Wed Jul 06, 2005 7:35 am

got strange white pipes on screen when i shoot outside of the playing area
is this normal?

http://www.xs4all.nl/~mjvj/link/bzfi0001.jpg
Image

Guest

Post by Guest » Wed Jul 06, 2005 8:48 am

10.34?
10.4 is tiger. SO I presume you mean that.
If so, it's ONLY for tiger, right?

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5172
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Post by JeffM » Wed Jul 06, 2005 4:28 pm

CannonBallGuy
not nesisarlay, that is why I want you to test it. I don't have a 10.3 system anymore :)

netochka nezvanova
yes that is normal ( a known issue ). It shoudl be fixed before final release.

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

What about...

Post by A Meteorite » Wed Jul 06, 2005 4:37 pm

Can I get a bzfs and bzadmin version? I would like to use this for my server, but I can't unless I get all three... :roll: Or is there a way I can do this through CVS? I heard that the -r argument allows me to specify a date. Either way is fine, I just like to get my paws on all of it. :D
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5172
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Post by JeffM » Wed Jul 06, 2005 4:40 pm

bzfs and bzadmin should be in the .app I built the full thing.

just right click to open it

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Wed Jul 06, 2005 4:41 pm

Ah, ok. Totally forgot about how the binarys did it. :lol-old: What about CVS, have you heard about the -r argument?
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

Guest

Post by Guest » Wed Jul 06, 2005 4:48 pm

JeffM2501 wrote:CannonBallGuy
not nesisarlay, that is why I want you to test it. I don't have a 10.3 system anymore :)
Heh. Sounds like you'r complaining...?
Downloading now. Will post results later.

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Wed Jul 06, 2005 4:58 pm

Testing now...

Guest

Post by Guest » Wed Jul 06, 2005 5:02 pm

It's broke.
Nothing... Nada. Zilch.

It kinda "opens up", but the desktop stays there.

if I try to open the "BZFlag.app/Contents/MacOS/bzflag" in Terminal, I get this:

Code: Select all

/Users/Me---/Desktop/BZFlag.app/Contents/MacOS/bzflag        
dyld: /Users/Me---/Desktop/BZFlag.app/Contents/MacOS/bzflag can't open library: /usr/X11R6/lib/libGLU.1.dylib  (No such file or directory, errno = 2)
Trace/BPT trap

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Wed Jul 06, 2005 5:13 pm

Same here... only I used Crash Reporter:

Code: Select all

dyld: /Volumes/BZFlag2.0.3b9/BZFlag.app/Contents/MacOS/BZFlag can't open library: /usr/X11R6/lib/libGLU.1.dylib  (No such file or directory, errno = 2)
why are you using X11?

I can give you XII reasons not to use it!


Anyway, I searched with terminal for this GLU library and couldn't find it...
(lib, bin, and X11R6 doesn't exist)

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5172
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Post by JeffM » Wed Jul 06, 2005 5:19 pm

dude ease up. this is just a test build to see if I could even make mac binarys.

it's not suposed to use X11, we'll have to find out why.

this is the reason I need people TEST it :)

Sir_Pants
Private First Class
Private First Class
Posts: 194
Joined: Mon Mar 28, 2005 2:41 am
Location: SOMEwhere in WA

Post by Sir_Pants » Wed Jul 06, 2005 6:23 pm

yea doesn't work for 10.3, it downloads and the icon is visible but when clicked on it doesn't open
MONKEYPANTS.COM
Image

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Wed Jul 06, 2005 6:27 pm

Very nice on 10.4. :P Works great. I will test more later today.

Oh joy: This is my 100th post! :D
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
netochka nezvanova
Private First Class
Private First Class
Posts: 116
Joined: Wed Jan 19, 2005 4:58 pm
Location: NL

Post by netochka nezvanova » Wed Jul 06, 2005 7:03 pm

still working fine here

i noticed the extra info while being killed. it reports also the type of flag my killer was carring while shooting me . but it's the short code. It would be nicer if there was the full name . Now a blue flag is shorten to "B*"


i do have X11 installed...
Image

User avatar
Kooppers
Private First Class
Private First Class
Posts: 28
Joined: Sat Jan 29, 2005 3:35 pm
Location: everywhere exepted here!

Post by Kooppers » Wed Jul 06, 2005 7:24 pm

I just tested it on my osx 10.4.1 .
All was just working fine for me.
Nothing more to add exepted that the dock image has changed and i have to get used to it , but it's not a bad one ;)

Cheers

User avatar
DTRemenak
General
General
Posts: 625
Joined: Thu Jan 16, 2003 4:54 am
Location: U.S.
Contact:

Post by DTRemenak » Wed Jul 06, 2005 7:31 pm

netochka nezvanova wrote:got strange white pipes on screen when i shoot outside of the playing area
is this normal?
This has been fixed.

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Fri Jul 08, 2005 4:28 am

I'll download the latest X11 for Jaguar and see if it works...


If I had xCode I would fix the problem but don't have it :'(


The GLU library is a graphics layer for OpenGL...

It's looking in the X11 file while it should look in the OpenGL.framework

You devs probably knew this... Just telling the people that "might" want to know :arrow:

User avatar
Saturos
Art Master General
Art Master General
Posts: 1111
Joined: Mon Apr 19, 2004 2:48 pm
Location: Berlin/Germany
Contact:

Post by Saturos » Fri Jul 08, 2005 9:30 am

Sir_Pants wrote:yea doesn't work for 10.3, it downloads and the icon is visible but when clicked on it doesn't open
Same here (on my father's PC).

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Sat Jul 09, 2005 7:24 pm

For some wierd reason I can't find X11 for Jaguar!

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Sat Jul 09, 2005 7:27 pm

BinarySpike wrote:For some wierd reason I can't find X11 for Jaguar!
There used to be one for Panther... I didn't think there was one for Jaguar.
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Sat Jul 09, 2005 7:58 pm

I got one for Jaguer before my computer HD messed up...


Anyway.

Dumbledore said that then latest bzflag version doesn't work on his 10.4



If I could get configure to work I would fix the stupid problem...

Code: Select all

BZFlag-2.0.3.20050709
configure: error: cannot run /bin/sh ./config.sub
And when Dumbledore get's errors with autogen.sh.....


*edit*
Fixed the ./config.sub error

Now it chokes on c-ares

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Sat Jul 09, 2005 10:36 pm

Ok, I tryed to fake out my computer saying that it had the lib...

I tryed my lib...

Code: Select all

dyld: /Users/nathan/Desktop/BZFlag.app/Contents/MacOS/BZFlag version mismatch for library: /usr/X11R6/lib/libGLU.1.dylib (compatibility version of user: 1.3.0 greater than library's version: 1.0.0)

Then I tryed A Meteorites lib

Code: Select all

dyld: /Users/nathan/Desktop/BZFlag.app/Contents/MacOS/BZFlag version mismatch for library: /usr/X11R6/lib/libGLU.1.dylib (compatibility version of user: 1.3.0 greater than library's version: 1.2.0)

I'll wait till sombody fixes this... but I still choke on c-ares.....

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest